If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Previewing a particular email increases CPU usage and memory usage drastically.

VERIFIED DUPLICATE of bug 98626

Status

MailNews Core
Backend
--
critical
VERIFIED DUPLICATE of bug 98626
16 years ago
9 years ago

People

(Reporter: Alex Mathews, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4+) Gecko/20010924
BuildID:    2001092408

When I preview the below email, the CPU usage jumps up and down and memory
consumption increases steadily.  This will continue with either Mozilla crashing
or Linux grinding to a hault because all resources are consumed by Mozilla.  The
email is coming from an Outlook Mail Client.  I have copied the full email from
.mozilla/user/account/Mail/Inbox file.  Nothing suspicious comes out on
stdout/stderr if I execute mozilla from a shell and view this email.





Reproducible: Always
Steps to Reproduce:
View below email:

From - Wed Sep 26 16:24:24 2001
X-UIDL: <NEBBKIMEOLGLKHDPM
FKBKEICCCAA.chmathew@eden.rutgers.edu>
X-Mozilla-Status: 0003
X-Mozilla-Status2: 00000000
Return-Path: <chmathew@eden.rutgers.edu>
Received: from mh9-sfba.mail.home.com ([24.0.95.244])
          by femail8.sdc1.sfba.home.com
          (InterMail vM.4.01.03.20 201-229-121-120-20010223) with ESMTP
          id
<20010926200000.VYYI24287.femail8.sdc1.sfba.home.com@mh9-sfba.mail.home.com>
          for <amathews@mail.union1.nj.home.com>;
          Wed, 26 Sep 2001 13:00:00 -0700
Received: from mx9-sfba.mail.home.com (mx9-sfba.mail.home.com [24.0.95.240])
        by mh9-sfba.mail.home.com (8.9.3/8.9.0) with ESMTP id MAA07068
        for <amathews@home.com>; Wed, 26 Sep 2001 12:59:58 -0700 (PDT)
Received: from eden.rutgers.edu (narnia6.rutgers.edu [165.230.180.176])
        by mx9-sfba.mail.home.com (8.11.1/8.11.1) with ESMTP id f8QJxsl25653
        for <amathews@home.com>; Wed, 26 Sep 2001 12:59:54 -0700 (PDT)
Received: from chmathew (unknown [172.23.1.163])
        by eden.rutgers.edu (Postfix) with SMTP id AC592A3A24
        for <amathews@home.com>; Wed, 26 Sep 2001 15:59:52 -0400 (EDT)
Reply-To: <chmathew@eden.rutgers.edu>
From: "Charles \"Chuck\" Mathews" <chmathew@eden.rutgers.edu>
To: "Alex Mathews" <amathews@home.com>
Subject: Expos situation
Date: Wed, 26 Sep 2001 16:03:30 -0400
Message-ID: <NEBBKIMEOLGLKHDPMFKBKEICCCAA.chmathew@eden.rutgers.edu>
MIME-Version: 1.0
Content-Type: multipart/related;
        boundary="----=_NextPart_000_0000_01C146A4.C9329200"
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook IMO, Build 9.0.2416 (9.0.2910.0)
Importance: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4133.2400

This is a multi-part message in MIME format.

------=_NextPart_000_0000_01C146A4.C9329200
Content-Type: multipart/alternative;
        boundary="----=_NextPart_001_0001_01C146A4.C9329200"


------=_NextPart_001_0001_01C146A4.C9329200
Content-Type: text/plain;
        charset="iso-8859-1"
Content-Transfer-Encoding: 7bit

Blankxxx.  xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx xxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxx

xxxxxxxxx xxxxxxxxx xxxxxxxxxxxxx xxxx xxx

~~~~~~~~~~~~~~~~~~~~~~~~~
xxxxxxxxxx
xxxxxxxxxx
xxxxxxxxxx
xxxxxxxxxx
xxxxxxxxxx
~~~~~~~~~~~~~~~~~~~~~~~~~




------=_NextPart_001_0001_01C146A4.C9329200
Content-Type: text/html;
        charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD><TITLE>Blank</TITLE>
<META http-equiv=3DContent-Type content=3D"text/html; =
charset=3Diso-8859-1">
<STYLE>BODY {
        MARGIN-TOP: 25px; FONT-SIZE: 10pt; MARGIN-LEFT: 25px; COLOR: #000000; =
FONT-FAMILY: Arial, Helvetica
}
P.msoNormal {
        MARGIN-TOP: 0px; FONT-SIZE: 10pt; MARGIN-LEFT: 0px; COLOR: #ffffcc; =
FONT-FAMILY: Helvetica, "Times New Roman"
}
LI.msoNormal {
        MARGIN-TOP: 0px; FONT-SIZE: 10pt; MARGIN-LEFT: 0px; COLOR: #ffffcc; =
FONT-FAMILY: Helvetica, "Times New Roman"
}
</STYLE>

<META content=3D"MSHTML 5.50.4611.1300" name=3DGENERATOR></HEAD>
<BODY background=3Dcid:240200020@26092001-1df8>
<DIV><SPAN class=3D240200020-26092001>xxx.&nbsp; xxxxxxxxxxxxxxxxxxxx =
xxxxxxxxxxxxxx=20
xxxxxxxxxx xxxxxxxxxxxx?&nbsp; xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx =
xx=20
xxxxxxxxxxxxxxxxxxxxxxxx?</SPAN></DIV>
<DIV><SPAN class=3D240200020-26092001></SPAN>&nbsp;</DIV>
<DIV><SPAN class=3D240200020-26092001>xxxxxxxxxxx xxxxxxxxxxxxxxx =
xxxxxxxxxx=20
xxxxxxx.</SPAN></DIV>
<DIV>&nbsp;</DIV>
<DIV>~~~~~~~~~~~~~~~~~~~~~~~~~</DIV>
<DIV>xxxxxxx</DIV>
<DIV>xxxxxxx</DIV>
<DIV>xxxxxxx</DIV>
<DIV><A=20
href=3D"mailto:foo@foo.com">foo@foo.com</A></=
DIV>
<DIV><A =
href=3D"http://www.foo.com/">www.foo.com</A></DIV>
<DIV>~~~~~~~~~~~~~~~~~~~~~~~~~</DIV>
<P>&nbsp;</P></BODY></HTML>

------=_NextPart_001_0001_01C146A4.C9329200--

------=_NextPart_000_0000_01C146A4.C9329200
Content-Type: image/gif;
        name="Blank Bkgrd.gif"
Content-Transfer-Encoding: base64
Content-ID: <240200020@26092001-1df8>

R0lGODlhLQAtAID/AP////f39ywAAAAALQAtAEACcAxup8vtvxKQsFon6d02898pGkgiYoCm6sq2
7iqWcmzOsmeXeA7uPJd5CYdD2g9oPF58ygqz+XhCG9JpJGmlYrPXGlfr/Yo/VW45e7amp2tou/lW
xo/zX513z+Vt+1n/tiX2pxP4NUhy2FM4xtjIUQAAOw==

------=_NextPart_000_0000_01C146A4.C9329200--



Actual Results:  The preview of the email looks fine, but it is plain and not
HTML.  The CPU usage starts to spike up and down and memory resources start
getting sucked up by mozilla.  If I preview another email the problems
disappears, but the memory is never freed up until I exit mozilla.

Comment 1

16 years ago
Reproduced with 2001102808/Win2k.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 2

16 years ago
<BODY background=3Dcid:240200020@26092001-1df8>

This causes the problem. No problem if you change this to "<body>".
(Reporter)

Comment 3

16 years ago
I've confirmed that changing the <BODY> tag to remove the background= does in
fact remove the problem in Linux (Build 2001102414) as well.  That leads me to
believe that the problem stems from the decoding of the embedded image for the
background of the HTML email.
(Reporter)

Comment 4

16 years ago
I have checked whether this problem still exists in Linux Build ID: 2002011614,
and it looks it has been fixed.  I guess a fix for something else has fixed the
issue with decoding a embedded image to be displayed as the background for the
HTML email.  The background now shows up correctly.

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 98626 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.