Closed Bug 1018198 Opened 6 years ago Closed 6 years ago

[hsb] Add Upper Sorbian to shipped-locales in Aurora and Beta

Categories

(Firefox Build System :: General, defect)

31 Branch
defect
Not set

Tracking

(firefox31 verified)

VERIFIED FIXED
mozilla31
Tracking Status
firefox31 --- verified

People

(Reporter: gueroJeff, Assigned: gueroJeff)

Details

Attachments

(1 file)

The Upper Sorbain (hsb) locale is ready to be added to shipped-locales for Aurora and Beta. The attached patch adds the locale for Aurora, but we'd like this to also be ported to Beta. As I do not have commit access, this patch will need to be commited for me please.

As usual, this is not going to land on mozilla-central, as the l10n config there is just for nightly.
Attached patch add-hsb.patchSplinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 985434
User impact if declined: Speakers of Upper Sorbian unable to use Firefox in their language.
Testing completed (on m-c, etc.): m-a
Risk to taking this patch (and alternatives if risky): Very low
String or IDL/UUID changes made by this patch: n/a
Attachment #8431557 - Flags: review?(l10n)
Attachment #8431557 - Flags: approval-mozilla-aurora?
Whiteboard: [checkin-needed-aurora]
Attachment #8431557 - Flags: review?(l10n) → review+
Whiteboard: [checkin-needed-aurora]
Attachment #8431557 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [checkin-needed-aurora]
[checkin-needed-aurora] is useless. Sheriff are tracking approval-mozilla-aurora+
Whiteboard: [checkin-needed-aurora]
I need some concensus and consistency on what the process is for getting a patch checkin when I need it then. I've had IRC conversations with Ryan about it and it seems like every time I need someone to check in a patch on aurora, the process for simply requesting the checkin changes.
Flags: needinfo?(ryanvm)
Sorry if I've contributed to any confusion. The [checkin-needed-aurora] is a bit superfluous, but I won't object to you setting it if it makes you feel better :). I have bug queries that will find these bugs either way, but adding the whiteboard comment might result in them being found a bit sooner.

However, you *ALWAYS* need approval first. Please don't add it to bugs that don't have approval because that does nothing but add noise to my bug queries.
Flags: needinfo?(ryanvm)
Thanks Ryan. I'm going to continue to use the whiteboard. Sorry for jumping the gun there. Just trying to get all needed info in a bug at once instead of increasing the amount of bugmail spam in the world ;-)
https://hg.mozilla.org/releases/mozilla-aurora/rev/9cc143b88287
Assignee: nobody → jbeatty
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Verified that the 'hsb' builds are present on mozilla-aurora-l10n [1] page for both 31 and 32 Aurora versions.
The builds are not available for Nighlty 33 and Beta 31.

[1] http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-aurora-l10n/
Status: RESOLVED → VERIFIED
Keywords: verifyme
Is there expected to be hsb builds for Firefox 31b1? My understanding was that we weren't shipping that locale which seems to contradict *this* bug.
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #8)
> Is there expected to be hsb builds for Firefox 31b1? My understanding was
> that we weren't shipping that locale which seems to contradict *this* bug.

Need-info Sylvestre.
Flags: needinfo?(sledru)
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #8)
> Is there expected to be hsb builds for Firefox 31b1? My understanding was
> that we weren't shipping that locale which seems to contradict *this* bug.

No builds needed for Beta or Mozilla Central. These single locale builds are for testing on Aurora channel only.
Arrg, sorry, ignore my last comment. We *are* taking this for Fx31
We didn't see any bug wrt hsb: we have done a default build. A step has been skipped?
Flags: needinfo?(sledru)
hsb is Beta builds are starting with B2. See bug 1023881 and needinfo-ing Rail for validation.
Flags: needinfo?(rail)
Detailed test results of the localized builds are here:
https://etherpad.mozilla.org/Fx-31b2

In general our testers found that much of the UI is either not translated or translated to German or Polish. As well, many websites serve German content to HSB users (including our own SUMO page). 
We also hit a persistent Mozmill test failure in our Undo Close Tab test, likely due to incomplete locale strings. Bug 1026582 has been filed to investigate further.

I'm not sure if these issues are dealbreakers for shipping this locale to Beta testers and/or Release. My gut tells me this is okay for Beta but not okay for Release. I would like either Release Management or someone from the l10n team to make that call though.
Sorbian is a minority language in the region of Germany boarding Poland. Finding UI content that may closely reflect German or Polish should be expected, but may, in fact, be Sorbian. Web compatibility redirects to German sites is fully expected. Additionally, the issues pertaining to "about" pages may be simply a "push-to-prod" issue on the web parts side.
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 31 → mozilla31
You need to log in before you can comment on or make changes to this bug.