[Flame] OTA updates are failing because PRODUCT_DEVICE does not match "msm8610"

VERIFIED FIXED

Status

Firefox OS
Vendcom
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: tchung, Unassigned)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [POVB])

(Reporter)

Description

4 years ago
When doing an check for updates on Nightly 2.0 OTA, the update server is failing to find the PRODUCT_DEVICE name that matches what the flame is showing.   As a result, no updates are found.

On device: 
localhost:B2G-flash-tool mozilla$ adb shell getprop ro.product.device
msm8610

From Update server link (looking for "/flame" in path)
https://aus4.mozilla.org/update/3/B2G/32.0a1/20140529040201/flame/en-US/nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1


Logcat:
05-30 09:02:46.223: I/Gecko(289): *** AUS:SVC Checker: checkForUpdates, force: true
05-30 09:02:46.223: I/Gecko(289): *** AUS:SVC getLocale - getting locale from file: resource://app/update.locale, locale: en-US
05-30 09:02:46.233: I/Gecko(289): *** AUS:SVC Checker:getUpdateURL - update URL: https://aus4.mozilla.org/update/3/B2G/32.0a1/20140530040207/msm8610/en-US/nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1
05-30 09:02:46.233: I/Gecko(289): *** AUS:SVC gCanCheckForUpdates - able to check for updates
05-30 09:02:46.233: I/Gecko(289): *** AUS:SVC Checker:checkForUpdates - sending request to: https://aus4.mozilla.org/update/3/B2G/32.0a1/20140530040207/msm8610/en-US/nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1
05-30 09:02:46.253: I/Gecko(289): *** AUS:SVC Checker:onError - request.status: 2152398864
05-30 09:02:46.263: I/Gecko(289): *** AUS:SVC getStatusTextFromCode - transfer error: Network is offline (go online), code: 2152398864
05-30 09:02:46.273: I/Gecko(289): *** AUS:SVC Creating UpdateService
05-30 09:02:46.273: I/Gecko(289): *** AUS:SVC UpdateService:onError - error during background update. error code: 111, status text: Network is offline (go online)
05-30 09:02:46.273: I/Gecko(289): *** AUS:SVC UpdateService:_registerOnlineObserver - waiting for the network to be online, then forcing another check
05-30 09:04:38.753: I/Gecko(289): *** AUS:SVC UpdateService:_offlineStatusChanged - network is online, forcing another background check
05-30 09:04:38.753: I/Gecko(289): *** AUS:SVC UpdateService:_attemptResume
05-30 09:04:38.753: I/Gecko(289): *** AUS:SVC Checker: checkForUpdates, force: false
05-30 09:04:38.763: I/Gecko(289): *** AUS:SVC Checker:getUpdateURL - update URL: https://aus4.mozilla.org/update/3/B2G/32.0a1/20140530040207/msm8610/en-US/nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml
05-30 09:04:38.763: I/Gecko(289): *** AUS:SVC Checker:checkForUpdates - sending request to: https://aus4.mozilla.org/update/3/B2G/32.0a1/20140530040207/msm8610/en-US/nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml
05-30 09:04:39.903: I/Gecko(289): *** AUS:SVC Checker:onLoad - request completed downloading document
05-30 09:04:39.903: I/Gecko(289): *** AUS:SVC Checker:onLoad - number of updates available: 0
05-30 09:05:01.713: I/Gecko(289): *** AUS:SVC Checker: checkForUpdates, force: true
05-30 09:05:01.713: I/Gecko(289): *** AUS:SVC Checker:getUpdateURL - update URL: https://aus4.mozilla.org/update/3/B2G/32.0a1/20140530040207/msm8610/en-US/nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1
05-30 09:05:01.723: I/Gecko(289): *** AUS:SVC Checker:checkForUpdates - sending request to: https://aus4.mozilla.org/update/3/B2G/32.0a1/20140530040207/msm8610/en-US/nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1
05-30 09:05:01.953: I/Gecko(289): *** AUS:SVC Checker:onLoad - request completed downloading document
05-30 09:05:01.953: I/Gecko(289): *** AUS:SVC Checker:onLoad - number of updates available: 0

Reported against build from 5/29.  going to revert back to find a regression range since this worked earlier in the week.

Repro:
1) install 2.0 nightly on flame (dated 5/29 nightly)
2) settings > device info > Check for updates
3) Verify no updates found due to error above

Expected:
- find updates for the device and apply it

ActuaL:
- updates not found
(Reporter)

Comment 1

4 years ago
reverted back to a 5/23 build and did OTA update via settings.   it found the update and applied it correctly to 5/30 image (today).

Build from: https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-flame/2014/05/2014-05-23-16-02-04/

05-30 09:43:19.551: I/GeckoUpdater(2154): Progress [ =                                                  ]
05-30 09:43:19.551: I/GeckoUpdater(2154): Progress [ ==                                                 ]
05-30 09:43:19.551: I/GeckoUpdater(2154): Progress [ ===                                                ]
05-30 09:43:19.561: I/GeckoUpdater(2154): Progress [ ====                                               ]
05-30 09:43:19.561: I/GeckoUpdater(2154): Progress [ =====                                              ]
05-30 09:43:19.561: I/GeckoUpdater(2154): Progress [ ======                                             ]
05-30 09:43:19.561: I/GeckoUpdater(2154): Progress [ =======                                            ]
05-30 09:43:19.561: I/GeckoUpdater(2154): Progress [ ========                                           ]
05-30 09:43:19.561: I/GeckoUpdater(2154): Progress [ =========                                          ]
05-30 09:43:19.561: I/GeckoUpdater(2154): Progress [ ==========                                         ]
05-30 09:43:19.561: I/GeckoUpdater(2154): Progress [ ===========                                        ]
05-30 09:43:19.561: I/GeckoUpdater(2154): Progress [ ============                                       ]
05-30 09:43:19.561: I/GeckoUpdater(2154): Progress [ =============                                      ]
05-30 09:43:19.561: I/GeckoUpdater(2154): Progress [ ==============                                     ]
05-30 09:43:19.561: I/GeckoUpdater(2154): Progress [ ===============                                    ]
05-30 09:43:19.561: I/GeckoUpdater(2154): Progress [ ================                                   ]
05-30 09:43:19.561: I/GeckoUpdater(2154): Progress [ =================                                  ]
05-30 09:43:19.581: I/GeckoUpdater(2154): Progress [ ==================                                 ]
05-30 09:43:29.691: I/GeckoUpdater(2154): Progress [ ===================                                ]
05-30 09:43:30.031: I/GeckoUpdater(2154): Progress [ ====================                               ]
05-30 09:43:33.561: I/GeckoUpdater(2154): Progress [ =====================                              ]
05-30 09:43:36.401: I/GeckoUpdater(2154): Progress [ ======================                             ]
05-30 09:43:36.641: I/GeckoUpdater(2154): Progress [ =======================                            ]
05-30 09:43:38.351: I/GeckoUpdater(2154): Progress [ ========================                           ]
05-30 09:43:39.031: I/GeckoUpdater(2154): Progress [ =========================                          ]
05-30 09:43:40.631: I/GeckoUpdater(2154): Progress [ ==========================                         ]
05-30 09:43:40.721: I/GeckoUpdater(2154): Progress [ ===========================                        ]
05-30 09:43:47.801: I/GeckoUpdater(2154): Progress [ ============================                       ]
05-30 09:43:48.251: I/GeckoUpdater(2154): Progress [ =============================                      ]
05-30 09:43:50.221: I/GeckoUpdater(2154): Progress [ ==============================                     ]
05-30 09:43:50.381: I/GeckoUpdater(2154): Progress [ ===============================                    ]
05-30 09:43:50.431: I/GeckoUpdater(2154): Progress [ ================================                   ]
05-30 09:43:51.111: I/GeckoUpdater(2154): Progress [ =================================                  ]
05-30 09:43:52.781: I/GeckoUpdater(2154): Progress [ ==================================                 ]
05-30 09:43:53.811: I/GeckoUpdater(2154): Progress [ ===================================                ]
05-30 09:43:54.531: I/GeckoUpdater(2154): Progress [ ====================================               ]
05-30 09:43:55.091: I/GeckoUpdater(2154): Progress [ =====================================              ]
05-30 09:43:55.511: I/GeckoUpdater(2154): Progress [ ======================================             ]
05-30 09:43:55.691: I/GeckoUpdater(2154): Progress [ =======================================            ]
05-30 09:43:55.691: I/GeckoUpdater(2154): Progress [ ========================================           ]
05-30 09:43:55.701: I/GeckoUpdater(2154): Progress [ =========================================          ]
05-30 09:43:59.921: I/GeckoUpdater(2154): Progress [ ==========================================         ]
05-30 09:44:14.501: I/GeckoUpdater(2154): Progress [ ===========================================        ]
05-30 09:44:15.881: I/GeckoUpdater(2154): Progress [ ============================================       ]
05-30 09:44:16.231: I/GeckoUpdater(2154): Progress [ =============================================      ]
05-30 09:44:16.331: I/GeckoUpdater(2154): Progress [ ==============================================     ]
05-30 09:44:16.381: I/GeckoUpdater(2154): Progress [ ===============================================    ]
05-30 09:44:16.381: I/GeckoUpdater(2154): Progress [ ================================================   ]
05-30 09:44:16.391: I/GeckoUpdater(2154): Progress [ =================================================  ]
05-30 09:44:16.391: I/GeckoUpdater(2154): Progress [ ================================================== ]
05-30 09:44:16.401: I/GeckoUpdater(2154): Finished applying update

From: 
Gaia      e83bd91c8f7c66f95d55cb741299e12bc8f7b429
Gecko     https://hg.mozilla.org/mozilla-central/rev/681c5668d881
BuildID   20140523160204
Version   32.0a1
ro.build.version.incremental=94

To: 
Gaia      26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko     https://hg.mozilla.org/mozilla-central/rev/e6f113c83095
BuildID   20140530040207
Version   32.0a1
ro.build.version.incremental=94

Updated

4 years ago
QA Contact: lmauritson
(In reply to Tony Chung [:tchung] from comment #0)
> When doing an check for updates on Nightly 2.0 OTA, the update server is
> failing to find the PRODUCT_DEVICE name that matches what the flame is
> showing.   As a result, no updates are found.
> 
> On device: 
> localhost:B2G-flash-tool mozilla$ adb shell getprop ro.product.device
> msm8610
> 
> From Update server link (looking for "/flame" in path)
> https://aus4.mozilla.org/update/3/B2G/32.0a1/20140529040201/flame/en-US/
> nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1
> 
> 
> Logcat:
> 05-30 09:02:46.223: I/Gecko(289): *** AUS:SVC Checker: checkForUpdates,
> force: true
> 05-30 09:02:46.223: I/Gecko(289): *** AUS:SVC getLocale - getting locale
> from file: resource://app/update.locale, locale: en-US
> 05-30 09:02:46.233: I/Gecko(289): *** AUS:SVC Checker:getUpdateURL - update
> URL:
> https://aus4.mozilla.org/update/3/B2G/32.0a1/20140530040207/msm8610/en-US/
> nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1
> 05-30 09:02:46.233: I/Gecko(289): *** AUS:SVC gCanCheckForUpdates - able to
> check for updates
> 05-30 09:02:46.233: I/Gecko(289): *** AUS:SVC Checker:checkForUpdates -
> sending request to:
> https://aus4.mozilla.org/update/3/B2G/32.0a1/20140530040207/msm8610/en-US/
> nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1
> 05-30 09:02:46.253: I/Gecko(289): *** AUS:SVC Checker:onError -
> request.status: 2152398864
> 05-30 09:02:46.263: I/Gecko(289): *** AUS:SVC getStatusTextFromCode -
> transfer error: Network is offline (go online), code: 2152398864
> 05-30 09:02:46.273: I/Gecko(289): *** AUS:SVC Creating UpdateService
> 05-30 09:02:46.273: I/Gecko(289): *** AUS:SVC UpdateService:onError - error
> during background update. error code: 111, status text: Network is offline
> (go online)
> 05-30 09:02:46.273: I/Gecko(289): *** AUS:SVC
> UpdateService:_registerOnlineObserver - waiting for the network to be
> online, then forcing another check
> 05-30 09:04:38.753: I/Gecko(289): *** AUS:SVC
> UpdateService:_offlineStatusChanged - network is online, forcing another
> background check
> 05-30 09:04:38.753: I/Gecko(289): *** AUS:SVC UpdateService:_attemptResume
> 05-30 09:04:38.753: I/Gecko(289): *** AUS:SVC Checker: checkForUpdates,
> force: false
> 05-30 09:04:38.763: I/Gecko(289): *** AUS:SVC Checker:getUpdateURL - update
> URL:
> https://aus4.mozilla.org/update/3/B2G/32.0a1/20140530040207/msm8610/en-US/
> nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml
> 05-30 09:04:38.763: I/Gecko(289): *** AUS:SVC Checker:checkForUpdates -
> sending request to:
> https://aus4.mozilla.org/update/3/B2G/32.0a1/20140530040207/msm8610/en-US/
> nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml
> 05-30 09:04:39.903: I/Gecko(289): *** AUS:SVC Checker:onLoad - request
> completed downloading document
> 05-30 09:04:39.903: I/Gecko(289): *** AUS:SVC Checker:onLoad - number of
> updates available: 0
> 05-30 09:05:01.713: I/Gecko(289): *** AUS:SVC Checker: checkForUpdates,
> force: true
> 05-30 09:05:01.713: I/Gecko(289): *** AUS:SVC Checker:getUpdateURL - update
> URL:
> https://aus4.mozilla.org/update/3/B2G/32.0a1/20140530040207/msm8610/en-US/
> nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1
> 05-30 09:05:01.723: I/Gecko(289): *** AUS:SVC Checker:checkForUpdates -
> sending request to:
> https://aus4.mozilla.org/update/3/B2G/32.0a1/20140530040207/msm8610/en-US/
> nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1
> 05-30 09:05:01.953: I/Gecko(289): *** AUS:SVC Checker:onLoad - request
> completed downloading document
> 05-30 09:05:01.953: I/Gecko(289): *** AUS:SVC Checker:onLoad - number of
> updates available: 0
> 
> Reported against build from 5/29.  going to revert back to find a regression
> range since this worked earlier in the week.
> 
> Repro:
> 1) install 2.0 nightly on flame (dated 5/29 nightly)
> 2) settings > device info > Check for updates
> 3) Verify no updates found due to error above
> 
> Expected:
> - find updates for the device and apply it
> 
> ActuaL:
> - updates not found

I'm not sure we should consider this as valid. Your base system defines ro.product.device=msm8610, hence gecko searches for an update with this value. But our sources/build system produces and uses a ro.product.device=flame. So until we fix (and we are working on this) full system images building, this kind of discrepency is expected.

Updated

4 years ago
Keywords: qaurgent, regression
(Reporter)

Comment 3

4 years ago
> I'm not sure we should consider this as valid. Your base system defines
> ro.product.device=msm8610, hence gecko searches for an update with this
> value. But our sources/build system produces and uses a
> ro.product.device=flame. So until we fix (and we are working on this) full
> system images building, this kind of discrepency is expected.

This is why i'm confused.   when i am running a flame pvtbuild from 20140523160204, it says the following:

Gaia      e83bd91c8f7c66f95d55cb741299e12bc8f7b429
Gecko     https://hg.mozilla.org/mozilla-central/rev/681c5668d881
BuildID   20140523160204
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014
ro.product.device  =  msm8610  

1) Then i apply Settings > Check for updates
2) See that: system update available: 63.08 Mb
3) download the update and apply it

Logcat progress:

05-30 10:18:41.849: I/GeckoUpdater(2257): Progress [ =================================================  ]
05-30 10:18:41.849: I/GeckoUpdater(2257): Progress [ ================================================== ]
05-30 10:18:41.849: I/GeckoUpdater(2257): Finished applying update
05-30 10:19:05.569: I/GeckoUpdater(2515): Finished applying update
05-30 10:19:06.039: E/GeckoConsole(2527): Could not read chrome manifest 'file:///system/b2g/chrome.manifest'.
05-30 10:19:06.359: E/GeckoConsole(2527): Native module at path '/system/b2g/distribution/bundles/libqc_b2g_location/libqc_b2g_location.so' is incompatible with this version of Firefox, has version 28, expected 32.
05-30 10:19:06.529: E/GeckoConsole(2527): [JavaScript Warning: "Could not map contract ID '@mozilla.org/gonk-gps-geolocation-provider;1' to CID fdffb9d1-0d61-4384-8993-206609376e73 because no implementation of the CID is registered." {file: "file:///system/b2g/distribution/bundles/libqc_b2g_location/chrome.manifest" line: 2}]
05-30 10:19:06.599: E/GeckoConsole(2527): Native module at path '/system/b2g/distribution/bundles/libqc_b2g_ril/libqc_b2g_ril.so' is incompatible with this version of Firefox, has version 28, expected 32.
05-30 10:19:06.669: E/GeckoConsole(2527): [JavaScript Warning: "Could not map contract ID '@mozilla.org/ril;1' to CID {9A7181E8-E66A-11E1-B4A1-B1066188709B} because no implementation of the CID is registered." {file: "file:///system/b2g/distribution/bundles/libqc_b2g_ril/chrome.manifest" line: 2}]
05-30 10:19:06.669: E/GeckoConsole(2527): [JavaScript Warning: "Could not map contract ID '@mozilla.org/telephony/telephonyprovider;1' to CID {7292B38A-1950-11E3-9E4A-46906188709B} because no implementation of the CID is registered." {file: "file:///system/b2g/distribution/bundles/libqc_b2g_ril/chrome.manifest" line: 3}]
05-30 10:19:07.109: E/GeckoConsole(2527): While creating services from category 'profile-after-change', service for entry 'Pico Speech Synth', contract ID '@mozilla.org/synthpico;1' does not implement nsIObserver.
05-30 10:19:07.389: I/Gecko(2527): *** AUS:SVC Creating UpdateService
05-30 10:19:07.389: E/GeckoConsole(2527): AUS:SVC Creating UpdateService
05-30 10:19:07.389: I/Gecko(2527): *** AUS:SVC gCanCheckForUpdates - able to check for updates
05-30 10:19:07.389: E/GeckoConsole(2527): AUS:SVC gCanCheckForUpdates - able to check for updates
05-30 10:19:07.389: I/Gecko(2527): *** AUS:SVC gCanApplyUpdates - testing write access /data/local/update.test
05-30 10:19:07.389: E/GeckoConsole(2527): AUS:SVC gCanApplyUpdates - testing write access /data/local/update.test
05-30 10:19:07.389: I/Gecko(2527): *** AUS:SVC gCanApplyUpdates - able to apply updates
05-30 10:19:07.389: E/GeckoConsole(2527): AUS:SVC gCanApplyUpdates - able to apply updates
05-30 10:19:07.389: I/Gecko(2527): *** AUS:SVC readStatusFile - status: succeeded, path: /data/local/updates/0/update.status
05-30 10:19:07.389: E/GeckoConsole(2527): AUS:SVC readStatusFile - status: succeeded, path: /data/local/updates/0/update.status
05-30 10:19:07.409: I/Gecko(2527): *** AUS:SVC readStatusFile - status: succeeded, path: /data/local/updates/0/update.status
05-30 10:19:07.409: E/GeckoConsole(2527): AUS:SVC readStatusFile - status: succeeded, path: /data/local/updates/0/update.status
05-30 10:19:07.409: I/Gecko(2527): *** AUS:SVC UpdateManager:get activeUpdate - channel has changed, reloading default preferences to workaround bug 802022
05-30 10:19:07.409: E/GeckoConsole(2527): AUS:SVC UpdateManager:get activeUpdate - channel has changed, reloading default preferences to workaround bug 802022
05-30 10:19:07.479: I/Gecko(2527): *** AUS:SVC getFileFromUpdateLink linkFile.path: /data/local/updates/0/update.link, link: /storage/sdcard0/updates/0/update.mar
05-30 10:19:07.479: E/GeckoConsole(2527): AUS:SVC getFileFromUpdateLink linkFile.path: /data/local/updates/0/update.link, link: /storage/sdcard0/updates/0/update.mar
05-30 10:19:07.749: E/GeckoConsole(2527): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 134}]
05-30 10:19:07.749: E/GeckoConsole(2527): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 134}]
05-30 10:19:07.769: E/GeckoConsole(2527): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 134}]
05-30 10:19:07.769: E/GeckoConsole(2527): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 134}]
05-30 10:19:07.789: E/GeckoConsole(2527): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 134}]
05-30 10:19:07.789: E/GeckoConsole(2527): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 134}]
05-30 10:19:07.809: I/Gecko(2527): *** AUS:SVC cleanUpMozUpdaterDirs - Cleaning MozUpdater folder
05-30 10:19:07.809: E/GeckoConsole(2527): AUS:SVC cleanUpMozUpdaterDirs - Cleaning MozUpdater folder
05-30 10:19:12.639: I/Gecko(2527): Nfc Worker: NFC_NOTIFICATION_INITIALIZED status:0
05-30 10:19:13.159: E/GeckoConsole(2577): Could not read chrome manifest 'file:///system/b2g/chrome.manifest'.

4) After device restarts, verify the build is now on:
Gaia      26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko     https://hg.mozilla.org/mozilla-central/rev/e6f113c83095
BuildID   20140530040207
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014
ro.product.device  =  msm8610
Specifically, bug 918068 changed the update url:
 - from http://update.boot2gecko.org/%CHANNEL%/update.xml
 - to https://aus4.mozilla.org/update/3/%PRODUCT%/%VERSION%/%BUILD_ID%/%PRODUCT_DEVICE%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/update.xml

The %CHANNEL% value was set at build time and thus included the PRODUCT_DEVICE value defined by our sources.

But in the new URL, we use %PRODUCT_DEVICE% which is replaced in nsUpdateService.js by gProductDevice. This value is directly getting the value of the ro.product.device property. Since your device has a base system.img flashed from T2M, then your ro.product.device is msm8610. Our builds have it being flame.

I really don't think this should be considered as a regression.
Depends on: 918068
(In reply to Alexandre LISSY :gerard-majax from comment #4)
> I really don't think this should be considered as a regression.

I'd call this a regression actually from migrating to the new update server setup, since this apparently doesn't work now.

Updated

4 years ago
Keywords: qaurgent, regressionwindow-wanted

Updated

4 years ago
Component: General → General Automation
Product: Firefox OS → Release Engineering
Ben - Are there any workarounds we can apply here to get Flame OTAs back up and running post landing bug 918068?
Flags: needinfo?(bhearsum)
(Reporter)

Comment 7

4 years ago
(In reply to Alexandre LISSY :gerard-majax from comment #4)
> Specifically, bug 918068 changed the update url:
>  - from http://update.boot2gecko.org/%CHANNEL%/update.xml
>  - to
> https://aus4.mozilla.org/update/3/%PRODUCT%/%VERSION%/%BUILD_ID%/
> %PRODUCT_DEVICE%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/
> %DISTRIBUTION_VERSION%/update.xml
> 
> The %CHANNEL% value was set at build time and thus included the
> PRODUCT_DEVICE value defined by our sources.
> 
> But in the new URL, we use %PRODUCT_DEVICE% which is replaced in
> nsUpdateService.js by gProductDevice. This value is directly getting the
> value of the ro.product.device property. Since your device has a base
> system.img flashed from T2M, then your ro.product.device is msm8610. Our
> builds have it being flame.
> 
> I really don't think this should be considered as a regression.

Not sure i agree.  since bug 918068 is new code, then i understand that the path is looking for a product named "flame" and is failing because my device name says otherwise.   however, the base image will continue to be set by the vendor, which leads me to think of two options:

1) we ask the vendor to change ro.product.device = flame  
** this will be a slower and messier, because we need to get vendor involved, recreate a base, and that slows us down.  This is also not in their best interest because they are promising to host Production updates, which may/may not account for the current msm8610 device name in their process.

2) we modify our own nightly script (bug 918068), and accept msm8610 as a alternative parameter.   I vote for this path, as i assume its much easier to just add this to a switch statement.

Bottom line, b2g engineering and QA will need the OTA nightly code to work, so this bug behavior blocks us in testing at the moment.

Thoughts?
If the server side can accept msm8610 then it would be good but it's not my call. That does not change anything to the fact that builds provided by partner and by us are diverging.
(In reply to Tony Chung [:tchung] from comment #7)
> (In reply to Alexandre LISSY :gerard-majax from comment #4)
> > Specifically, bug 918068 changed the update url:
> >  - from http://update.boot2gecko.org/%CHANNEL%/update.xml
> >  - to
> > https://aus4.mozilla.org/update/3/%PRODUCT%/%VERSION%/%BUILD_ID%/
> > %PRODUCT_DEVICE%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/
> > %DISTRIBUTION_VERSION%/update.xml
> > 
> > The %CHANNEL% value was set at build time and thus included the
> > PRODUCT_DEVICE value defined by our sources.
> > 
> > But in the new URL, we use %PRODUCT_DEVICE% which is replaced in
> > nsUpdateService.js by gProductDevice. This value is directly getting the
> > value of the ro.product.device property. Since your device has a base
> > system.img flashed from T2M, then your ro.product.device is msm8610. Our
> > builds have it being flame.
> > 
> > I really don't think this should be considered as a regression.
> 
> Not sure i agree.  since bug 918068 is new code, then i understand that the
> path is looking for a product named "flame" and is failing because my device
> name says otherwise.   however, the base image will continue to be set by
> the vendor, which leads me to think of two options:
> 
> 1) we ask the vendor to change ro.product.device = flame  
> ** this will be a slower and messier, because we need to get vendor
> involved, recreate a base, and that slows us down.  This is also not in
> their best interest because they are promising to host Production updates,
> which may/may not account for the current msm8610 device name in their
> process.
> 
> 2) we modify our own nightly script (bug 918068), and accept msm8610 as a
> alternative parameter.   I vote for this path, as i assume its much easier
> to just add this to a switch statement.
> 
> Bottom line, b2g engineering and QA will need the OTA nightly code to work,
> so this bug behavior blocks us in testing at the moment.
> 
> Thoughts?

Another solution is using system.img from pvtbuilds. Those should be fine since we define ro.product.device to flame, and we are working on making also boot.img and recovery.img available.
(Reporter)

Comment 10

4 years ago
ni? vance chen.

> (In reply to Tony Chung [:tchung] from comment #7)
> > 
> > 1) we ask the vendor to change ro.product.device = flame  
> > ** this will be a slower and messier, because we need to get vendor
> > involved, recreate a base, and that slows us down.  This is also not in
> > their best interest because they are promising to host Production updates,
> > which may/may not account for the current msm8610 device name in their
> > process.
> > 

Vance, as we're exploring options, the best one right now is to see if T2M would be willing to change the ro.product.device = Flame.   can you bring this up with them?   This will fix our internal nightly update infrastructure.  Thanks!
Flags: needinfo?(vchen)
(In reply to Jason Smith [:jsmith] from comment #6)
> Ben - Are there any workarounds we can apply here to get Flame OTAs back up
> and running post landing bug 918068?

OTAs do work, as long as your PRODUCT_DEVICE is "flame". This supports the configuration where you flash one of your flame.zip's. I can make both work, but it's not clear to me that Tony's configuration is valid. I've been working on the assumption that anybody on our nightly channel should've flashed a flame.zip (ie, not just gecko+gaia) at some point.
Flags: needinfo?(bhearsum)
A few of us talked about this on IRC. Mwu said that the best solution is to get the vendor to switch to "flame", because "msm8610" encompasses more than just Flame devices. Given that, there's nothing for me to do.

After the vendor switches, I think everyone will need to reflash before updates are working again.
Component: General Automation → General
Product: Release Engineering → Firefox OS
(Reporter)

Comment 13

4 years ago
(In reply to Ben Hearsum [:bhearsum] from comment #12)
> A few of us talked about this on IRC. Mwu said that the best solution is to
> get the vendor to switch to "flame", because "msm8610" encompasses more than
> just Flame devices. Given that, there's nothing for me to do.
> 
> After the vendor switches, I think everyone will need to reflash before
> updates are working again.

in order to unblock QA from doing OTA nightly teting, is there a workaround that QA can add in the device configurations for now?
(Reporter)

Comment 14

4 years ago
Mwu's pointed me to a workaround by editing the build.prop setting and remounting adb.  We can temporarily do this work until T2M provides us the permanent fix in ro.product.device.

Here are the steps below: 

% adb pull /system/build.prop
61 KB/s (5078 bytes in 0.080s)

% sed -i -e "s/ro.product.device=msm8610/ro.product.device=flame/" build.prop

% adb remount
remount succeeded

% adb push build.prop /system/
109 KB/s (5076 bytes in 0.045s)

% adb shell chmod 644 /system/build.prop
% adb reboot

And to verify:
% adb shell getprop ro.product.device
flame

Lets get these steps added to the flashing script
Component: General → Vendcom

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+

Updated

4 years ago
Whiteboard: POVB
Will talk to T2M to see if we can get new base image by the end of this Friday(6/6)
Flags: needinfo?(vchen)
update - Vendor will address this in an upcoming build as Vance suggested.

(In reply to Vance Chen [:vchen][vchen@mozilla.com] from comment #15)
> Will talk to T2M to see if we can get new base image by the end of this
> Friday(6/6)
Since we're going with the partner solution, this bug doesn't depend on bug 918068 anymore.
No longer depends on: 918068

Updated

4 years ago
Whiteboard: POVB → [POVB]
Hi Tony

A new flame base image that fixes this issue is available on the box now. please help to give it a try and let me know if there is still any problem

Thanks

Vance
Flags: needinfo?(tchung)
(Reporter)

Comment 19

4 years ago
(In reply to Vance Chen [:vchen][vchen@mozilla.com] from comment #18)
> Hi Tony
> 
> A new flame base image that fixes this issue is available on the box now.
> please help to give it a try and let me know if there is still any problem
> 
> Thanks
> 
> Vance

Yes, fixed in Image v10H-4.   Thanks!

$ adb shell getprop ro.product.device
Flame
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(tchung)
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
(In reply to Tony Chung [:tchung] from comment #19)
> (In reply to Vance Chen [:vchen][vchen@mozilla.com] from comment #18)
> > Hi Tony
> > 
> > A new flame base image that fixes this issue is available on the box now.
> > please help to give it a try and let me know if there is still any problem
> > 
> > Thanks
> > 
> > Vance
> 
> Yes, fixed in Image v10H-4.   Thanks!
> 
> $ adb shell getprop ro.product.device
> Flame

I don't think this will work. Updates are case sensitive. Eg:
https://aus4.mozilla.org/update/3/B2G/32.0a1/20140515163731/flame/en-US/nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1
vs.
https://aus4.mozilla.org/update/3/B2G/32.0a1/20140515163731/Flame/en-US/nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 21

4 years ago
Having 'Flame' when running 'adb shell getprop ro.product.device' on Image v10H-4, and checking for updates gives me the message 'No updates were found'... I was trying to update from Friday's build.
(Reporter)

Comment 22

4 years ago
(In reply to Ben Hearsum [:bhearsum] from comment #20)
> (In reply to Tony Chung [:tchung] from comment #19)
> > (In reply to Vance Chen [:vchen][vchen@mozilla.com] from comment #18)
> > > Hi Tony
> > > 
> > > A new flame base image that fixes this issue is available on the box now.
> > > please help to give it a try and let me know if there is still any problem
> > > 
> > > Thanks
> > > 
> > > Vance
> > 
> > Yes, fixed in Image v10H-4.   Thanks!
> > 
> > $ adb shell getprop ro.product.device
> > Flame
> 
> I don't think this will work. Updates are case sensitive. Eg:
> https://aus4.mozilla.org/update/3/B2G/32.0a1/20140515163731/flame/en-US/
> nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1
> vs.
> https://aus4.mozilla.org/update/3/B2G/32.0a1/20140515163731/Flame/en-US/
> nightly/Boot2Gecko%202.0.0.0-prerelease/default/default/update.xml?force=1

Ugh..  Vance/ Francis, can you report back to Vendor and ask them to fix this again?   needs to be case sensitive == "flame" not "Flame"
Flags: needinfo?(vchen)
Flags: needinfo?(frlee)
hi Yanan,

could you please refer to comment22 and fix this issue found in v10H?
Flags: needinfo?(frlee) → needinfo?(yanan.zhao)

Comment 24

4 years ago
Hi Francis,

Already add the property on v121-2 to fix this issue, can verify on next official release.
Thanks
Flags: needinfo?(yanan.zhao)
Duplicate of this bug: 1024541
I can verify that with v121-2, the device name is set to "flame" and we were able to perform the STR's in bug 1024541 without issue regarding the device name.

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Marking fixed per comment 26 by the latest base image.
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Verified that issue does NOT occur on 2.0 Flame with latest base (v121-2)

Result: OTA update functions as expected going from 20140612000201 to 20140613000203

Environmental Variables:
Device: Flame 2.0
Build ID: 20140613000203
Gaia: a3a5322692578e0a577fb7fa08e32144b2b05ba3
Gecko: 8897bc43f59b
Version: 32.0a2 (2.0) 
Firmware Version: v121-2
Status: RESOLVED → VERIFIED
clear my ni? since this issue is fixed
Flags: needinfo?(vchen)

Comment 30

4 years ago
Verified fixed on Flame 2.1 KK (319mb/full flash)

Actual result: Received notification and performed OTA from 20141020001201 to 20141021001201.

Device: Flame 2.1
BuildID: 20141021001201
Gaia: e458f5804c0851eb4e93c9eb143fe044988cecda
Gecko: ee86921a986f
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified

Comment 31

4 years ago
Flame 2.2 KK OTA are failing:


I/Gecko   (  205): UpdatePrompt: Forcing update check
I/Gecko   (  205): *** AUS:SVC Checker: checkForUpdates, force: true
I/Gecko   (  205): *** AUS:SVC Checker:getUpdateURL - update URL: https://aus4.mozilla.org/update/3/B2G/36.0a1/20141123160201/flame/en-US/aurora/Boot2Gecko%202.2.0.0-prerelease%20(SDK%2019)/default/default/update.xml?force=1
I/Gecko   (  205): *** AUS:SVC Checker:checkForUpdates - sending request to: https://aus4.mozilla.org/update/3/B2G/36.0a1/20141123160201/flame/en-US/aurora/Boot2Gecko%202.2.0.0-prerelease%20(SDK%2019)/default/default/update.xml?force=1
I/GeckoDump(  205): XXX FIXME : Got a mozContentEvent: force-update-check
E/QCALOG  (  348): [MessageQ] ProcessNewMessage: [XT-CS] unknown deliver target [OS-Agent]
E/QCALOG  (  348): [MessageQ] ProcessNewMessage: [XTWWAN-PE] unknown deliver target [OS-Agent]
I/Gecko   (  205): *** AUS:SVC Checker:onLoad - request completed downloading document
I/Gecko   (  205): *** AUS:SVC Checker:onLoad - number of updates available: 0
I/Gecko   (  205): UpdatePrompt: Setting gecko.updateStatus: no-updates
E/QCALOG  (  348): [MessageQ] ProcessNewMessage: [XTWiFi-PE] unknown deliver target [OS-Agent]
V/WLAN_PSA(  209): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
D/wpa_supplicant(14772): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 50 4f 4c 4c
D/wpa_supplicant(14772): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant(14772): nl80211: survey data missing!
E/QCALOG  (  348): [MessageQ] ProcessNewMessage: [XT-CS] unknown deliver target [OS-Agent]
E/QCALOG  (  348): [MessageQ] ProcessNewMessage: [XTWWAN-PE] unknown deliver target [OS-Agent]
E/QCALOG  (  348): [MessageQ] ProcessNewMessage: [XTWiFi-PE] unknown deliver target [OS-Agent]
V/WLAN_PSA(  209): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
D/wpa_supplicant(14772): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 50 4f 4c 4c
You need to log in before you can comment on or make changes to this bug.