[B2G][Calendar] Pressing the back arrow button in the 'Add an account' screen does not work.

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Calendar
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Dean R. Gomez (DeanG), Assigned: millermedeiros)

Tracking

({regression})

unspecified
2.0 S3 (6june)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 fixed)

Details

(Whiteboard: [2.0-flame-test-run-1])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8431747 [details]
Back_Error.jpeg

Description:
When a user launches the 'Calendar' app, press the drawer icon in the upper left hand corner of the month view, selects the gear icon for settings, presses the 'Add Account' button, and attempts to press the back arrow in the upper left corner, the user will not be taken to the 'Calendar Settings' page. 

Repro Steps:
1) Update a Flame to BuildID: 20140529040201
2) Launch 'Calendar' app.
3) In month view, press the drawer icon in the upper left corner.
4) Press the gear icon on the bottom of the drop-down menu.
5) Select 'Add Account'.
6) Press the back arrow in the upper left corner.
7) Observe results.

Actual:
The user will remain on the 'Add Account' page.
Expected:
The user will be taken back to the 'Calendar Settings' page.

2.0 Environmental Variables:
Device: Flame 2.0
BuildID: 20140530040207
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko: e6f113c83095
Version: 32.0a1
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 6/6, 100%
See attached: Back_Error.jpeg, Logcat_Back_Error.txt
(Reporter)

Comment 1

3 years ago
Created attachment 8431749 [details]
Logcat_Back_Error.txt

Attaching Logcat.
*Logcat may be affected by Bug 1010993.*
(Reporter)

Comment 2

3 years ago
Flame 1.4

This issue DOES NOT occur on Flame 1.4

1.4F Environmental Variables:
Device: Flame 1.4F
BuildID: 20140530000202
Gaia: fe612fd21389193a8e593aa718831602e5086a62
Gecko: 25011f9a8f26
Version: 30.0
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Buri 2.0

This issue DOES occur on Buri 2.0

2.0 Environmental Variables:
Device: Buri 2.0 MOZ
BuildID: 20140530040207
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko: e6f113c83095
Version: 32.0a1
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Open_C 2.0

This issue DOES occur on Open_C 2.0

2.0 Environmental Variables:
Device: Open_C 2.0
BuildID: 20140530040207
Gaia: 26d8fcab9b61f46451600f39c51e03
87ef3c4f88
Gecko: e6f113c83095
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
(Assignee)

Updated

3 years ago
See Also: → bug 1017811
Pretty much the same problem as bug 1017811, except different UX.
Blocks: 789261
blocking-b2g: --- → 2.0?
blocking-b2g: 2.0? → 2.0+

Updated

3 years ago
Duplicate of this bug: 1018830
Assignee: nobody → mmedeiros
(Assignee)

Updated

3 years ago
Blocks: 1019717
(Assignee)

Updated

3 years ago
Target Milestone: --- → 2.0 S3 (6june)
(Assignee)

Comment 5

3 years ago
landed into master: https://github.com/mozilla-b2g/gaia/commit/5fbba20cb5d8d640291c5e4061c1e26c0a6c4743
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
status-b2g-v2.0: affected → fixed

Comment 6

3 years ago
[Environment]
Gaia      8d865839d932bfbd5e157f376f74d8cb12bfdd51
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/1d4046a8cb6c
BuildID   20140610000223
Version   32.0a2
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

[Result]
Pass
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.