Stepping disabled after breakpoint is hit

REOPENED
Unassigned

Status

DevTools
Debugger
REOPENED
4 years ago
7 days ago

People

(Reporter: fitzgen, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

STR: 

1. Clone https://github.com/fitzgen/wu.js
2. Checkout 7bb63d89e15af1def9f0f86f5a421a038ef0fdb3
3. Open test-es5/test.html
4. Set a BP on test-enumerate.js line 4
5. Refresh

ER:

Hit the BP

AR:

Execution pauses like you hit the BP, but the stepping buttons are disabled like you didn't pause and you can't step.

This is what I'm seeing in the console:

"""
A promise chain failed to handle a rejection.

Date: Fri May 30 2014 18:00:28 GMT-0400 (EDT)
Full Message: TypeError: cm.lineInfo(...) is null

debugger.js:107
"""

Which (for posterity) is the "let markers = ..." line here:

> function hasBreakpoint(ctx, line) {
>   let { cm } = ctx;
>   let markers = cm.lineInfo(line).gutterMarkers;
> 
>   return markers != null &&
>     markers.breakpoints.classList.contains("breakpoint");
> }
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1013948
I'm reopening because the patch in bug 957174 fixes the displayed error, but the stepping buttons still look disabled. It must be a different issue with an error that is swallowed.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

4 years ago
Blocks: 1074182
Summary: Stop at breakpoint but buttons disabled and can't step → Stepping disabled after breakpoint is hit

Updated

7 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.