Autophone - s1s2 - Regression in local "time to throbber stop" on 2014-05-11

RESOLVED FIXED in Firefox 32

Status

()

Firefox for Android
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gbrown, Assigned: Paolo)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Firefox 34
x86_64
Android
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox31 unaffected, firefox32+ fixed, firefox33 fixed, firefox34 fixed, fennec32+)

Details

(Reporter)

Description

4 years ago
http://phonedash.mozilla.org/#/org.mozilla.fennec/throbberstop/local-blank/norejected/2014-05-11/2014-05-12/notcached/noerrorbars/standarderror shows a slight regression on most devices.

One example:

2014-05-11 04:49:06
nexus-7-jss15q-2
(fx-team/rev/b5f1695e602c):
2887±20
N=8

vs.

2014-05-11 10:26:05
nexus-7-jss15q-2
(fx-team/rev/f36bdf55548a):
3101±12
N=8

http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=b5f1695e602c&tochange=f36bdf55548a points to bug 956332.
(Reporter)

Comment 1

4 years ago
Paolo -- Do you think bug 956332 might have caused this small startup performance regression on Android?
Flags: needinfo?(paolo.mozmail)
(Reporter)

Updated

4 years ago
tracking-fennec: --- → ?
(Assignee)

Comment 2

4 years ago
(In reply to Geoff Brown [:gbrown] from comment #1)
> Paolo -- Do you think bug 956332 might have caused this small startup
> performance regression on Android?

It's possible, because we now initialize the storage module earlier, in which case solving bug 1012677 may be the way forward here.
Flags: needinfo?(paolo.mozmail)
Assignee: nobody → paolo.mozmail
Blocks: 956332
tracking-fennec: ? → 32+
tracking-firefox32: --- → ?
Marking as 32+ affected based on the assumption that bug 956332 is the cause.

Paolo: Can you make the case to work on this while 32 is still on Aurora (~2.5 more weeks)?
status-firefox31: --- → unaffected
status-firefox32: --- → affected
status-firefox33: --- → affected
tracking-firefox32: ? → +
Flags: needinfo?(paolo.mozmail)
(Assignee)

Comment 4

4 years ago
I think that someone with an Android build should look into bug 1012677, which is likely to solve this regression. I added some information to the bug, feel free to set the tracking flags there.
Depends on: 1012677
Flags: needinfo?(paolo.mozmail)
Geoff, did bug 1012677 resolve this?
Flags: needinfo?(gbrown)

Comment 6

4 years ago
I think so. http://phonedash.mozilla.org/#/org.mozilla.fennec/throbberstop/local-blank/norejected/2014-07-30/2014-08-04/notcached/noerrorbars/standarderror shows the drop on fx-team for the revision in bug 1012677 comment 4 followed thereafter for the other branches as the patch was merged.
(Reporter)

Comment 7

4 years ago
Agreed!

2014-07-31 12:56:07
nexus-7-jss15q-2
(fx-team/rev/3cde40ba857c):
3261±35
N=8

2014-07-31 13:50:12
nexus-7-jss15q-2
(fx-team/rev/e21dd0c363f8):
2964±17
N=8
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(gbrown)
Resolution: --- → FIXED
status-firefox32: affected → fixed
status-firefox33: affected → fixed
status-firefox34: --- → fixed
Target Milestone: --- → Firefox 34
You need to log in before you can comment on or make changes to this bug.