Closed Bug 1018485 Opened 5 years ago Closed 2 years ago

[B2G][Tarako][Facebook][Camera]Performance issues attempting to Select Photo from Camera App while within Facebook

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v1.3T affected, b2g-v1.4 unaffected, b2g-v2.0 unaffected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.3T --- affected
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected

People

(Reporter: mclemmons, Unassigned)

References

()

Details

(Keywords: perf, Whiteboard: [c=effect p= s= u=tarako] [tarako-exploratory])

Attachments

(2 files)

User downloads and installs Facebook App from Marketplace. User taps Facebook and logs in. User taps Photo in upper middle and selects Camera and takes a photo. The photo is taken but the user is never prompted to either select the photo or retake the photo (as is the case with Flame 2.0). User's only options seem to either restart the device or long presses homescreen to exit Facebook. However, when user returns to that same area within Facebook, the image taken has not been selected or saved. 

Prerequisites:
1. Download and install Facebook from Marketplace 

Repro Steps: 
1) Update a Tarako to BuildID: 20140530014002
2) Tap Facebook, then Photos
3) Tap Camera and take a photo
4) Observe device behavior 

Actual: 
Device non responsive with no indication to user to select or retake the photo. User's option is to restart device or long press homescreen button to exit area – losing saved work. 

Expected: 
An on screen message to retake or select the photo and continued functionality without having to restart the device or long press homescreen button.


Notes: 
Repro frequency: (5/5, 100%) 
See attached: video clip, logcat, firewatch

1.3T Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140530014002
Gaia: e68858693b71d917c9c5ee7e215f7ceea04635f7
Gecko: 1945abae19ff
Version: 28.1
Firmware Version: sp6821a-gonk-4.0-5-12
User Agent: Mozilla/5.0 (Mobile; rv:28.1) Gecko/28.1 Firefox/28.1
This issue does not reproduce on Flame 2.0 following the STR from Comment 0. User is presented the options of Retake or Select and both options are available. 

2.0 Environmental Variables: 
Device: Flame 2.0 MOZ 
BuildID: 20140529040201 
Gaia: 4142df90c71abdc1e3a87cd37dff1a22d5e38b34 
Gecko: 1e712b724d17 
Version: 32.0a1 
Firmware Version: v10G-2 
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Update to Comment 1 - These are the correct variables for 5/30/14

2.0 Environmental Variables:
Device: Flame 2.0
BuildID: 20140530040207
Gaia: 26d8fcab9b61f46451600f39c51e03
87ef3c4f88
Gecko: e6f113c83095
Version: 32.0a1
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
This issue does not reproduce on Flame 1.4 following the STR from Comment 0. User is presented the options of Retake or Select and both options are available. 

1.4 Environmental Variables:
Device: Flame 1.4
BuildID: 20140530000202
Gaia: fe612fd21389193a8e593aa718831602e5086a62
Gecko: 25011f9a8f26
Version: 30.0
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
The video is unclear to the problem scope here - can we get a smaller video that focuses on the scope of this bug specifically?
Keywords: qawanted
Priority: -- → P2
Whiteboard: [tarako-exploratory] → [tarako-exploratory][c=effect p= s= u=tarako]
Profile : 
http://people.mozilla.org/~bgirard/cleopatra/#report=ce8946dee798cbe437eabcab19c1ab23efec1a82

I think it's a perf issue when calling up the camera from the Facebook app.
Keywords: perf
Harald, fyi.
Flags: needinfo?(hkirschner)
Whiteboard: [tarako-exploratory][c=effect p= s= u=tarako] → [c=effect p= s= u=tarako] [tarako-exploratory]
After bug 1007019 received huge impact from various fixes, can we retest this with the latest 1.3T?
Flags: needinfo?(hkirschner)
Flags: needinfo?(nhirata.bugzilla)
https://people.mozilla.org/~bgirard/cleopatra/#report=ca18a96e99f06dcdc6ed08472aa7eaf0e060a38a

Here's the profile for the low-fi version of Facebook with the patch.  Please note that the e.me app version still shows the hi-fi version.

Gaia      140a7fad7b758c8e656cf865cefb032f85ec634b
Gecko     59c7eabd7edd2ec7a5c6951468342f3f6c59bb2f
BuildID   20140613100047
Version   28.1
ro.build.version.incremental=eng.ubuntu.20140609.164436
ro.build.date=Mon Jun  9 16:46:33 PDT 2014
Tarako
Flags: needinfo?(nhirata.bugzilla) → needinfo?(hkirschner)
Note Bug 1025144 is tracking the e.me version difference with browser/marketplace app.
jsmith: https://www.youtube.com/watch?v=TQxFOhNBK6A&feature=youtube_gdata_player

This is from today's build which is much better than before.  It could take up to a 45 seconds for the camera to load before today's build.  You can still see parts where it seems unresponsive.

Gaia      e073132c427e85f15408c5d9a9c700b20ee12b8b
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/d78bccbc2a24
BuildID   20140613014003
Version   28.1
ro.build.version.incremental=eng.cltbld.20140613.133443
ro.build.date=Fri Jun 13 13:34:53 EDT 2014
Tarako

This is not the same build as done for the profiling.  The profiling runs on a different UA which gives a more minimized version of Facebook.  Having said that, there still is a performance issue with the camera app being called from a third party app.
Flags: needinfo?(jsmith)
Keywords: qawanted
Are we sure the root cause here is related to third party app here? The only thing the app is doing here is exposing an input=file element and allowing the user to select the camera through it. I'd expect this issue to reproduce elsewhere with an input=file element.
Flags: needinfo?(jsmith)
I believe we made some changes to email as well as contacts and sms in regards to the interactions between camera/gallery.  I am unsure about bluetooth and browser now that I think about it.  There might be a gap in coverage there.  I don't think you can share camera through blue tooth?

We might see the issue in browser.
FB is continuing to reduce memory by rolling out React based mobile frontend.
Flags: needinfo?(hkirschner)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.