documentation on how to install bugzilla under apache is now incorrect

RESOLVED DUPLICATE of bug 1188824

Status

()

Bugzilla
Documentation
RESOLVED DUPLICATE of bug 1188824
4 years ago
3 years ago

People

(Reporter: Marc Chamberlin, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 2014050900

Steps to reproduce:

1. Installed Apache2 version 2.4.6-6.23.1-x86_64 on an  openSuSE 13.1 linux system.

2. Follow   the  directions on the webpage at http://www.bugzilla.org/docs/4.4/en/html/configuration.html for  integrating bugzilla with  apache using cgi in section 2.2.4.1.1. Apache httpd™ with mod_cgi


Actual results:

Apache is moving towards using a new access control  syntax which uses a "Require" syntax rather than the "Order Allow/Deny" syntax and Bugzilla needs to step up to support this change as well. As it stands,  currently if neither the "Require"  or the "Order Allow/Deny" access privileges is configured in the httpd.conf file,  for the Bugzilla directory, Apache now defaults  to denying all access from all users. This results in a 403 error from the server denying access to the Bugzilla web pages.


Expected results:

Of course I expected to be able to access the Bugzilla webpages after installation. I fixed this problem by adding in the Order/Allow directives to the Apache configuration for the Bugzilla directory. The aforementioned directions should reflect something like the  following - (taken directly from my own httpd.conf.local file)

<Directory /srv/www/bugzilla>
AddHandler cgi-script .cgi
Options +ExecCGI
DirectoryIndex index.cgi index.html
AllowOverride Limit FileInfo Indexes Options
Order allow,deny
Allow from all
</Directory>

Note the addition of the last two directives for the Order/Allow specifications. This is NOT shown on the website and cost me a lot of time tracking it down! Please add it so others won't wander into the same quagmire I did trying to figure out why Bugzilla failed to start up after I installed it following these directions!

FYI - Some good bug reports on this issue can be  found on the openSuSE/Novell bug tracker -
https://bugzilla.novell.com/show_bug.cgi?id=855049
https://bugzilla.novell.com/show_bug.cgi?id=854263

Comment 1

3 years ago
The "Allow from all" command is not necessary everywhere, at least not in Mageia, so this must be distro-specific.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1188824
You need to log in before you can comment on or make changes to this bug.