Closed Bug 1018491 Opened 7 years ago Closed 6 years ago

[B2G][Music] The search feature offers no way to filter results by artist, album, or song

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.3 affected, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

RESOLVED DUPLICATE of bug 838035
Tracking Status
b2g-v1.3 --- affected
b2g-v1.4 --- affected
b2g-v2.0 --- affected
b2g-v2.1 --- affected

People

(Reporter: bmorgan, Unassigned)

References

Details

(Whiteboard: permafail)

Attachments

(2 files)

Attached file logcat.txt
Description:
When using the search feature in the Music app (not the icons on the bottom), there is no way of filtering search results by artist/album/song.

Pre-requisite: Ensure that there is music saved to the device

Repro Steps:
1) Update a Flame to BuildID: 20140530040207
2) Tap on the Music app to open it
3) Pull the screen down to reveal the search bar
4) Enter characters into the search bar, observe results for artist/album/song
5) Observe there is no way to filter results by artist/album/song

Actual:
There is no discernable way to filter search results by artist/album/song

Expected:
A method of filtering search results by artist/album/song

2.0 Environmental Variables:
Device: Flame 2.0 MOZ
BuildID: 20140530040207
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko: e6f113c83095
Version: 32.0a1
Firmware Version: 10g-2

My User Agent: Mozilla/5.0(Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 100%
See attached: logcat

Logcat issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1010993
Attached image 2014-05-30-17-24-37.png
The issue does occur on the Flame 1.4.  There is no discernable way to filter search results by artist/album/song.
Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

The issue does occur on the Buri 1.4.  There is no discernable way to filter search results by artist/album/song.
Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

The issue does occur on the Buri 1.3.  There is no discernable way to filter search results by artist/album/song.
Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

1.4 Environmental Variables:
Device: Flame 1.4 MOZ
BuildID: 20140530000202
Gaia: fe612fd21389193a8e593aa718831602e5086a62
Gecko: 25011f9a8f26
Version: 30.0
Firmware Version: 10g-2

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140530000202
Gaia: fe612fd21389193a8e593aa718831602e5086a62
Gecko: 25011f9a8f26
Version: 30.0
Firmware Version: v1.2-device.cfg

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140530024008
Gaia: 5bd226b03a2d63dfe9df204f7c0afb9984e8fd42
Gecko: 57cd741e4d0b
Version: 28.0
Firmware Version: v1.2-device.cfg
Since Bug 838035 was never implemented, this functionality doesn't exist.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.0-flame-test-run-1] → [2.0-flame-test-run-1], [2.0-flame-test-run-2]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → 2
QA Whiteboard: 2 → [QAnalyst-Triage+][lead-review+]
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(dharris)
Whiteboard: [2.0-flame-test-run-1], [2.0-flame-test-run-2] → permafail
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(dharris)
Depends on: 838035
Let's implement bug 838035 first.
Doesn't bug 838035 actually *resolve* this bug? I'm not clear on what else there is to do here.
(In reply to Jim Porter (:squib) from comment #4)
> Doesn't bug 838035 actually *resolve* this bug? I'm not clear on what else
> there is to do here.

I think it's fixed by bug 838035, let's dupe this.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 838035
You need to log in before you can comment on or make changes to this bug.