[Flame][Dialer] Missing headset icon when calling

VERIFIED FIXED in Firefox OS v2.0

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jlorenzo, Assigned: paco)

Tracking

({regression})

unspecified
2.0 S4 (20june)
x86
Mac OS X
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

Details

Attachments

(6 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8431983 [details]
Missing headset icon - screenshot

Device Flame
Gaia      26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko     https://hg.mozilla.org/mozilla-central/rev/e6f113c83095
BuildID   20140530040207
Version   32.0a1

STR
1. Pair a bluetooth headset
2. Make or receive a call
3. Pick up

Actual result
No headset icon shown. See attached screenshot for details.

Additional notes: Not reproduced with today's 1.4 build.
(Reporter)

Updated

4 years ago
Keywords: smoketest
I don't think I'd block on a headset icon missing for smoketests. Certainly something we need to get fixed, but not enough to call a fire drill on.

QAWanted to check 1.4.
Keywords: smoketest → qawanted
(In reply to Jason Smith [:jsmith] from comment #1)
> I don't think I'd block on a headset icon missing for smoketests. Certainly
> something we need to get fixed, but not enough to call a fire drill on.
> 
> QAWanted to check 1.4.

Actually - QA Wanted to get a screenshot of what's seen on 1.4 to see the fallout.

Updated

4 years ago
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
Keywords: qawanted → regressionwindow-wanted, smoketest

Updated

4 years ago
Keywords: smoketest → qawanted

Updated

4 years ago
blocking-b2g: --- → 2.0?
Let's get the 1.4 screenshot first before we go after a window.
Keywords: regressionwindow-wanted
Actually I'm going to hold off on the nom here until I get better clarification on the bug here on 1.4 vs. 2.0.
blocking-b2g: 2.0? → ---

Comment 5

4 years ago
Created attachment 8432603 [details]
1.4_Headset

I have posted a 1.4 screenshot.

On 1.4 there is a 'headset' icon that is displayed. 

On 2.0 the icon disappeared after the first phone call took place and then consecutive from there on.

Updated

4 years ago
Keywords: qawanted

Updated

4 years ago
blocking-b2g: --- → 2.0?
Keywords: regressionwindow-wanted

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
Assignee: nobody → pacorampas
Device: Flame v2.0
Gaia      908f94fda04462001ece86e6b6c15ad8b05f7526
Gecko     https://hg.mozilla.org/mozilla-central/rev/5e8e9d864a4d
BuildID   20140605160202
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

### STR, Flame v2.0
1. Same as https://bugzilla.mozilla.org/show_bug.cgi?id=1018495#c0
2. <ISSUE> Ringtone comes out from both flame speaker & bt headset when headset is connected, will file a bug.
3. <ISSUE> No headset icon.

Device: Buri v2.0
Gaia      908f94fda04462001ece86e6b6c15ad8b05f7526
Gecko     https://hg.mozilla.org/mozilla-central/rev/5e8e9d864a4d
BuildID   20140605160202
Version   32.0a1
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013

### STR, Buri v2.0
1. Bluetooth on and connected.
2. Making/receiving call for the 1 time after bt is connected.
3. <ISSUE> Speaker icon shown in stead of headset icon, ringtones from headset only. http://youtu.be/RKLVAalVhNk
4. Making/receiving call again.
5. <ISSUE> No icon shown. http://youtu.be/iAkCwag6ylI

Updated

4 years ago
Blocks: 950760
Target Milestone: --- → 2.0 S4 (20june)
Last Friday I checked with Arnau that the headset icon was not available so we need to include it.
Setting ni to Victoria to be aware of this.
Flags: needinfo?(vpg)
B2G Inbound window:
Last Working
Build ID: 20140529083004
Gecko: https://hg.mozilla.org/integration/b2g-inbound/rev/f72106cb1769
Gaia: d5dcbabd1ad07d5fd30a7875a9a80817bc93619c
Platform Version: 32.0a1
Firmware Version: V10g-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

First Broken
Build ID: 20140529113002
Gecko: https://hg.mozilla.org/integration/b2g-inbound/rev/8630b86e15c7
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Platform Version: 32.0a1
Firmware Version: V10g-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Last Working Gaia / First Broken Gecko - OK
First Broken Gaia / Last Working Gecko - Fail
Gaia push log: https://github.com/mozilla-b2g/gaia/compare/d5dcbabd1ad07d5fd30a7875a9a80817bc93619c...26d8fcab9b61f46451600f39c51e0387ef3c4f88
QA Whiteboard: [QAnalyst-Triage?]
Keywords: regressionwindow-wanted
When finishing a QA request, make sure you needinfo jmitchell.
Flags: needinfo?(ckreinbring)
Flags: needinfo?(ckreinbring) → needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
(Reporter)

Comment 11

4 years ago
It's seems that Bug 951606 is the origin of the regression. Can you have a look Germán?
Blocks: 951606
Flags: needinfo?(gtorodelvalle)
(In reply to Johan Lorenzo [:jlorenzo] from comment #11)
> It's seems that Bug 951606 is the origin of the regression. Can you have a
> look Germán?

Actually Maria already assigned someone here, so don't worry about this.
Flags: needinfo?(gtorodelvalle)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Created attachment 8440632 [details]
Headset icon in all states and sizes
Flags: needinfo?(vpg)
PLease find attached the headset icon in all states and sizes.

THanks!

Updated

4 years ago
Duplicate of this bug: 1026548

Updated

4 years ago
Attachment #8440632 - Attachment is obsolete: true

Comment 16

4 years ago
Created attachment 8442663 [details]
Headset icon all sizes
(Assignee)

Comment 17

4 years ago
Created attachment 8442683 [details]
headset.png
(Assignee)

Comment 18

4 years ago
Created attachment 8442685 [details] [review]
Patch in github
Attachment #8442685 - Flags: review?(anthony)
(Assignee)

Updated

4 years ago
Attachment #8442683 - Flags: ui-review?(vpg)

Updated

4 years ago
Attachment #8442685 - Flags: review?(anthony) → review+
Attachment #8442683 - Flags: ui-review?(vpg) → ui-review+
Merged: b55b89fe20ecf439b44b3753d8dc4c9741e43e6f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-v2.1: --- → fixed

Comment 21

4 years ago
Created attachment 8533613 [details]
Verify_Video_Flame.MP4

This issue has been verified successfully on Flame 2.0 & 2.1.
See attachment: Verify_Video_Flame.MP4
Reproducing rate: 0/10

Flame v2.0 version:
Gaia-Rev        856863962362030174bae4e03d59c3ebbc182473
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/e40fe21e37f1
Build-ID        20141208000206
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141208.035628
FW-Date         Mon Dec  8 03:56:38 EST 2014
Bootloader      L1TC00011880

Flame v2.1 version:
Gaia-Rev        38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8b92c4b8f59a
Build-ID        20141205001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141205.035305
FW-Date         Fri Dec  5 03:53:16 EST 2014
Bootloader      L1TC00011880

Updated

4 years ago
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.