Navigation History is lost by redirects

RESOLVED WORKSFORME

Status

()

Core
Networking
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Jake, Unassigned)

Tracking

29 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

I went to a page on a website that produced a 404 not found error (broken link probably).  I then went 'back'.


Actual results:

I was taken back to a completely different site I was visiting previously.  The site I was visiting was completely lost from the history, and as such I cannot provide more details.


Expected results:

I should have been taken back to whence I came.

Note: it is likely that the error handler on the site caused the back button to miscue, but...
(Reporter)

Comment 1

4 years ago
Revert note: the site can't cause the back button to miscue.  This is a bug and probably a longstanding one.
(Reporter)

Comment 2

4 years ago
Note the 404 error was provided by the website itself, not an ISP or browser default.
I can't reproduce in FF 29.0.1, Win 7 x64.
Please provide the link of the page you're testing with.

Also please check if the issue occurs using Firefox in safe mode (with your addons disabled):
http://support.mozilla.com/kb/Safe+Mode

And on a new, empty profile:
http://support.mozilla.org/en-US/kb/Managing-profiles#w_starting-the-profile-manager
Component: Untriaged → Networking
Flags: needinfo?(jake_hotson)
Product: Firefox → Core
(Reporter)

Comment 4

4 years ago
I can't repro this myself now either.

There is deffo an issue in which a (mis)typed address is lost by a redirect (such that a correction to the typing is impossible and it has to entirely retyped), though that will take some thought to design a solution, and is not the issue raised.

Raise a feature request and close this?
Flags: needinfo?(jake_hotson)
There isn't much to request without reliable steps to reproduce or a testcase to demonstrate the problem.
Feel free to reopen this bug if you experience this again and try to provide the above details.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.