M094 crash [@ nsTableRowFrame::IR_TargetIsChild]

RESOLVED DUPLICATE of bug 105275

Status

()

--
critical
RESOLVED DUPLICATE of bug 105275
17 years ago
17 years ago

People

(Reporter: jay, Assigned: karnaze)

Tracking

({crash, topcrash})

Trunk
x86
Linux
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

17 years ago
This is showing up as a topcrasher for M094 on Linux.  I'm not sure I got the
correct component, but here is the latest Talkback data:

nsTableRowFrame::IR_TargetIsChild   19 
BBID range: 35454952 - 35891794
Min/Max Seconds since last crash: 14 - 820162
Min/Max Runtime: 2017 - 820162
Crash data range: 2001-09-16 to 2001-09-25
Build ID range: 2001091311 to 2001091311

Stack Trace: 

	 nsTableRowFrame::IR_TargetIsChild()
	 nsTableRowFrame::IncrementalReflow()
	 nsTableRowFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 nsTableRowGroupFrame::IR_TargetIsChild()
	 nsTableRowGroupFrame::IncrementalReflow()
	 nsTableRowGroupFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 nsTableFrame::IR_TargetIsChild()
	 nsTableFrame::IncrementalReflow()
	 nsTableFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 nsTableOuterFrame::OuterReflowChild()
	 nsTableOuterFrame::IR_InnerTableReflow()
	 nsTableOuterFrame::IR_TargetIsInnerTableFrame()
	 nsTableOuterFrame::IR_TargetIsChild()
	 nsTableOuterFrame::IncrementalReflow()
	 nsTableOuterFrame::Reflow()
	 nsBlockReflowContext::DoReflowBlock()
	 nsBlockReflowContext::ReflowBlock()
	 nsBlockFrame::ReflowBlockFrame()
	 nsBlockFrame::ReflowLine()
	 nsBlockFrame::ReflowDirtyLines()
	 nsBlockFrame::Reflow()
	 nsBlockReflowContext::DoReflowBlock()
	 nsBlockReflowContext::ReflowBlock()
	 nsBlockFrame::ReflowBlockFrame()
	 nsBlockFrame::ReflowLine()
	 nsBlockFrame::ReflowDirtyLines()
	 nsBlockFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 CanvasFrame::Reflow()
	 nsBoxToBlockAdaptor::Reflow()
	 nsBoxToBlockAdaptor::DoLayout()
	 nsBox::Layout()
	 nsScrollBoxFrame::DoLayout()
	 nsBox::Layout()
	 nsContainerBox::LayoutChildAt()
	 nsGfxScrollFrameInner::LayoutBox()
	 nsGfxScrollFrameInner::Layout()
	 nsGfxScrollFrame::DoLayout()
	 nsBox::Layout()
	 nsBoxFrame::Reflow()
	 nsGfxScrollFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 ViewportFrame::Reflow()
	 nsHTMLReflowCommand::Dispatch()
	 PresShell::ProcessReflowCommand()
	 PresShell::ProcessReflowCommands()
	 HandlePLEvent()
	 PL_HandleEvent()
	 PL_ProcessPendingEvents()
	 nsEventQueueImpl::ProcessPendingEvents()
	 event_processor_callback()
	 our_gdk_io_invoke()
	 libglib-1.2.so.0 + 0xf2f0 (0x403692f0)
	 libglib-1.2.so.0 + 0x10b86 (0x4036ab86)
	 libglib-1.2.so.0 + 0x111b3 (0x4036b1b3)
	 libglib-1.2.so.0 + 0x1137c (0x4036b37c)
	 libgtk-1.2.so.0 + 0x92d2c (0x40283d2c)
	 nsAppShell::Run()
	 nsAppShellService::Run()
	 main1()
	 main()
	 libc.so.6 + 0x1cc6f (0x404abc6f)     (35891794)	URL: www.rtl.de
(35891794)
Comments: i connect www.rtl.de - and the browser goes down!
     (35872160)	URL: www.sport1.de
(35872160)
Comments: Crashed while loading parts of the site.
     (35801088)	URL: http://www.gmate.co.kr
(35801088)
Comments: Opened the site.
     (35630733)	URL: http://relaunch.bad-zwischenahn.de/index1.html
(35630733)
Comments: The site contains a flash plugin  i guess thats the reason for the crash
     (35462346)	URL: http://www.fitforfun.de/food/specials/100fetttipps/
(35462346)
Comments: Been surfing around following the links on the above given site and
thebeast crashed. Might be a Macromedia Flash bug  I've installed Flash5 rv 47 
which tells me something about an invalid ELF header forShockwaveFlash.class on
startup. No else plugin
     (35462346)	Comments:  is installed. Hope thathelps.
     (35455010)	URL: http://www.serveisweb.com/castella/index.htm
(35455010)
Comments: Clicked the first link on that page (the one that reads "Radio y
television on-line"
     (35454952)	URL: http://www.serveisweb.com/castella/index.htm
(35454952)
Comments: Clicked a link on that page

Comment 1

17 years ago
I don't see anything related to the plugin code in the stack trace. -->Layout
Assignee: av → attinasi
Component: Plug-ins → Layout
QA Contact: shrir → petersen

Comment 2

17 years ago
the obvious choice...
Assignee: attinasi → karnaze

Updated

17 years ago
Keywords: crash, topcrash
(Assignee)

Comment 3

17 years ago
I can't see any obvious problems in nsTableRowFrame::IR_TargetIsChild that might 
cause this. It would be useful if there were a line number.
(Assignee)

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 105275 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ nsTableRowFrame::IR_TargetIsChild]
You need to log in before you can comment on or make changes to this bug.