If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fix -Wreorder warnings in js/src/jsgc.cpp

RESOLVED DUPLICATE of bug 1013531

Status

()

Core
JavaScript: GC
RESOLVED DUPLICATE of bug 1013531
3 years ago
3 years ago

People

(Reporter: cpeterson, Assigned: cpeterson)

Tracking

(Blocks: 1 bug)

unspecified
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox31 unaffected, firefox32 affected)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Created attachment 8432061 [details] [diff] [review]
fix-Wreorder-warnings.patch

These are new clang warnings from AutoCheckCannotGC bug 1013531:

js/src/jsgc.cpp:1118:5 [-Wreorder] field 'helperState' will be initialized after field 'alwaysPreserveCode'
js/src/jsgc.cpp:1124:5 [-Wreorder] field 'lockOwner' will be initialized after field 'inUnsafeRegion'
Attachment #8432061 - Flags: review?(terrence)
Comment on attachment 8432061 [details] [diff] [review]
fix-Wreorder-warnings.patch

Review of attachment 8432061 [details] [diff] [review]:
-----------------------------------------------------------------

D'oh! I thought I fixed that before pushing. Thanks for the fix.
Attachment #8432061 - Flags: review?(terrence) → review+
Independently fixed by patch in the original bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1013531
You need to log in before you can comment on or make changes to this bug.