Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: angelo.borsotti, Unassigned)

Tracking

29 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

Opened a page in a new tab.


Actual results:

The page was displayed, but also a new window appeared on the desktop displaying ad.


Expected results:

The window was blocked.
I think that the desktop space is mine to manage, and only mine. No applications should
display extra windows that I do not know of. There are applications that display more than one window when run, but they are known, and are not unexpected. In this case instead
they are not expected and the user does not know that they will appear.
I think that besides an option "Block popup windows" another one is needed, that block new windows that are not opened manually by the user.
This will force sites that want to display ad to use layers on top of already opened windows or tabs, and will allow the user to dismiss such sites and their ads closing them with one single click.
It is difficult nowadays not to be bothered by ads, but something can be done to limit them at least not to mess up the desktop.

Comment 1

5 years ago
Your computer is infected by an adware, see
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware

You need to use a software to remove this adware like Adwcleaner. As it's a support question, bug report closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

5 years ago
Do you mean that an honest (non-adware) web page is prevented by Firefox
to open a window?

Comment 3

5 years ago
Adware are installed by extension or third-party software. If each time you open a webpage, another window pops up, so you're infected. That's all.
(Reporter)

Comment 4

5 years ago
I have removed ads with Adwcleaner. Then I have opened again the web page I suspected it could cause
the problem, and made another scan with Adwcleaner. It confirmed me that it was that page the culprit.
Thus, ads not only gets in the computer when I install software, but also when I open web pages with
Firefox.
Now, if Firefox could block the opening of new windows (of course, blocking done with some user
preference enabled), it could limit the bad effects of ads.
I think that having some safety belt is better than having none allowing thus ads to have all its way.
This is then my request: besides blocking pop-up windows, could add another checkbox to options->general
"block new windows"? and when a script in a web page attempts to open one issue a message "page xxx attempts
to open an window"?

Comment 5

5 years ago
Add-ons do that.
(Reporter)

Comment 6

5 years ago
I have searched the addon FF site, but found none.
Besides that, since FF has a "block popup" feature, for completeness it would be
appropriate to have also a "block window} feature.
You need to log in before you can comment on or make changes to this bug.