If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Group text messages (MMS) are not handled properly

RESOLVED DUPLICATE of bug 1106663

Status

Firefox OS
Gaia::SMS
RESOLVED DUPLICATE of bug 1106663
3 years ago
2 years ago

People

(Reporter: pdog, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: groupmms)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

Scenario 1:
1.) Sent a group message to multiple recipients (person B, C, and D)

Scenario 2:
1.) Received a group text message/group MMS from person B to me (person A), person C, and person D
2.) Attempted to reply to group MMS by viewing latest MMS received from person B and responding


Actual results:

Scenario 1:
Group message is sent as a regular SMS individually to person B, person C, and person D, as 3 separate conversations.

Scenario 2:
Reply was only sent to person B as a regular SMS. Persons C and D did not receive my message.


Expected results:

In scenario 1, the message should automatically be converted to MMS and it should start a new, single conversation between me and persons B, C, and D. This means that if D replies to the group message that I just created and sent, then persons B and C should also see D's reply. The group message should also appear as a separate, single conversation instead of as individual conversations with persons B, C, and D.

In scenario 2, when I reply to person B's group message, then it should automatically reply as an MMS message and both persons C and D should see the message as well. This is supposed to be a group conversation and it should be handled as such.

Currently, if person B starts a group text, then I can see MMS replies from C and D, but I can't follow the conversation because it does not appear as a single thread. All replies from C are listed as a separate conversation with him, and same for B and D. This means that if B and C are bickering back and forth with occasional input from D, I have no way of knowing what the context of the individual replies are.

Group MMS messages should be distinguishable from regular SMS. My conversation history with person B should only include SMS and picture/video messages. Group MMS, including group picture/video messages, should have a separate conversation history, and viewing and responding within that conversation history should automatically send a group message to all involved.
Scenario 1: it was made by purpose. We thought that
* more often, someone that adds several recipients does _not_ want to send a group MMS, but rather send the same message to several people. We found it quite disturbing that on some other phones, simply replying would send the group MMS to all recipients, even that the other phone does not give any indication that it was a group MMS (I think it was happening on iPhone).
* sending several SMS would be less costly than sending one MMS.

If you add a subject or an image we'll send a group MMS though.
This is definitely something we can revisit if we have enough feedback though. I can imagine a checkbox "send as a group MMS" for example.

Scenario 2: Group MMS is actually not _that_ easy and we didn't invest a lot of work in it yet. I mean, we invest a lot of work to make it work and then considered it was a lot more work to just make it work in a consistent way, so we just disabled it when receiving a message, and instead you see the behavior you see. I think that enabling group mms is just a matter of enabling a pref, maybe we can make it available in the Settings "developer" section.

see http://mzl.la/1gWIU1q for all bugs related to this feature.
(Reporter)

Comment 2

3 years ago
Thank you for the explanation. You're right in that it actually is a good idea to default to sending a regular SMS to multiple recipients first. I think the checkbox is a good and valuable idea because I would have never guessed that adding a subject would convert my message to a group MMS, which is what I wanted. Subjects are a nice feature in some circumstances, but it's way more tedious and less obvious than a simple check box.

As for scenario 2, adding a preference for enabling the behavior I described would be excellent, but why not add it to the messaging settings?

Also, I think it's most important right now for group MMS to appear as a single, separate conversation with the participants involved. If I receive a group message from person C who was responding to persons B and D, then I have no idea what the context of his reply is because his reply shows up in my personal conversation history with him instead. I believe that this is what is being discussed in bug 880243.

Thanks for your reply and to everyone who has been putting work into the OS.
(In reply to poordog from comment #2)
> Thank you for the explanation. You're right in that it actually is a good
> idea to default to sending a regular SMS to multiple recipients first. I
> think the checkbox is a good and valuable idea because I would have never
> guessed that adding a subject would convert my message to a group MMS, which
> is what I wanted. Subjects are a nice feature in some circumstances, but
> it's way more tedious and less obvious than a simple check box.

I'll file a separate bug for this and ask to our UX designers.

> 
> As for scenario 2, adding a preference for enabling the behavior I described
> would be excellent, but why not add it to the messaging settings?

Because the whole feature is not ready ;)

> 
> Also, I think it's most important right now for group MMS to appear as a
> single, separate conversation with the participants involved. If I receive a
> group message from person C who was responding to persons B and D, then I
> have no idea what the context of his reply is because his reply shows up in
> my personal conversation history with him instead.

Yes, I completely understand this, don't worry :) But we need to make it clear that this is a group MMS conversation.

To be fair, we have a lot of things on our plate right now, and group MMS is not really a priority for us. But if this interests you and you think you can help us working on it, we can try to feed you with UX and technical information.
(Reporter)

Comment 4

3 years ago
I understand that group MMS isn't exactly a top priority issue, it was just a feature that I had grown accustomed to from my old feature phone since my colleagues tend to use it very often. Unfortunately, my JS and web application knowledge is next to nil right now (trying to learn in my free time), but if there is any other way that I could help out, then I would be more than happy to. Thanks for explaining how I can at least initiate a group MMS for the time being and for taking the time to address this issue.
Bevis, do you know if it's possible to enable groupmms when receiving a message using a pref? Or is it a variable in RIL's code?
Flags: needinfo?(btseng)
Depends on: 1020209
(In reply to Julien Wajsberg [:julienw] from comment #5)
> Bevis, do you know if it's possible to enable groupmms when receiving a
> message using a pref? Or is it a variable in RIL's code?

Yes, there is a constant to toggle the support of MMS grouping:
http://hg.mozilla.org/releases/mozilla-b2g30_v1_4/file/31787cc4e43b/dom/mobilemessage/src/gonk/MobileMessageDB.jsm#l23

However, I found something wrong in MobileMessageDB.jsm if we enabled it.
I've filed bug 1020209 to address this.

In addition, I also found something abnormal in Gaia after applying the WIP patch in bug 1020209:
1. I still saw that only the sender of the MMS is listed in both the Thread List and in the Thread UI   (Composer).
2. If I killed SMS app, the participants will be listed correctly in both List and Composer.

I am not sure if this is intended in your current implementation.
Flags: needinfo?(btseng)
Yeah, group MMS is not working properly in Gaia, but at least maybe the user here might be able to try it and it could work good enough for him.

Thanks Bevis !

Comment 8

3 years ago
I just noticed that the bug I filed 1020841 is a dupe of this one. I did search but different combinations and I didn't see this bug, my apologies. 

The functionality where text messages are grouped together is extremely common. I use this every day to communicate with co-workers and friends. I saw that you were considering a button to enable grouping, as far as I know, other phones group text messages by default. All of the people I group text are able to join me in conversations on android and IOS but the way firefox OS currently handles group text messages has left me the odd man out. If you're going to create a toggle switch I think it would be best to enable group texting by default and allow someone to turn it off if they don't want the conversation grouped together as this is the way other phones work.

This bug is an extremely serious problem for me as I've come to rely on having the immediate ability to have group conversations with teams working on projects all over the country. I am very grateful that you guys are working on this bug.
Duplicate of this bug: 1020841
Our studies show that most people don't want to send group messages by default, although I understand the need to do this sometimes.

Also, the reception of group mms is not working right now, due to other higher priority work.
Just filed bug 1020893 to use a pref to enable/disable group mms.

Comment 12

3 years ago
(In reply to Julien Wajsberg [:julienw] from comment #10)
> Our studies show that most people don't want to send group messages by
> default, although I understand the need to do this sometimes.
> 
> Also, the reception of group mms is not working right now, due to other
> higher priority work.

I find this interesting. For example, I was at a BBQ on Easter with about 30 people. One family member was absent in another state. A mass group text message conversation was initiated by the ladies in our family with just about everyone at the BBQ included. Every single phone at the Easter celebration which was included in the mass family conversation supported group text messaging by default. The phones were all iphones or various android devices. I'm wondering if there is a modern smart phone that doesn't support group text messaging by default. 

The inability to participate in group text conversations has rendered the bulk of my work related communications impossible which is too bad because I really like the ZTE Open C. I have no choice but to go back to the old android phone I hoped to replace until this is fixed. 

I appreciate you responding to me as quickly as you did. Good luck with the development guys, take care.
(In reply to James from comment #12)
> (In reply to Julien Wajsberg [:julienw] from comment #10)
> > Our studies show that most people don't want to send group messages by
> > default, although I understand the need to do this sometimes.
> > 
> > Also, the reception of group mms is not working right now, due to other
> > higher priority work.
> 
> I find this interesting. For example, I was at a BBQ on Easter with about 30
> people. One family member was absent in another state. A mass group text
> message conversation was initiated by the ladies in our family with just
> about everyone at the BBQ included. Every single phone at the Easter
> celebration which was included in the mass family conversation supported
> group text messaging by default. The phones were all iphones or various
> android devices. I'm wondering if there is a modern smart phone that doesn't
> support group text messaging by default.

And that's actually what our studies showed as confusing. If you send a group MMS to say Bob and Alice, some phones don't show properly that it's a group MMS when they support it. So if Bob answers the group MMS, he will actually answered to both Alice and you, even if he intended to send it to you only.

So, if I'm not wrong, what you really want is being able to answer a group MMS using the same receivers.

There are several technical issues to do this.

For example, there is no easy and generic way to know your own phone number (some SIM cards include it, some others don't). I think iPhone and maybe some Android use a text message responder to find the user's phone number in a generic way, and maybe we could do this (after all we send some messages to the carrier to get the balance).

Without this, we can't answer reliably to a group MMS. Because when you receive a group MMS, your phone is in the "receivers" property just like other phones, and so, when you hit "reply", we need to remove your own phone number.

We already have most of the code needed to properly support group mms but face technical issues like this (this one is the biggest).

The other issue (IMO) is to find a proper UX to let the user send group MMS or several text when there are several recipients. And there are other UX questions, none unresolvable, but still unresolved.

> The inability to participate in group text conversations has rendered the
> bulk of my work related communications impossible which is too bad because I
> really like the ZTE Open C. I have no choice but to go back to the old
> android phone I hoped to replace until this is fixed. 

I'm sad :(

Is there any chance you can help with this? For example, if I can have a way to enable group MMS, could you test and report things that look weird for you?

Comment 14

3 years ago
(In reply to Julien Wajsberg [:julienw] from comment #13)
> And that's actually what our studies showed as confusing. If you send a
> group MMS to say Bob and Alice, some phones don't show properly that it's a
> group MMS when they support it. So if Bob answers the group MMS, he will
> actually answered to both Alice and you, even if he intended to send it to
> you only.

I recall standard non-smart flip phones suffering from this problem.

In the past I have received messages that have gone to a group where one party responds with information which they intended to send to only the author of the message only. However, it has been my experience the party who expects to respond to a single person, yet responds to many, is the odd duck in the group as modern phones support group messaging functionality by default. I have to message groups frequently and everyone's phone just works in this regard. 

The idea of a toggle switch or the ability to single someone out if need be is interesting. I personally leave the group text and select a single person's name to go to a private thread when I need to send private info. 

> So, if I'm not wrong, what you really want is being able to answer a group
> MMS using the same receivers.

I want to be able to select Alice and Bob and perhaps others, then initiate a group message which we can all read and respond to. If Alice and Bob start a conversation which includes me, I want to be able to respond to both of them in a common thread. I should be able to see their comments and mine together in either scenario.

Currently, when I'm texting Alice and Bob or Alice and Bob decide to text me, the messages are going to private threads as opposed to a common group thread. Alice and Bob are complaining and telling me to join the group conversation so other people can respond to my ideas too. 

I had an antiquated android phone running android 2.3.7 gingerbread which broke up the texts the way Firefox OS currently does. However, all of the modern phones I've encountered group texts by default. I was able to install a 3d party app https://hellotext.com/ on the antiquated android gingerbread phone which grouped texts together for me and brought me up to the current status of text messaging. Hello text is a fantastic messaging app. I would *love* to see its features integrated into firefox os. I know several people who have replaced their default messaging app with it. If you're seeking a behavior model for group text messaging I can't think of a better example than hello text. It makes communicating with many people extremely fast and easy.

> There are several technical issues to do this.
> 
> For example, there is no easy and generic way to know your own phone number
> (some SIM cards include it, some others don't). I think iPhone and maybe
> some Android use a text message responder to find the user's phone number in
> a generic way, and maybe we could do this (after all we send some messages
> to the carrier to get the balance).
>
> Without this, we can't answer reliably to a group MMS. Because when you
> receive a group MMS, your phone is in the "receivers" property just like
> other phones, and so, when you hit "reply", we need to remove your own phone
> number.
> 
> We already have most of the code needed to properly support group mms but
> face technical issues like this (this one is the biggest).

I'm not sure if this is relevant to the issue you're describing but when I select "settings" then "device information" my phone number is listed. T-Mobile is my carrier and all I had to do was plug in my sim card. No other configuration was necessary beyond manually imputing my contacts and setting up my email.

Regarding, removing my own number and comments from the common thread, my comments should appear in the thread too, so I'm not sure if it's necessary to remove what I'm saying from the common thread?  

> > The inability to participate in group text conversations has rendered the
> > bulk of my work related communications impossible which is too bad because I
> > really like the ZTE Open C. I have no choice but to go back to the old
> > android phone I hoped to replace until this is fixed. 
> 
> I'm sad :(
> 
> Is there any chance you can help with this? For example, if I can have a way
> to enable group MMS, could you test and report things that look weird for
> you?

I'm not much of a programmer but I am competent at following directions and skilled with computers. I'm working my way through a bachelors degree in IT and have been using linux and BSD for ten years. I'd be happy to follow any directions you give me and give you guys feedback.
(In reply to James from comment #14)
> I'm not sure if this is relevant to the issue you're describing but when I
> select "settings" then "device information" my phone number is listed.
> T-Mobile is my carrier and all I had to do was plug in my sim card. No other
> configuration was necessary beyond manually imputing my contacts and setting
> up my email.

You're the lucky one where we can actually get the number :) For example we can't on my 2 SIMs (Both Orange France).

> 
> Regarding, removing my own number and comments from the common thread, my
> comments should appear in the thread too, so I'm not sure if it's necessary
> to remove what I'm saying from the common thread?  


Thanks for the valuable input. Seeing that 2 different persons reported this in 1 week, I'll try to bump up the priority of this feature.
NI me to do some bug triage around groupmms.
Flags: needinfo?(felash)
(Reporter)

Comment 17

3 years ago
(In reply to Julien Wajsberg [:julienw] from comment #15)

> Thanks for the valuable input. Seeing that 2 different persons reported this
> in 1 week, I'll try to bump up the priority of this feature.

That's awesome news. I wish some other bugs around here could also get this kind of attention considering that more than 2 people have already expressed interest in them over the past 2 years.

I'm a little curious about the issue you mentioned about the sender's phone number also having the "receivers" property. As per James's comment, it just sounds like this means that we will see our own number and our own messages in the comment thread. This is actually a desired behavior and this is how group message threads should look anyway, but I'm guessing that I'm misunderstanding this issue.

My very basic feature phone handled group messages properly, and although I personally think they're annoying, I find that more of my colleagues are using them all of the time, and I can't take part in the conversations. If the UX team is open to suggestions, then I have a few ideas I could suggest, but right now, I would just really like the check box idea you suggested before. Unlike James, I don't have another phone that I can switch back to, so considering that I'm stuck using my Open C, I'd be more than happy to test new changes. Maybe flashing the phone will also fix the tons of other issues and bugs that I am facing right now.
You want to see them in your local thread (like a normal message), but you don't want to _send_ the MMS back to yourself.
Note: about the other issues you have, you might try to send a mail to dev-gaia, people will be able to tell you if it's fixed in newer versions (I'll assume you have v1.3 on the Open C ?), or otherwise if there is an existing bug, or if new bugs should be opened.
Flags: needinfo?(felash)
Flags: needinfo?(felash)

Comment 20

3 years ago
(In reply to Julien Wajsberg [:julienw] from comment #15)
> 
> You're the lucky one where we can actually get the number :) For example we
> can't on my 2 SIMs (Both Orange France).
>
> 
> Thanks for the valuable input. Seeing that 2 different persons reported this
> in 1 week, I'll try to bump up the priority of this feature.

Thank you very much. I want to stick with you guys.
Flags: needinfo?(felash)
Whiteboard: groupmms
Flags: needinfo?(felash)
It's been a long time.

I created a meta bug (bug 1106663) where the new work will happen, so let's dupe this bug there.

This is clearly not a priority right now, but some people asked me about this recently again. So let's try to move the technical issues forward.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(felash)
Resolution: --- → DUPLICATE
Duplicate of bug: 1106663
You need to log in before you can comment on or make changes to this bug.