SM 2.26: Dragging Newsgroup Post/article to Local Folder Hangs Folder

NEW
Unassigned

Status

5 years ago
2 months ago

People

(Reporter: srollin2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:29.0) Gecko/20100101 Firefox/29.0 SeaMonkey/2.26 (Beta/Release)
Build ID: 20140428215742

Steps to reproduce:

Tried to save a Newsgroup post to a Local Folder by selecting the post, dragging and dropping into the target Local Folder.


Actual results:

The target Local Folder becomes hung in Wait with a spinning "blue beach-ball" and cannot be accessed until SM is completely closed and restarted - simply closing and re-opening Mail/News has no effect.  Other Local Folders, Newsgroups, and Mail/News operations may still be accessed/displayed until the user attempts the same action for a new/different target Local Folder - then that target Folder also becomes hung in Wait for the remainder of session.


Expected results:

The selected post should be saved to the target Local Folder and the Local Folder contents should be readily available for normal display/access without hangup.

Comment 1

5 years ago
Sounds like Thunderbird Bug 1015536 (Drag drop suddenly misbehaving in version 24.5.0)
See Also: → bug 1015536
(Reporter)

Comment 2

5 years ago
Yes - I was in fact able to see/replicate this behavior in Thunderbird 31 on may Mac, and it's even worse in that case; there are also some display window blanking issues.  Looks like SM inherited the TB bug.
(Reporter)

Comment 3

5 years ago
Still broken in SM 2.29.
(Reporter)

Comment 4

4 years ago
Still broken in SM 2.33.1.
FYI Similar bug 1015536 has been closed WFM
Flags: needinfo?(srollin2)
Still a problem and I can reproduce it with Tb 60.1 too. Need to check if it is in 60.3.3 also.

In the Local Folders create a folder named a. In you newsgroup account folder (tested with news.mozilla.org and mozilla.support.seamonkey) pick a message and drag it to the a folder. Spinning wheel appears. macOS 2.49.5 and Windows 2016 2.53 x64.

In TB the message is moved but the spinning wheel still shows. In SeaMonkey only the spinng wheel shows. After restarting both the message shows up in the a folder.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(srollin2)
OS: Mac OS X → All
Hardware: x86 → All
Summary: SM 2.26 (Mac): Dragging Newsgroup Post to Local Folder Hangs Folder until Restart → SM 2.26: Dragging Newsgroup Post to Local Folder Hangs Folder until Restart
Created attachment 9031723 [details]
Capture.PNG

Wayne, still occurs with a freshly compiled TB 60.4. Indicator is spinning forever. Should we move the bug to shared mailnews or open a TB one in case you can someone reproduce it?
Flags: needinfo?(vseerror)
I can reproduce this on Thunderbird using 60 and 64
Component: MailNews: General → Backend
Flags: needinfo?(vseerror)
Product: SeaMonkey → MailNews Core
Summary: SM 2.26: Dragging Newsgroup Post to Local Folder Hangs Folder until Restart → SM 2.26: Dragging Newsgroup Post/article to Local Folder Hangs Folder
Version: SeaMonkey 2.26 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.