Closed Bug 1018705 Opened 6 years ago Closed 6 years ago

Fail to build xulrunner for the telemetry testcase of startupcache

Categories

(Toolkit Graveyard :: XULRunner, defect, major)

x86_64
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
mozilla33

People

(Reporter: sinker, Assigned: sinker)

Details

Attachments

(1 file, 2 obsolete files)

Attached patch fix-xulrunner-telemetry.diff (obsolete) — Splinter Review
Get the following message as building xulrunner with/without startupcache.

Makefile:72: FULL_NSPR_CFLAGS=-I\${includedir}
OMNIJAR_NAME=omni.ja \
        /home/thinker/progm/mozilla-central/obj-test/_virtualenv/bin/python /home/thinker/progm/mozilla-central/toolkit/mozapps/installer/packager.py -DMOZ_GLUE_IN_PROGRAM -DNO_NSPR_10_SUPPORT -DDLL_PREFIX=lib -DDLL_SUFFIX=.so -DBIN_SUFFIX= -DGRE_MILESTONE=32.0a1 -DGRE_BUILDID=20140601155945 -DMOZ_DEB_TIMESTAMP="Sun, 01  Jun 2014 16:47:53 +0800" -DMOZ_APP_NAME=xulrunner -Dinstalldir=/home/thinker/tmp/xulrunner/lib/xulrunner-32.0a1  \
                --format omni \
                 \
                --ignore-errors \
                 \
                 \
                 \
                --optimizejars \
                 \
                 ../../dist ../../dist/xulrunner \
                
Traceback (most recent call last):
  File "/home/thinker/progm/mozilla-central/toolkit/mozapps/installer/packager.py", line 402, in <module>
    main()
  File "/home/thinker/progm/mozilla-central/toolkit/mozapps/installer/packager.py", line 346, in main
    sink.close(args.manifest is not None)
  File "/home/thinker/progm/mozilla-central/python/mozbuild/mozpack/packager/__init__.py", line 366, in close
    self.packager.close()
  File "/home/thinker/progm/mozilla-central/python/mozbuild/mozpack/packager/__init__.py", line 298, in close
    self._queue.execute()
  File "/home/thinker/progm/mozilla-central/python/mozbuild/mozpack/packager/__init__.py", line 217, in execute
    function(*args)
  File "/home/thinker/progm/mozilla-central/toolkit/mozapps/installer/packager.py", line 229, in add_manifest
    self._formatter.add_manifest(entry)
  File "/home/thinker/progm/mozilla-central/python/mozbuild/mozpack/packager/formats.py", line 241, in add_manifest
    formatter, base, path = self._get_omnijar(entry.base)
  File "/home/thinker/progm/mozilla-central/python/mozbuild/mozpack/packager/formats.py", line 228, in _get_omnijar
    return self.omnijars[base], base, mozpack.path.relpath(path, base)
  File "/home/thinker/progm/mozilla-central/python/mozbuild/mozpack/path.py", line 27, in relpath
    rel = normsep(os.path.relpath(path, start))
  File "/home/thinker/progm/mozilla-central/obj-test/_virtualenv/lib/python2.7/posixpath.py", line 420, in relpath
    raise ValueError("no path specified")
ValueError: no path specified

After looking into the code, it is caused by packing TestStartupCacheTelemetry.js.
Comment on attachment 8432211 [details] [diff] [review]
fix-xulrunner-telemetry.diff

@Gregory, how do you think this patch?
Attachment #8432211 - Flags: feedback?(gps)
Comment on attachment 8432211 [details] [diff] [review]
fix-xulrunner-telemetry.diff

Review of attachment 8432211 [details] [diff] [review]:
-----------------------------------------------------------------

::: startupcache/test/Makefile.in
@@ +3,5 @@
>  # License, v. 2.0. If a copy of the MPL was not distributed with this
>  # file, You can obtain one at http://mozilla.org/MPL/2.0/.
>  
>  LIBS += $(MOZ_COMPONENT_LIBS)
> +EXTRA_COMPONENTS += \

If you change this to EXTRA_COMPONENTS, you should move it to a moz.build file.
Attachment #8432211 - Flags: feedback?(gps) → feedback+
Move EXTRA_COMPONENTS to moz.build.

@Gregory would you review it?
Attachment #8432211 - Attachment is obsolete: true
Attachment #8433044 - Flags: review?(gps)
Attachment #8433044 - Flags: review?(gps) → review+
Comment on attachment 8443873 [details] [diff] [review]
Install the test component of startupcach as one of EXTRA_COMPONENTS.

In the future, please just use the checkin-needed bug keyword. It plays more nicely with our bug marking tools :)
Attachment #8443873 - Flags: checkin? → checkin+
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Assignee: nobody → tlee
Target Milestone: --- → mozilla33
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.