If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

use new <wizard/> tag for Account Manager

VERIFIED FIXED in mozilla0.9.9

Status

SeaMonkey
MailNews: Account Configuration
P1
normal
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: Joe Hewitt (gone), Assigned: racham)

Tracking

(Depends on: 1 bug)

Trunk
mozilla0.9.9
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(10 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
The new wizard tag is far cleaner and has correct key handling and
platform-specific appearances, so we should use it for the account manager
instead of the old wizardOverlay crud.

Comment 1

16 years ago
The <wizard> binding can be fixed to set  initial focus it once I have a working
<wizard> to play with.
(Assignee)

Comment 2

16 years ago
Sure. Please update the bug once you get there. I will do the needful to get
going..Are we setting up any test wizard for testig this new <wizard> concept
and flow ? Please let me if it is the case. thanks.
Status: NEW → ASSIGNED

Comment 3

16 years ago
Can we start coding to the new Wizard tag or is it still a work in progress?
(Reporter)

Comment 4

16 years ago
Created attachment 53820 [details] [diff] [review]
wizard test case

Comment 5

16 years ago
I was working on this last week and expect to resume it soon, time permitting.
(Assignee)

Comment 6

16 years ago
Cool..!!

It looks neat and works great (impressive gain in keyboard navigation)...

Getting focus on the initial element (as mentioned earlier), movnig the focus
(by default) onto the Finish button are some improvements that can be done.

thanks,
bhuvan.

Comment 7

16 years ago
adding 0.9.7 milestone but if it got done sooner no one would object :)
Keywords: nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 8

16 years ago
I have the extended the test case with 2 more pages to test navigation further.
I found 2 categories of problems viz., focus and navigation.

Added to new test case i.e., wizardtest.xul (will post in the next update) as
messsenger.jar and opened it in place of accountwizard (modifying chrome urls in
http://lxr.mozilla.org/seamonkey/source/mailnews/base/prefs/resources/content/accountUtils.js#185

to point to wizardtest.xul) from AccountCentral page (or you can use
Tasks->Mail&Newsgropus->Mail&Newsgroups Account Settings->New Account).

Filed the following bugs on those issues (assigned to hewitt).

* bug 105850 - new <wizard> has some focus problems
* bug 105853 - new <wizard> has some navigation problems

Adding dependencies.
Depends on: 105850, 105853
(Assignee)

Comment 9

16 years ago
Created attachment 54374 [details]
wizard test case I have used (wizardtest.xul) placed in mozilla\mailnews\base\prefs\resources\content
(Assignee)

Comment 10

16 years ago
Shifting the current mail account wizard can be planned when all valid focus and
navigation problems are fixed.
(Assignee)

Updated

16 years ago
Depends on: 109997, 109998, 110000, 110001
No longer depends on: 105850, 105853
(Assignee)

Comment 11

16 years ago
*** Bug 111089 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

16 years ago
I spoke to Hewitt about the various bugs that need to be solved for this one to
procede further. Hewitt have those bugs targetted for 098 right now. Moving this
one to 098 too. However, as soon as he finds time to fix them, I will be
retesting the built-up-wizard I have to make sure we are progressing as expected.
Target Milestone: mozilla0.9.7 → mozilla0.9.8
(Assignee)

Comment 13

16 years ago
*** Bug 114069 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

16 years ago
*** Bug 111347 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
When verify: I would suggest to verify all scenarious from duplicate bugs.
(Assignee)

Comment 16

16 years ago
Hewitt has been knocking out critical wizard bugs. Thanks. We shall be done with
this new mail wizard in mozilla0.9.9. Moving the milestone accordingly.
Target Milestone: mozilla0.9.8 → mozilla0.9.9
(Assignee)

Comment 17

16 years ago
Created attachment 67397 [details] [diff] [review]
patch, v1.0 - adapting new <wizard/> for mail account wizard

Screen shots of wizard pages with new <wizard/> base are to follow. It is
important to note that user can navigate wizard pages using tabs, arrow keys
and Enter key.

In this patch, Account Wizard is concised into one XUL file with each of
screens attached defined as a wizardpage. Label entities are grouped into one
file.

Please do provide your feedback. I have tested navigation, mail/news account
creation, ISP account setup from rdf files, migration of 4.x accounts, sending
and receiving messages from accounts created.

There are couple of bugs which still need to be fixed in the base <wizard/>.
They are,
1. Bug 109997 - <wizard/> : doesn't display (default or manual) radio selection
on first launch
2. Bug 110000 - <wizard/> : 'Finish' button appears on the first page on coming
back from page2 to page1 in <wizard/>
3. Bug 122930 - <wizard/> : When pageIndex is used to start the wizard,
navigation fails on wizard rewind
4. Bug 122932 - <wizard/> : classic skin : mailnews wizard displays scroll bar
on a wizard page

Hewitt is aware of these bugs and will be fixing them soon.

Meanwhile, the patch posted works fine for regular use. Please provide review
comment so that we can get this into the tree soon and get wider coverage of
functionality test.
(Assignee)

Comment 18

16 years ago
Created attachment 67398 [details]
screenshot1 - Account Type page
(Assignee)

Comment 19

16 years ago
Created attachment 67399 [details]
screenshot2 - user identity information page
(Assignee)

Comment 20

16 years ago
Created attachment 67400 [details]
screenshot3 - mail server page
(Assignee)

Comment 21

16 years ago
Created attachment 67401 [details]
screenshot4 - user login name page
(Assignee)

Comment 22

16 years ago
Created attachment 67402 [details]
screenshot5 - account name page
(Assignee)

Comment 23

16 years ago
Created attachment 67403 [details]
screenshot6 - mail account congratulations page
(Assignee)

Comment 24

16 years ago
Created attachment 67404 [details]
screenshot7 - news account congratulations page
(Assignee)

Comment 25

16 years ago
Created attachment 67405 [details]
screenshot8 - news server page : classic skin
(Assignee)

Updated

16 years ago
Attachment #54374 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
Depends on: 122930, 122932
Keywords: patch
(Assignee)

Comment 26

16 years ago
In the last update, please read 

screenshot8 - news server page : classic skin

as 

screenshot8 - mail server page : classic skin




Comment 27

16 years ago
Comment on attachment 67397 [details] [diff] [review]
patch, v1.0 - adapting new <wizard/> for mail account wizard

a couple comments:

1) is it desireable to have all of the wizard panels defined in one big xul
file?  Or should we still try to keep them in separate files and bring them in
as overlays just for clarity.

From the diffs, I couldn't tell which .xul files were going away. Can you list
them?

Looks like we added a bunch of DTDs to AccountWizard.dtd, shouldn't these
strings have already been defined for the old account wizard? I didn't see
these strings getting removed from the original locations. Are we ending up
with 2 copies?
(Assignee)

Comment 28

16 years ago
1) is it desireable to have all of the wizard panels defined in one big xul
file?  Or should we still try to keep them in separate files and bring them in
as overlays just for clarity.

I believe it's faster to load pages if they are inline. Hewitt, how expensive
are overlays if we use them instead ? thanks.

If we end up putting all panels in one file i.e., AccountWizard.xul, the
following files will go away.

/mailnews/base/prefs/resources/content/aw-accname.xul
/mailnews/base/prefs/resources/content/aw-accounttype.xul
/mailnews/base/prefs/resources/content/aw-done.xul
/mailnews/base/prefs/resources/content/aw-identity.xul
/mailnews/base/prefs/resources/content/aw-login.xul
/mailnews/base/prefs/resources/content/aw-newsserver.xul
/mailnews/base/prefs/resources/content/aw-server.xul
/mailnews/base/prefs/resources/content/aw-wizardAdapter.js
/mailnews/base/prefs/resources/locale/en-US/aw-accounttype.dtd
/mailnews/base/prefs/resources/locale/en-US/aw-accname.dtd
/mailnews/base/prefs/resources/locale/en-US/aw-identity.dtd
/mailnews/base/prefs/resources/locale/en-US/aw-done.dtd
/mailnews/base/prefs/resources/locale/en-US/aw-email.dtd
/mailnews/base/prefs/resources/locale/en-US/aw-mailtype.dtd
/mailnews/base/prefs/resources/locale/en-US/aw-login.dtd
/mailnews/base/prefs/resources/locale/en-US/aw-server.dtd

Comment 29

16 years ago
The screenshots look great.  IMHO, one big file is probably better... perf-wise
as well.

Comment 30

16 years ago
Yeah, the shots look good, except...what's with the scrollbars in Classic?

Comment 31

16 years ago
Yeah, that's ugly.  See bug 122932 (a dependency on this bug).

Comment 32

16 years ago
Comment on attachment 67397 [details] [diff] [review]
patch, v1.0 - adapting new <wizard/> for mail account wizard

I'll defer to your judgement since you get to maintain it as to whether you
want several files or just one. 

sr=mscott
Attachment #67397 - Flags: superreview+
Comment on attachment 67397 [details] [diff] [review]
patch, v1.0 - adapting new <wizard/> for mail account wizard

R=ducarroz
Attachment #67397 - Flags: review+
(Assignee)

Comment 34

16 years ago
JFD & Scott, thanks for reviews. Thanks to Hewitt in fixing some core <wizard/>
bugs to let the progress continue on mailnews wizard.

We can expect to see bugs from tomorrow which are dupes of ones mentioned in
this bug (check dependencies). It is also possible to discover some new bugs and
I will fix them as they show up. Please use the new mailnews account wizard and
file bugs.

Fix checked in.

Marking fixed.

Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 35

16 years ago
Mozilla 2002020703, Windows 2000.
if I have a browser window open and a Mail & Newsgroups window open, then take
the Account Wizard for a ride, choosing Finish at the end of the wizard switches
focus to the browser window rather than returning it to the Mail & Newsgroups
window. this happened with my previous build from 20020204??. if this is the
wrong place to report this, sorry, let me know and I'll create a new bug

Comment 36

16 years ago
racham:
FWIW on Windows, do Alt-PrintScreen instead of PrintScreen to grab just the
current window. Easier than grabbing the whole screen and cropping, IMHO. Sorry
to spam a closed bug.

Comment 37

16 years ago
Trunk build 2002-02-11-03:WinMe
Trunk build 2002-02-11-11: Linux RH 7.1
Trunk build 2002-02-11: Mac 9.1, OS 10.1
Verified Fixed, although I experienced all the problems described in Comment# 17.
Status: RESOLVED → VERIFIED

Updated

16 years ago
Depends on: 125376
Product: Browser → Seamonkey
Blocks: 60649
You need to log in before you can comment on or make changes to this bug.