"Quick Filter of local mail folder with just Sender, Recipient, and Subject" does not find all hits

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
4 years ago
2 years ago

People

(Reporter: pinncons, Unassigned)

Tracking

24 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.131 Safari/537.36

Steps to reproduce:

Hard to reproduce.  I have an Inbox with 2500 items.  I do a search on Sender, and it shows me Emails.  I move them to a folder.  Later, I'll stumble across another Email with that Sender info, and I have to move it separately.  And it's not an email that came in after I did the initial search.


Actual results:

I keep finding Emails that Search missed.


Expected results:

Search should find all the Emails I asked for.
There are some kinds of search.
  (a) Search of Global Indexer and Search (Gloda search)
  (b-1) Search by "Search Folder"
  (b-2) Search of Edit/Find/Search Messages
  (c) Search of Quick Filter Bar
  (d) Pseudo Search by View/Custom View
And, there are two types if IMAP : Local Search / Online Search.
And, if IMAP, auto-sync is relevant to Body Search.
And, there is difference between "search of meta data held in .msf" and "search of message header data or message body data which is held in msgStore file"

Which case?

"Search does not find all hits" == false negative case == Should be found, but wasn't found.
If "false negative" happened on a mail in a mail folder, can Tb find the mail by next?
   Create a local mail folder, copy the mail to the new mail folder, Repair Folder,
   then do search at this folder which contains the mail only.

FYI.
  false positive which I could reproduce in non-Gloda search is following only:
     Bug 697021 (Body search)
  false negative which I could reproduce or I know in non-Gloda search is following only:
     Bug 697021 (Body search), 
     Search of multiple-header header except Received: fails, becuse search searches first occurrence only.
     IMAP server doesn't return correct result in Online search request.
  pseudo false negative :
     If IMAP with Offline-Use=Off, message body is not held locally. So "Local body Search" doesn't work.
     If IMAP with Offline-Use=Off,  and if customized header,  the header is not held locally, so local search for it doesn't work.
(Reporter)

Comment 2

4 years ago
My server is POP3.  This happens in QuickFilter.  Oddly enough, I haven't seen the misses with Body, just Sender, Recipient, and Subject.  I performed the Repair Folder and will let you know if I have a reoccurrence.
Summary: Search does not find all hits → "Quick Search of local mail folder with just Sender, Recipient, and Subject" does not find all hits

Comment 3

4 years ago
(In reply to Tom from comment #2)
> My server is POP3.  This happens in QuickFilter.  Oddly enough, I haven't
> seen the misses with Body, just Sender, Recipient, and Subject.  I performed
> the Repair Folder and will let you know if I have a reoccurrence.

results?
Component: Untriaged → Search
Flags: needinfo?(pinncons)
Summary: "Quick Search of local mail folder with just Sender, Recipient, and Subject" does not find all hits → "Quick Filter of local mail folder with just Sender, Recipient, and Subject" does not find all hits

Comment 4

2 years ago
Tom seems to be gone
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(pinncons)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.