Single word (foo) searches try to load http://foo

RESOLVED DUPLICATE of bug 854305

Status

()

RESOLVED DUPLICATE of bug 854305
4 years ago
2 years ago

People

(Reporter: mfinkle, Unassigned)

Tracking

unspecified
Other
Android
Points:
---

Firefox Tracking Flags

(fennec33+)

Details

Seems recent. Multi-word searches work.

Updated

4 years ago
tracking-fennec: --- → ?
I think we've always done this. Desktop does too. Typing 'newegg' should take you to newegg.com. It would be nice if we could detect 404's from those searches and redirect to a search. The search widget work was a way to get us partway there (i.e. make it easy to do the search, even if we didn't kick it off for you).
Even if Desktop does this, we are different. We have a single search/URL box. It's a pain.
Actually, trying today in Nightly, Desktop does search. So does Fennec for me. We're you really using "foo" or were you using something else?

On Desktop I've only seen this problem when you type something like window.alert. It tries to make that a domain, when it should search.

Comment 4

4 years ago
Searching for "foo" just worked for me on the latest Nightly.

Are you on some shady network that's trying to do some DNS hijacking?
(In reply to :Margaret Leibovic from comment #4)
> Searching for "foo" just worked for me on the latest Nightly.
> 
> Are you on some shady network that's trying to do some DNS hijacking?

Could be that. I was using hotel Wifi. It works fine on my home Wifi. But turning off Wifi and using AT&T results in http://foo again.

(In reply to Wesley Johnston (:wesj) from comment #3)
> Actually, trying today in Nightly, Desktop does search. So does Fennec for
> me. We're you really using "foo" or were you using something else?

I was trying baseball and baby and coaster. All were failing.
I wonder if some IME's are trying to do fixup for us or something.

Comment 7

4 years ago
(In reply to Wesley Johnston (:wesj) from comment #6)
> I wonder if some IME's are trying to do fixup for us or something.

I don't know that it's an IME issue, if it changed for mfinkle depending on the wifi network.

Isn't bnicholson trying to work on the number searching problem? Maybe the solution to that problem will help fix this one.
Flags: needinfo?(bnicholson)
Err. Yeah, I realized after I wrote this. If I had to guess, I'd guess that we're trying to do a DNS search for the host to determine if we do a search or load what is typed. Most times it fails. On captive portals its getting redirected so that it appears to succeed.

Comment 9

4 years ago
Should this just be duped to bug 854305?
(In reply to :Margaret Leibovic from comment #7)
> Isn't bnicholson trying to work on the number searching problem? Maybe the
> solution to that problem will help fix this one.

The number problem was already fixed (bug 993705), but yeah, we could probably adapt that patch to fix this bug (https://bugzilla.mozilla.org/show_bug.cgi?id=854305#c7).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(bnicholson)
Resolution: --- → DUPLICATE
Duplicate of bug: 854305
tracking-fennec: ? → +
tracking-fennec: + → 33+
You need to log in before you can comment on or make changes to this bug.