Unable to add a bookmark to homescreen

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Browser
P1
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: viorela, Assigned: daleharvey)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
# Prerequisities:
Connect to network

#STR:
1. Launch Browser app
2. In the url bar type: http://mozqa.com/data/firefox/layout/mozilla.html
3. Press Bookmark button
4. Tap Add to homescreen
5. Enter a name in the website name field - Add link page (E.g. gaia1234)
6. Tap Add to Home Screen
7. Touch home button to get to Homescreen
8. Search for the bookmark you just added 

#Expected results:
The bookmark title is displayed on the first page of Homescreen

#Actual results
The bookmark title is not displayed on any of the Homescreen pages -> the bookmark is not installed on Homescreen

First failing build: 
Gaia      e98fe1e94d3d80ad36903500d8ca3333904b162c
Gecko     https://hg.mozilla.org/mozilla-central/rev/85f6afe5cdde
BuildID   20140531160201
Version   32.0a1
ro.build.version.incremental=eng.tclxa.20131223.163538
ro.build.date=Mon Dec 23 16:36:04 CST 2013

Last working build:
Gaia      26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko     https://hg.mozilla.org/mozilla-central/rev/e6f113c83095
BuildID   20140530040207
Version   32.0a1
ro.build.version.incremental=eng.tclxa.20131223.163538
ro.build.date=Mon Dec 23 16:36:04 CST 2013

I was able to reproduce the failure manually and also by running the automated test.
This is not reproducible on v1.4.

Jenkins report: http://selenium.qa.mtv2.mozilla.com:8080/view/B2G%20Hamachi/job/b2g.hamachi.mozilla-central.ui.non-smoketest/388/HTML_Report/
(Reporter)

Updated

4 years ago
Priority: -- → P1
(Assignee)

Comment 1

4 years ago
Ill take a look at this
Assignee: nobody → dale
(Assignee)

Comment 2

4 years ago
I cant reproduce this on master gaia with an old gecko, this may be related to gecko issues people have been mentioning recently, flashing latest build
I think we should really wait for bug 1018406 to get fixed & then retest this. bug 1018406 has literally broken the world on the homescreen, so I'm not sure if there's value in opening new bugs right now on trunk for homescreen.
Depends on: 1018406
(Assignee)

Comment 4

4 years ago
Tested on latest master gecko + gaia, working here, I think this was a broken gecko glitch
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
No longer depends on: 1018406
(Reporter)

Comment 5

4 years ago
I had to reopen the bug as this issue is reproducible again on the latest v2.0 build. 
I'm not able to add a bookmark to Homescreen. 

#ENV:
Device: Flame
Gaia      d2cfef555dabab415085e548ed44c48a99be5c32
Gecko     https://hg.mozilla.org/mozilla-central/rev/51b428be6213
BuildID   20140605040202
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
The UX has entirely changed on trunk right now, so I don't think it makes sense to reopen this bug. Please open a new bug for the issue you have found.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(viorela.ioia)
Resolution: --- → WORKSFORME
(Reporter)

Updated

4 years ago
Flags: needinfo?(viorela.ioia)
You need to log in before you can comment on or make changes to this bug.