[System] Intermittent Marionette JS Failure on Travis: mozChromeNotifications: Sending one notification, remove from tray, resend: ScriptTimeout: (28) timed out

RESOLVED DUPLICATE of bug 1011158

Status

RESOLVED DUPLICATE of bug 1011158
5 years ago
5 years ago

People

(Reporter: julienw, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8432391 [details]
Screenshot when the failure happens

1) mozChromeNotifications: Sending one notification, remove from tray, resend:

ScriptTimeout: (28) timed out

Remote Stack:

<none>

at Error.MarionetteError (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/error.js:67:13)

at Object.Client._handleCallback (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:476:19)

at /home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:510:21

at TcpSync.send (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/drivers/tcp-sync.js:100:10)

at Object.send (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:457:36)

at Object.Client._sendCommand (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:503:19)

at Object._executeScript (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:1468:19)

at Object.executeAsyncScript (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:1249:19)

at Context.<anonymous> (/home/travis/build/mozilla-b2g/gaia/apps/system/test/marionette/notification_resend_test.js:195:20)

at Test.Runnable.run (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:196:15)

at Runner.runTest (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:374:10)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:452:12

at next (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:299:14)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:309:7

at next (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:247:23)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:271:7

at done (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:185:5)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:199:9

at Object.executeHook (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:369:18)

at process._tickCallback (node.js:415:13)
Bad, it smells like the mozResendAllNotifications callback is never called.
Maybe that is another manifestation of bug 1011158 and all of those are a symptom of the Notification DB task queue getting blocked?
Flags: needinfo?(mhenretty)
I suspect this may be fixed by making Notification DB more robust with promises, in bug 1003050.
Depends on: 1003050
(In reply to Alexandre LISSY :gerard-majax from comment #2)
> Maybe that is another manifestation of bug 1011158 and all of those are a
> symptom of the Notification DB task queue getting blocked?

I agree these things seem related. mozResendNotification doesn't use Notification.get, so this is probably related to the NotificationDB startup code. Fixing bug 1003050 sounds like a good first step here. Thanks for taking this on!
Flags: needinfo?(mhenretty)
As of bug 1011158, we identified that OS.File was having an improper behavior making the Notification API stuck ; bug is now fixed, and chances are that the present bug is just another symptom of the same root cause.

I'm closing this bug as a dupe of bug 1011158. Feel free to re-open if it happens again :)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1011158
You need to log in before you can comment on or make changes to this bug.