Closed Bug 1018940 Opened 6 years ago Closed 6 years ago

Intermittent browser_net_html-preview.js | Test timed out

Categories

(DevTools :: Netmonitor, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 872379

People

(Reporter: cbook, Unassigned)

References

()

Details

(Keywords: intermittent-failure)

Rev5 MacOSX Mountain Lion 10.8 mozilla-inbound opt test mochitest-devtools-chrome on 2014-06-02 02:39:07 PDT for push ab302f484e0c

slave: talos-mtnlion-r5-046

https://tbpl.mozilla.org/php/getParsedLog.php?id=40851102&tree=Mozilla-Inbound



TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_html-preview.js | Test timed out
It seems that "http://example.com/browser/browser/devtools/netmonitor/test/sjs_content-type-test-server.sjs?fmt=bogus" isn't fully loading, but just *sometimes*, based on the following log: 

19:06:36     INFO -    "http://example.com/browser/browser/devtools/netmonitor/test/sjs_content-type-test-server.sjs?fmt=bogus": {
19:06:36     INFO -      "UPDATING_REQUEST_HEADERS": 1,
19:06:36     INFO -      "RECEIVED_REQUEST_HEADERS": 1,
19:06:36     INFO -      "UPDATING_REQUEST_COOKIES": 1,
19:06:36     INFO -      "RECEIVED_REQUEST_COOKIES": 1,
19:06:36     INFO -      "UPDATING_REQUEST_POST_DATA": 0,
19:06:36     INFO -      "RECEIVED_REQUEST_POST_DATA": 0,
19:06:36     INFO -      "UPDATING_RESPONSE_HEADERS": 0,
19:06:36     INFO -      "RECEIVED_RESPONSE_HEADERS": 0,
19:06:36     INFO -      "UPDATING_RESPONSE_COOKIES": 0,
19:06:36     INFO -      "RECEIVED_RESPONSE_COOKIES": 0,
19:06:36     INFO -      "STARTED_RECEIVING_RESPONSE": 0,
19:06:36     INFO -      "UPDATING_RESPONSE_CONTENT": 0,
19:06:36     INFO -      "RECEIVED_RESPONSE_CONTENT": 0,
19:06:36     INFO -      "UPDATING_EVENT_TIMINGS": 0,
19:06:36     INFO -      "RECEIVED_EVENT_TIMINGS": 0
19:06:36     INFO -    }

Everything except UPDATING_REQUEST_POST_DATA and RECEIVED_REQUEST_POST_DATA should be 1.
Has not occurred since fix for bug 872379 landed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 872379
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.