Build error in bitmap.h : undefined reference to 'ffsl'

RESOLVED DUPLICATE of bug 965870

Status

()

Core
Memory Allocator
RESOLVED DUPLICATE of bug 965870
4 years ago
4 years ago

People

(Reporter: mhaigh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
I'm unable to build Fennec with the r8e NDK toolchain on OSX.

Log:

 1:02.02 libxul.so
 1:42.47 libreplace_jemalloc.so
 1:42.61 Executing: /usr/local/bin/ccache /Users/martyn/android-ndk-r8e/toolchains/arm-linux-androideabi-4.7/prebuilt/darwin-x86_64/bin/arm-linux-androideabi-g++ -idirafter /Users/martyn/android-ndk-r8e/platforms/android-9/arch-arm/usr/include -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Werror=int-to-pointer-cast -Wtype-limits -Wempty-body -Wsign-compare -Wno-invalid-offsetof -mandroid -fno-short-enums -fno-exceptions -Wno-psabi -march=armv7-a -mthumb -mfpu=vfp -mfloat-abi=softfp -mno-unaligned-access -isystem ../../../../build/stlport/stlport -isystem /Users/martyn/android-ndk-r8e/sources/cxx-stl/system/include -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -std=gnu++0x -pipe -DDEBUG -DTRACING -g -funwind-tables -fPIC -shared -Wl,-z,defs -Wl,-h,libreplace_jemalloc.so -o libreplace_jemalloc.so /Users/martyn/Mozilla/git-master/objdir-droid/memory/replace/jemalloc/tmp1JykpE.list -mandroid -L/Users/martyn/android-ndk-r8e/platforms/android-9/arch-arm/usr/lib -Wl,-rpath-link=/Users/martyn/android-ndk-r8e/platforms/android-9/arch-arm/usr/lib --sysroot=/Users/martyn/android-ndk-r8e/platforms/android-9/arch-arm -llog -Wl,--allow-shlib-undefined -mthumb -Wl,-z,noexecstack -Wl,-z,text -Wl,--build-id -Wl,-rpath-link,/Users/martyn/Mozilla/git-master/objdir-droid/dist/bin -Wl,-rpath-link,/usr/local/lib ../../../build/stlport/libstlport_static.a -static-libstdc++
 1:42.61 /Users/martyn/Mozilla/git-master/objdir-droid/memory/replace/jemalloc/tmp1JykpE.list:
 1:42.61     INPUT("jemalloc_config.o")
 1:42.61     INPUT("mozjemalloc_compat.o")
 1:42.61     INPUT("pthread_atfork.o")
 1:42.61     INPUT("../../jemalloc/arena.o")
 1:42.61     INPUT("../../jemalloc/atomic.o")
 1:42.61     INPUT("../../jemalloc/base.o")
 1:42.61     INPUT("../../jemalloc/bitmap.o")
 1:42.61     INPUT("../../jemalloc/chunk.o")
 1:42.61     INPUT("../../jemalloc/chunk_dss.o")
 1:42.61     INPUT("../../jemalloc/chunk_mmap.o")
 1:42.61     INPUT("../../jemalloc/ckh.o")
 1:42.61     INPUT("../../jemalloc/ctl.o")
 1:42.61     INPUT("../../jemalloc/extent.o")
 1:42.61     INPUT("../../jemalloc/hash.o")
 1:42.61     INPUT("../../jemalloc/huge.o")
 1:42.61     INPUT("../../jemalloc/jemalloc.o")
 1:42.61     INPUT("../../jemalloc/mb.o")
 1:42.61     INPUT("../../jemalloc/mutex.o")
 1:42.61     INPUT("../../jemalloc/prof.o")
 1:42.61     INPUT("../../jemalloc/quarantine.o")
 1:42.61     INPUT("../../jemalloc/rtree.o")
 1:42.61     INPUT("../../jemalloc/stats.o")
 1:42.61     INPUT("../../jemalloc/tcache.o")
 1:42.61     INPUT("../../jemalloc/tsd.o")
 1:42.61     INPUT("../../jemalloc/util.o")
 1:42.61
 1:42.61 /Users/martyn/Mozilla/git-master/memory/jemalloc/src/include/jemalloc/internal/bitmap.h:133: error: undefined reference to 'ffsl'
 1:42.61 /Users/martyn/Mozilla/git-master/memory/jemalloc/src/include/jemalloc/internal/bitmap.h:137: error: undefined reference to 'ffsl'
 1:42.61 collect2: error: ld returned 1 exit status
 1:42.61 make[5]: *** [libreplace_jemalloc.so] Error 1
 1:42.61 make[4]: *** [memory/replace/jemalloc/libs] Error 2
 1:42.61 make[3]: *** [libs] Error 2
 1:42.61 make[2]: *** [default] Error 2
 1:42.61 make[1]: *** [realbuild] Error 2
 1:42.61 make: *** [build] Error 2
 1:42.64 440 compiler warnings present.



Moz config:
mk_add_options MOZ_OBJDIR="$MOZ_OBJ/objdir-droid"

ac_add_options --with-android-ndk="$HOME/android-ndk-r8e"
ac_add_options --with-android-sdk="$HOME/android-sdk-macosx/platforms/android-17"
ac_add_options --with-android-version=9

ac_add_options --enable-android-synthapks

# android options
ac_add_options --enable-application=mobile/android
ac_add_options --target=arm-linux-androideabi

ac_add_options --with-ccache

mk_add_options AUTOCLOBBER=1

ac_add_options --enable-updater
ac_add_options --enable-update-channel=nightly

ac_add_options --enable-debug
ac_add_options --disable-optimize






I see this too when building debug, although I don't see it when building optimized.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 965870
You need to log in before you can comment on or make changes to this bug.