If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Try server: builds triggered for platforms that weren't specified in the commit message

RESOLVED DUPLICATE of bug 942167

Status

Release Engineering
General
RESOLVED DUPLICATE of bug 942167
3 years ago
5 months ago

People

(Reporter: bbouvier, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
In the try commit message, I only put MacOS 10.6/10.8, and builds were also triggered on B2G emulators.

See for instance https://tbpl.mozilla.org/?tree=Try&rev=4f702beeb85f

try: -b do -e -p macosx64 -u jittests[10.6,10.8] -t none
Note to whoever picks this up: this is where the code is:

bhearsum
15:55:35 https://github.com/mozilla/build-buildbotcustom/blob/master/try_parser.py
pmoore|buildduty
15:55:44 ah, perfect!
15:55:45 thanks ben
bhearsum
15:55:50 it's got tests, too: https://github.com/mozilla/build-buildbotcustom/blob/master/test/test_try_parser.py
I don't see anything other than Mac builds and Mac jittests on that push. Did you by any chance, in whatever push you actually did see it, catch the mistaken periodic nonunified emulator builds that bug 942167 comment 76 says we need to get rid of, because come on, periodic builds on try?
(Reporter)

Comment 3

3 years ago
(In reply to Phil Ringnalda (:philor) from comment #2)
> I don't see anything other than Mac builds and Mac jittests on that push.
> Did you by any chance, in whatever push you actually did see it, catch the
> mistaken periodic nonunified emulator builds that bug 942167 comment 76 says
> we need to get rid of, because come on, periodic builds on try?

Ha, sorry, I may have cancelled the builds as they were unexpected, in order to spare some CPU energy. I remember seeing that the emulator builds were nonunified, so i might have triggered the periodic builds, indeed.
Indeed, https://secure.pub.build.mozilla.org/buildapi/self-serve/try/rev/4f702beeb85f.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 942167
(Assignee)

Updated

5 months ago
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.