[B2G][OTA][1.4] 6/2/2014 Unable to OTA

RESOLVED DUPLICATE of bug 1019170

Status

Release Engineering
General Automation
RESOLVED DUPLICATE of bug 1019170
3 years ago
3 years ago

People

(Reporter: Josh Schmitt [Joshs], Unassigned)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(b2g-v1.4 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8432567 [details]
log.txt

Description:
User is unable to update via OTA.

Repro Steps:
1) Update a Flame to 20140530000202
2) Open settings and turn on Wifi
3) Proceed to 'Device Information'
4) Select 'Check Now'

Actual:
After checking for updates it says 'this is already on the latest version on FFOS'.

Expected:
OTA update is downloaded.

Environmental Variables:
Device: Flame
Build ID: 20140530000202
Gaia: fe612fd21389193a8e593aa718831602e5086a62
Gecko: 25011f9a8f26
Version: 30.0 (1.4) 
Firmware Version: v10G-2

Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Notes:
Repro frequency: 100%
See attached: logcat

I will test on Buri and post my results.
(Reporter)

Comment 1

3 years ago
Issue repros on 1.4 Buri.

Updated

3 years ago
Keywords: qaurgent, regression, regressionwindow-wanted

Updated

3 years ago
QA Contact: ddixon

Updated

3 years ago
blocking-b2g: --- → 1.4?

Comment 2

3 years ago
Are we sure the build is not already updated?   according to the logcat, it says its already on the latest version.


06-02 11:33:45.028: E/GeckoConsole(291): AUS:SVC UpdateService:selectUpdate - skipping update because the update's application version is less than the current application version
06-02 11:33:45.028: I/Gecko(291): UpdatePrompt: Setting gecko.updateStatus: already-latest-version

Please double check the version again after restarting the device

Comment 3

3 years ago
(In reply to Tony Chung [:tchung] from comment #2)
> Are we sure the build is not already updated?   according to the logcat, it
> says its already on the latest version.
> 
> 
> 06-02 11:33:45.028: E/GeckoConsole(291): AUS:SVC UpdateService:selectUpdate
> - skipping update because the update's application version is less than the
> current application version
> 06-02 11:33:45.028: I/Gecko(291): UpdatePrompt: Setting gecko.updateStatus:
> already-latest-version
> 
> Please double check the version again after restarting the device

Yes, it's still 5/30 after restart.
When checking for updates initially it already says this is the latest version even though the device is on 5/30. After restarting device it still shows 5/30 build and still says the latest version when checking for Update.

Comment 4

3 years ago
Created attachment 8432702 [details]
logcat_from_today_to_friday

What's weird though, after flashing to today's (6/02) build system update shows up. When install it, it'll update to Friday's (5/30) build, see the logcat for more info.

'From' build info:
BuildID: 20140602000203
Gaia: ba8d7ef46cadf5d66d189b0b036d0f2e936bece0
Gecko: 384d3410a854
Version: 30.0

'To' build info:
BuildID: 20140530000202
Gaia: fe612fd21389193a8e593aa718831602e5086a62
Gecko: 25011f9a8f26
Version: 30.0
aki, any ideas if this is a releng issue ?
Flags: needinfo?(aki)

Comment 6

3 years ago
Non-flame is bug 1019170.

For Flame, was it originally a Moco-releng-provided pvtbuilds build, or a partner build?
Flags: needinfo?(aki)
(In reply to Aki Sasaki [:aki] from comment #6)
> Non-flame is bug 1019170.
> 
> For Flame, was it originally a Moco-releng-provided pvtbuilds build, or a
> partner build?

Flame 1.4 (and older) is also bug 1019170. These should be fixed when the nightlies finish this evening.
(In reply to Aki Sasaki [:aki] from comment #6)
> For Flame, was it originally a Moco-releng-provided pvtbuilds build, or a
> partner build?

If anyone is having issues with Flame updates on mozilla-centra/master/2.0, it's probably bug 1018276, which I think is what you were getting at here.
Unable to provide Regression Window for this issue. 

I tested earlier and later builds surrounding the build listed in comment 0.  

Every build will update to the exact same build in comment 0.  
This leads me to believe that this is an external issue.  

The device will update to the following build: 

Environmental Variables:
Device: Flame
Build ID: 20140530000202
Gaia: fe612fd21389193a8e593aa718831602e5086a62
Gecko: 25011f9a8f26
Version: 30.0 (1.4) MOZ
Firmware Version: v10G-2
Keywords: qaurgent, regressionwindow-wanted
Going to mark this dependent on bug 1019170 since that appears to be what we need to fix here.
Component: General → General Automation
Depends on: 1019170
Product: Firefox OS → Release Engineering
(In reply to Jason Smith [:jsmith] from comment #10)
> Going to mark this dependent on bug 1019170 since that appears to be what we
> need to fix here.

Arguably it's a dupe, but it doesn't really matter. AFAIK this is fixed now. The snippets look fine to me, and someone in #b2g got an update to their hamachi device.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
blocking-b2g: 1.4? → ---
No longer depends on: 1019170
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1019170
You need to log in before you can comment on or make changes to this bug.