[B2G][Camera]Taking a picture with flash and timer enabled causes the camera to freeze

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Camera
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: astole, Assigned: justindarc)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:1.4+, b2g-v1.4 affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8432713 [details]
logcat

If the timer is set to either 5 seconds or 10 seconds and the flash is enabled, the camera freezes during the countdown at either 1 or 2 seconds. The only way to get out of the frozen state is by force closing the app. This issue does not occur if the timer is set for 3 seconds and occurs more frequently after at least one picture is taken.

Repro Steps:
1) Update a Flame to BuildID: 20140602000203
2) Open the camera app
3) Take a picture
4) Enable the flash and set the timer to either 5 or 10 seconds
5) Take a picture

Actual:
Camera app freezes at either 1 or 2 seconds during the countdown

Expected:
Camera app doesn't freeze and a picture is taken

1.4 Environmental Variables:
Device: Flame 1.4 MOZ
BuildID: 20140602000203
Gaia: ba8d7ef46cadf5d66d189b0b036d0f2e936bece0
Gecko: 384d3410a854
Version: 30.0
Firmware Version: v10G-2

Repro frequency: 2/2, 90%
See attached: Video, logcat

Comment 1

4 years ago
let's check that on Buri
Keywords: qawanted
I am not able to reproduce this on Flame using:

Gaia   ba8d7ef46cadf5d66d189b0b036d0f2e936bece0
SourceStamp 384d3410a854
BuildID 20140602000203
Version 30.0
v10G-2

I set the timer at 5 seconds and it counted down and took the picture.
(Reporter)

Comment 3

4 years ago
Sometimes it takes a few attempts to get the issue to occur. The issue was reproducible on 3/3 devices.

Attaching a video of the issue.
status-b2g-v1.4: --- → affected
(Reporter)

Comment 4

4 years ago
User agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Flags: needinfo?(jdarcangelo)
(In reply to Andrew Stole from comment #4)
> User agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Andrew: Does this mean you can reproduce on trunk as well?
Flags: needinfo?(astole)
(Reporter)

Comment 6

4 years ago
Sorry, the device I was using to check the user agent was on the incorrect build. I was not able to reproduce this issue on trunk.

User agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
Flags: needinfo?(astole)
(Assignee)

Comment 7

4 years ago
(In reply to Andrew Stole from comment #6)
> Sorry, the device I was using to check the user agent was on the incorrect
> build. I was not able to reproduce this issue on trunk.
> 
> User agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Should this be closed then?
Flags: needinfo?(jdarcangelo) → needinfo?(astole)
(Reporter)

Comment 8

4 years ago
No, this should not be closed. The issue occurs on 1.4 but does not occur on trunk.
Flags: needinfo?(astole)
For QA Wanted - can we validate that the reproduction rate is correct here?
Reproduced 5 out of 6 tries for me on different device than the original reporter.

Result: Camera app freezes at either 1 or 2 seconds during the countdown

Environmental Variables:
Device: Flame v1.4
BuildID: 20140603000203
Gaia: d108159874cb594e7068a5c8384f05f0a8910bfd
Gecko: 42d80aea48e3
Version: 30.0
Firmware Version: v10G-2
Keywords: qawanted
In that case, the timer isn't working correctly with 5 seconds then in most cases.
blocking-b2g: --- → 1.4?
(Assignee)

Updated

4 years ago
Assignee: nobody → jdarcangelo
blocking-b2g: 1.4? → 1.4+
(Assignee)

Comment 12

4 years ago
Not able to reproduce on:

Gaia      0c16adced7c51f795ef250aebe184f60b6a9b987
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/04216748e6c1
BuildID   20140604000202
Version   30.0
Firmware Version: v10G-2
(Assignee)

Comment 13

4 years ago
(In reply to Brogan Zumwalt from comment #10)
> Reproduced 5 out of 6 tries for me on different device than the original
> reporter.
> 
> Result: Camera app freezes at either 1 or 2 seconds during the countdown
> 
> Environmental Variables:
> Device: Flame v1.4
> BuildID: 20140603000203
> Gaia: d108159874cb594e7068a5c8384f05f0a8910bfd
> Gecko: 42d80aea48e3
> Version: 30.0
> Firmware Version: v10G-2

I flashed my Flame back to this version and was still unable to reproduce it. Can we get a video of the STR?
(In reply to Justin D'Arcangelo [:justindarc] from comment #13)
> (In reply to Brogan Zumwalt from comment #10)
> > Reproduced 5 out of 6 tries for me on different device than the original
> > reporter.
> > 
> > Result: Camera app freezes at either 1 or 2 seconds during the countdown
> > 
> > Environmental Variables:
> > Device: Flame v1.4
> > BuildID: 20140603000203
> > Gaia: d108159874cb594e7068a5c8384f05f0a8910bfd
> > Gecko: 42d80aea48e3
> > Version: 30.0
> > Firmware Version: v10G-2
> 
> I flashed my Flame back to this version and was still unable to reproduce
> it. Can we get a video of the STR?

The video is here - http://youtu.be/Ms7w6uQKBQ4
I tried across multiple devices.  It seems there is a 90% chance of getting into the erroneous state from which point this bug reproduces by the third picture taken.  

Once in this state 60% of the time it happens with the first picture taken, it didn't take me longer than taking 3 pictures with a 5 second timer. 

To reset the state, close out the Camera app and relaunch it and rerun the STR's laid out in Comment 0.  The other 10% I was in a state where the bug simply did not reproduce with the STR's even after taking multiple pictures.
(Assignee)

Comment 16

4 years ago
To prove I'm not making this up.. I *think* I'm following the same STR as Comment 0, but maybe someone can help point out if I'm doing something wrong.. Here is a video where I am *not* able to reproduce using latest v1.4 build on Flame:

https://www.youtube.com/watch?v=JR-3Sgk1Byc

Gaia      0c16adced7c51f795ef250aebe184f60b6a9b987
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/04216748e6c1
BuildID   20140604000202
Version   30.0

Also, my Flame has the latest v10G-2 firmware.
Marcia - Can you work with Peter to see if you can figure out how to reproduce this in house?
Flags: needinfo?(mozillamarcia.knous)

Comment 18

4 years ago
(In reply to Justin D'Arcangelo [:justindarc] from comment #16)
> To prove I'm not making this up.. I *think* I'm following the same STR as
> Comment 0, but maybe someone can help point out if I'm doing something
> wrong.. Here is a video where I am *not* able to reproduce using latest v1.4
> build on Flame:
> 
> https://www.youtube.com/watch?v=JR-3Sgk1Byc

Comment 0, Step 4:
> 4) Enable the flash and set the timer to either 5 or 10 seconds

I tap the flash icon(!) and then set the timer to either 5 or 10 secs (reproduced 5/5 tries)
I still am having difficulty reproducing this with the same steps. There is one way, however, I can get this to reproduce every time: I set HDR as a paramter as well, and the camera freezes when it gets to "1" and I have to reboot the device.
Flags: needinfo?(mozillamarcia.knous)
I think based on the above comments here we need the STR clarified clearly here.
Keywords: steps-wanted
I was able to reproduce this on my own flame 15 / 15 times using these str:

1) Load Camera app
2) Select Settings
3) Select self-timer and set to 10 seconds
4) Take a picture

The camera froze at the following: 4 sec
8 sec, 7 sec, 1 sec, 7 sec, 1 sec, 7 sec, 3 sec, 8 sec,8 sec, 9 sec, 3 sec, 4 sec, 7 sec, 4 sec, 7 sec

The majority of the time it occurred with 7 to 8 seconds left.
When the countdown would reach 3 the countdown progress seemed to slow a little and become laggy. 
I did not adjust the flash at all, which defaults to Auto.
I did not adjust the HDR, which defaults to off.

Environmental Variables:
Device: Flame 1.4
Build ID: 20140605111917
Gaia: 183efb374be1bcbf92f1fb3d0212a68b564a6d3e
Gecko: 633f6addec6d
Version: 30.0 (1.4) 
Firmware Version: v10G-2
Keywords: steps-wanted
nkot and I did some testing. It turns out this happens, but it happens intermittently. Following this set of STR seems to get a higher rate of reproduction for me:

1) Open the camera app
2) Turn the flash "off"
3) Set the timer to 5 seconds
4) Turn on HDR
5) Take a picture

I often time will get a freeze when the camera reaches "1" second.
For all the people trying to reproduce the issue. I have two flames one with the latest vendor image:

Foxfone-One-v10G-2.zip file in https://mozilla.box.com/s/ii8sm72iv5v0955b8f8m

I can reproduce the issue almost all the time with the device with an older vendor image and latest gecko/gaia but I don't see the issue on the device with the vendor image above.

What vendor image are you using? Also I struggled with strange issues in the past with flame devices from the prototype batch. Do you have a production version?
(Assignee)

Comment 24

4 years ago
To add some more data to this, I tested two different Flame devices (both with the latest vendor firmware 10g-2) and was unable to reproduce with the latest Gaia + Gecko build for v1.4 and 2.0.
Also, we should all clarify how we are flashing our devices. I flash mine using the TPE tool, which flashes gecko and gaia. That may also help answer the issue of inconsistencies.
(Assignee)

Comment 26

4 years ago
I am flashing using the B2G Flash Tool (Gaia + Gecko):

https://github.com/Mozilla-TWQA/B2G-flash-tool
(Assignee)

Comment 27

4 years ago
(In reply to Marcia Knous [:marcia - use needinfo] from comment #22)
> nkot and I did some testing. It turns out this happens, but it happens
> intermittently. Following this set of STR seems to get a higher rate of
> reproduction for me:
> 
> 1) Open the camera app
> 2) Turn the flash "off"
> 3) Set the timer to 5 seconds
> 4) Turn on HDR
> 5) Take a picture
> 
> I often time will get a freeze when the camera reaches "1" second.

Marcia,
Just curious.. When you get the freeze following these steps (with HDR), does it un-freeze itself after a few seconds? The reason I ask is there's a known issue with HDR freezing/taking too long on Flame (we're adding a loading spinner in those cases).

Comment 28

4 years ago
NI marcia for comment 26/27
Flags: needinfo?(mozillamarcia.knous)
I moved to base image H and I now cannot reproduce this even with HDR turned on, using Flame device and:

Gaia   8d865839d932bfbd5e157f376f74d8cb12bfdd51
SourceStamp 1d4046a8cb6c
BuildID 20140610000223
Version 32.0a2

Gaia   f42ebc93554979501d3ac52bcf9e69cb4b310a4f
SourceStamp 9dc0ffca10f4
BuildID 20140610040208
Version 33.0a1

Asking for the remote test team to retest on their hardware with Image H.

Also, regarding Comment 23, none of us that are testing are using prototype phones AFAIK (all of the MV phones that were prototype are locked away and out of circulation).
Flags: needinfo?(mozillamarcia.knous) → needinfo?(nkot)
Keywords: qawanted
Myself, NKot, and Andrew (the reporter) have all been working on this. We have updated to Image H and none of us have been able to repro the issue using the various STRs. 


Latest Build - 
Environmental Variables:
Device: Flame 2.0
Build ID: 20140610000915
Gaia: 8b7ecdfbd5bca2cad1e46dd2f9b0bafa74adf931
Gecko: ddb2d43fbfa0
Version: 32.0a2 (2.0) 
Firmware Version: v10H-4
Flags: needinfo?(nkot)
Keywords: qawanted
I close this then. Please reopen if someone can reproduce
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID

Updated

4 years ago
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.