Closed Bug 1019178 Opened 7 years ago Closed 7 years ago

Assertion count mismatch during layout/reftests/bugs/355548-3.xml on Android 4.0 Debug

Categories

(Firefox for Android :: General, defect)

x86
Android
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 456899

People

(Reporter: gbrown, Assigned: gbrown)

References

Details

Android 4.0 *Debug* tests currently only run on the Cedar tree. We are trying to get these tests to pass so that they can be run on trunk trees.

On Cedar, on Android 4.0 Debug, layout/reftests/bugs/355548-3.xml consistently fails with an assertion count mismatch:

https://tbpl.mozilla.org/php/getParsedLog.php?id=40873243&tree=Cedar&full=1#error0

08:57:47     INFO -  REFTEST TEST-START | http://10.12.133.21:30577/tests/layout/reftests/bugs/355548-3.xml
08:57:47     INFO -  REFTEST TEST-LOAD | http://10.12.133.21:30577/tests/layout/reftests/bugs/355548-3.xml | 834 / 1320 (63%)
08:57:47     INFO -  REFTEST INFO | START http://10.12.133.21:30577/tests/layout/reftests/bugs/355548-3.xml
08:57:47     INFO -  REFTEST INFO | [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
08:57:47     INFO -  REFTEST INFO | Initializing canvas snapshot
08:57:47     INFO -  REFTEST INFO | DoDrawWindow 0,0,800,1000
08:57:47     INFO -  REFTEST INFO | [CONTENT] RecordResult fired
08:57:47     INFO -  REFTEST INFO | RecordResult fired
08:57:47     INFO -  REFTEST TEST-LOAD | http://10.12.133.21:30577/tests/layout/reftests/bugs/355548-3-ref.xml | 834 / 1320 (63%)
08:57:47     INFO -  REFTEST INFO | START http://10.12.133.21:30577/tests/layout/reftests/bugs/355548-3-ref.xml
08:57:47     INFO -  REFTEST INFO | [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
08:57:47     INFO -  REFTEST INFO | Initializing canvas snapshot
08:57:47     INFO -  REFTEST INFO | DoDrawWindow 0,0,800,1000
08:57:47     INFO -  REFTEST INFO | [CONTENT] RecordResult fired
08:57:47     INFO -  REFTEST INFO | RecordResult fired
08:57:47     INFO -  REFTEST TEST-PASS | http://10.12.133.21:30577/tests/layout/reftests/bugs/355548-3.xml | image comparison (==)
08:57:47     INFO -  REFTEST INFO | Loading a blank page
08:57:47     INFO -  REFTEST TEST-UNEXPECTED-FAIL | http://10.12.133.21:30577/tests/layout/reftests/bugs/355548-3.xml | assertion count 1 is more than expected 0 assertions
08:57:47     INFO -  REFTEST TEST-END | http://10.12.133.21:30577/tests/layout/reftests/bugs/355548-3.xml

Logcat shows the assertion:

http://mozilla-releng-blobs.s3.amazonaws.com/blobs/cedar/sha512/d004a3f90a319a63f58ab7f79b49676968c046e2032c6ec6785e4e0dd673403cc9cb93bb66d48495a69cb8029fddc2bfdfe193c94485cb46003d8b5592c46d15

05-30 12:06:01.250 E/GeckoConsole( 2119): [JavaScript Warning: "'fontfamily' is deprecated in MathML 3, superseded by 'mathvariant'." {file: "http://10.26.130.20:30300/tests/layout/reftests/bugs/355548-3.xml" line: 0}]
05-30 12:06:01.250 E/GeckoConsole( 2119): [JavaScript Warning: "'fontfamily' is deprecated in MathML 3, superseded by 'mathvariant'." {file: "http://10.26.130.20:30300/tests/layout/reftests/bugs/355548-3.xml" line: 0}]
05-30 12:06:01.250 E/GeckoConsole( 2119): [JavaScript Warning: "'fontfamily' is deprecated in MathML 3, superseded by 'mathvariant'." {file: "http://10.26.130.20:30300/tests/layout/reftests/bugs/355548-3.xml" line: 0}]
05-30 12:06:01.273 I/Gecko   ( 2119): [2119] ###!!! ASSERTION: forgot to short-circuit a text run with zero-sized font?: 'GetStyle()->size != 0', file /builds/slave/ced-and-d-00000000000000000000/build/gfx/thebes/gfxFT2FontBase.cpp, line 148
See https://tbpl.mozilla.org/?tree=Cedar&showall=1&jobname=android.*debug for more logs.
This assertion ("forgot to short-circuit a text run with zero-sized font?") was added in bug 505284. Maybe :dolske can offer insight?

:roc -- It looks like you wrote this test. Do you understand what is happening here?

If we just want to allow the assertion in this test, I'm happy to take care of it.
Flags: needinfo?(roc)
I pushed it, but the patch wasn't mine. The testcase I had in the bug was for a Windows CE port of Firefox, long since dead, so I can't offer any help there either.
I don't know. It should be fairly easy to debug. The assertion stack would be a good start. If you can get the assertion with a debugger connected I'd be happy to work through it with you on IRC.
Flags: needinfo?(roc)
See Also: → 456899
I have not been able to reproduce this assertion when running in a debugger on a local device. But I noticed that bug 456899 deals with the same assertion, and has a very old wip patch. I un-bitrotted that patch and found that it resolved this bug (https://tbpl.mozilla.org/?tree=Cedar&rev=35812daf3e23), so will pursue in bug 456899.
Assignee: nobody → gbrown
Depends on: 456899
See Also: 456899
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 456899
You need to log in before you can comment on or make changes to this bug.