mk68.com - left frame content is not rendered

RESOLVED INVALID

Status

Tech Evangelism Graveyard
German
P2
critical
RESOLVED INVALID
17 years ago
3 years ago

People

(Reporter: thora, Unassigned)

Tracking

Details

(Whiteboard: [PROPRIETARY-JS][havefix][havecontact], URL)

(Reporter)

Description

17 years ago
The browser(Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.4) Gecko/20010913)
didn't (Linux & Windows) show the JavaScipt on the left side of the webside, the
Konqueror 2.2.1 (KDE 2.2.1) and the Iexplorer works fine.

Comment 1

17 years ago
From menu html source

 if (document.all) {
                menu.innerHTML=menucontent
        }
        if (document.layers) {
                document.menu.document.write(menucontent)
                document.menu.document.close()
        }

Mozilla doesn't support either of these.
-> TE
Assignee: rogerl → nitot
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Europe: West
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: pschwartau → caillon
Hardware: PC → All
Summary: <!FRAME SRC → left menu is not rendered
Whiteboard: [PROPRIETARY-JS]
Version: other → unspecified

Comment 2

16 years ago
Yep.  Severity to major since there is no other way to navigate through that
site without their bad menus code.
Severity: normal → major
Priority: -- → P3
Summary: left menu is not rendered → mk68.com - left menu is not rendered
Whiteboard: [PROPRIETARY-JS] → [PROPRIETARY-DOM][LAYER]
in http://www.mk68.com/wir4/left-site/left.html, they just need to add this :
  else if (/* choose your preffered way to detect gecko*/)
       document.getElementById('menu').innerHTML=menucontent
Severity: major → critical
Priority: P3 → P2
Whiteboard: [PROPRIETARY-DOM][LAYER] → [PROPRIETARY-DOM][LAYER][havefix]
sniff gecko : http://developer.netscape.com/evangelism/docs/articles/find-gecko/

contact info : http://www.mk68.com/wir4/cgi-bin/mail-site/form.asp
Whiteboard: [PROPRIETARY-DOM][LAYER][havefix] → [PROPRIETARY-DOM][LAYER][havefix][havecontact]
can anyone contact them with this fix ? :

if (document.all)
{
    menu.innerHTML = menucontent;
}
if (document.layers)
{
    document.menu.document.write(menucontent);
    document.menu.document.close();
}
else if (document.getElementById('menu').innerHTML)
{
    document.getElementById('menu').innerHTML = menucontent;
}

Comment 6

15 years ago
I sent him a message.  I don't know if he can understand English though.
Summary: mk68.com - left menu is not rendered → mk68.com - left frame content is not rendered
Whiteboard: [PROPRIETARY-DOM][LAYER][havefix][havecontact] → [PROPRIETARY-JS][havefix][havecontact]
New Component
Component: Europe: West → German

Comment 8

15 years ago
default german owner
Assignee: nitot → german
QA Contact: z-caillon-obsolete2 → german
The domain mk68.com is not active (technically spoken: no SOA record available). I'm going to resolve this as INVALID and so please reopen if the website will reappear :-)
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.