Mozilla hangs after pressing Tab in sole text field

VERIFIED WORKSFORME

Status

()

Core
XUL
--
major
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: saari (gone))

Tracking

({hang})

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Build: 2001092504, Mac OS 9.1, Classic theme

To reproduce:
1.  Type `javascript:prompt("test")' (without single quotes) in Navigator's
    address field, and press Enter.
2.  Wait for the dialog to open.
3.  When the dialog opens, press the Tab key.

What should happen:
*   Nothing, since focus is already in the only focusable control in the
    dialog (the text field).

What actually happens:
*   The caret starts flashing very fast.
*   Mozilla hangs.

This originally happened in a dialog asking me for my mail password; 
javascript:prompt() is just a convenient testcase.

See also bug 94298, which applies to text fields in Web pages.
(Reporter)

Updated

16 years ago
Keywords: hang

Comment 1

16 years ago
This isn't a dup of 100921 then?

Comment 2

16 years ago
Looks like a dup of bug 100923.

(Bug 100921 is about components not receiving focus, although the cause for
 both was the same.)

I cannot reproduce this with Build 2001092521 on Linux.

Comment 3

16 years ago
--> saari
Assignee: hyatt → saari

Comment 4

16 years ago
build: 2001092503
Windows 98

I followed the directions above, and the focus went from the text field to the
first button (OK) as expected.

I pressed Tab again, the focus went to the second button (Cancel) as expected.

Tabbed again, and focus went back to the first button.  I expected it to go to
the text field instead.

Pressed Shift-Tab (when focus is on the first button), focus went into text
field as expected.

Shift-Tab in the text field causes the symptoms given in the above description.

I killed and restarted Mozilla, created the popup, and pressed Shift-Tab right
away.  Same results -> hang.

Comment 5

16 years ago
I think this was fallout from 100921, which bryner checked in a fix for on 
9/25. In current builds, on either Mac or win2k, I can't reproduce this hang
as described (even in Classic on Mac, where the buttons aren't focussable).

Reopen as required...
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

16 years ago
Verified worksforme, build 2001092808, Mac OS 9.1.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.