Changing profile info rejects password when logged in via Persona

RESOLVED DUPLICATE of bug 746492

Status

()

bugzilla.mozilla.org
Extensions: Persona
RESOLVED DUPLICATE of bug 746492
4 years ago
4 years ago

People

(Reporter: vstamour, Unassigned)

Tracking

Production
x86_64
Linux

Details

(Reporter)

Description

4 years ago
The form to change profile information makes it look like it requires entering the current password to make any change.

When logged in with Persona, however, entering a password causes a "wrong password" error.

Not entering a password at all works, and applies the desired changes, but it's highly unintuitive.

It would make sense, IMO, to remove that field when logged in with Persona.
i've done some work as part of bug 1003701 to make this much clearer, which i need to break out into a new bug.

technically this is a result of how the persona integration with bugzilla is implemented, marking as a duplicate of bug 746492
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 746492
You need to log in before you can comment on or make changes to this bug.