[traceback] AttributeError: 'NoneType' object has no attribute 'summary'

VERIFIED FIXED in 2014Q2

Status

support.mozilla.org
General
P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: stephend, Assigned: rrosario)

Tracking

unspecified
2014Q2

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=qa c=aaq p=0 s=2014.10 [fromAutomation])

(Reporter)

Description

4 years ago
Between these two builds:

Failed > Console Output  #1552 	Jun 1, 2014 8:08:50 PM	 
Success > Console Output  #1551 	May 31, 2014 8:08:50 PM

we're getting the following 500 Internal Server Error, which comes from running test_that_posting_question_works[1] against staging:

Traceback (most recent call last):
File "/usr/lib64/python2.6/site-packages/newrelic-2.16.0.12/newrelic/hooks/framework_django.py", line 492, in wrapper return wrapped(*args, **kwargs)
File "/data/www/support.allizom.org/kitsune/kitsune/sumo/decorators.py", line 20, in _checkssl return view_func(request, *args, **kwargs)
File "/data/www/support.allizom.org/kitsune/kitsune/questions/views.py", line 682, in aaq_step3 step=1)
File "/data/www/support.allizom.org/kitsune/kitsune/sumo/decorators.py", line 20, in _checkssl return view_func(request, *args, **kwargs)
File "/data/www/support.allizom.org/kitsune/vendor/src/django-mobility/mobility/decorators.py", line 23, in wrapper return f(request, *args, **kw)
File "/data/www/support.allizom.org/kitsune/vendor/src/django-session-csrf/session_csrf/__init__.py", line 127, in wrapper response = f(request, *args, **kw)
File "/data/www/support.allizom.org/kitsune/kitsune/questions/views.py", line 517, in aaq product.get('products'))
File "/data/www/support.allizom.org/kitsune/kitsune/questions/views.py", line 1617, in _search_suggestions doc.current_revision.summary),
AttributeError: 'NoneType' object has no attribute 'summary'

[1] https://github.com/mozilla/sumo-tests/blob/master/tests/desktop/test_questions.py#L16
STR:
1. got to https://support.allizom.org
2. click ask a question
3. click firefox for desktop
4. select any category
5. type in a question which contains the word "test"

Expected result:
A list of articles should be displayed

Actual result:
"
An Error Occurred

Oh, no! It looks like an unexpected error occurred. We've already notified the site administrators. Please try again now, or in a few minutes.
"
The test also fails in the latest Jenkins run.
http://selenium.qa.mtv2.mozilla.com:8080/view/All%20not%20B2G/job/sumo.stage/1294/HTML_Report/

I could only reproduce this issue on staging and asking questions for firefox desktop.
Also the question must contain the word "test". I could not reproduce the issue with other questions.
(Assignee)

Comment 2

4 years ago
Reindexing fixed the issue.
Assignee: nobody → rrosario
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Priority: -- → P3
Resolution: --- → FIXED
Whiteboard: [fromAutomation] → u=qa c=aaq p=0 s=2014.10 [fromAutomation]
Target Milestone: --- → 2014Q2
(Reporter)

Comment 3

4 years ago
Thx, Ricky.  It did indeed; verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.