[Sora][HOMO]Not possible to manage the enable/disable SMS status report in SMS

RESOLVED DUPLICATE of bug 933133

Status

P1
normal
RESOLVED DUPLICATE of bug 933133
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
DEFECT DESCRIPTION:
 Not possible to manage the enable/disable SMS status report in SMS
 
  REPRODUCING PROCEDURES:
 1. Using MMI commands, set the Status Report in the MS. 
 2. Send an MO SM with the Status Report parameter included. 
 3. Check that the message reaches its destination, and that the Status report
 is returned by the network and correctly received by the MS
 
 
  EXPECTED BEHAVIOUR:
 The message reaches its destination, and the Status report is returned by
 the network and correctly received by the MS.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 sw127 + YJ127NV0
 
  USER IMPACT:
 High
 
  REPRODUCING RATE:
 100%
 
  For FT PR, Please list reference mobile's behavior:
Could you clarify what you mean by "Using MMI commands, set the Status Report in the MS"? what operations have you done
Flags: needinfo?(sync-1)

Comment 2

4 years ago
(In reply to Vance Chen [:vchen][vchen@mozilla.com] from comment #1)
> Could you clarify what you mean by "Using MMI commands, set the Status
> Report in the MS"? what operations have you done

We already have a deliver report in UI, but this feature requires a message notification to tell the ensure a message status.
Thanks for the clarification Tianm, then this is a new feature request, not a bug

Comment 4

4 years ago
Firefox OS v1.3
Mozilla build ID:20140422024003
(Reporter)

Updated

4 years ago
Flags: needinfo?(sync-1)
Sorry, I don't understand the issue here at all.

Can you put the expected behavior (I know it's already in comment 0, but please put it again) and the actual faulty behavior?
Flags: needinfo?(sync-1)

Comment 6

4 years ago
(In reply to Julien Wajsberg [:julienw] from comment #5)
> Sorry, I don't understand the issue here at all.
> 
> Can you put the expected behavior (I know it's already in comment 0, but
> please put it again) and the actual faulty behavior?

It means a notification message which is used to tell end user the delivery report.
Vance has discussed it with me, thus you can ask him.
(Reporter)

Updated

4 years ago
Flags: needinfo?(sync-1)
(In reply to Julien Wajsberg [:julienw] from comment #5)
> Sorry, I don't understand the issue here at all.
> 
> Can you put the expected behavior (I know it's already in comment 0, but
> please put it again) and the actual faulty behavior?

Hi Julien -

The expected behavior from issue submitter is to display a notification while the device receives a SMS status report from network. For now we only show a check mark on the thread view, and the tester say it is not enough.

That's why i think this is not a bug but a new feature request
Ok, then it's bug 933133 !
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 933133
You need to log in before you can comment on or make changes to this bug.