Flash plugin causes Firefox to freeze on OS X 10.6

RESOLVED DUPLICATE of bug 1015976

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 1015976
4 years ago
4 years ago

People

(Reporter: nmalkin, Unassigned)

Tracking

32 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Using: Firefox 32.0a1 (2014-06-02) and Adobe Flash 13.0.0.214 (latest)
This bug was introduced in one of the Nightlies between 5/26 and 5/29; there were no problems prior to this.

The bug is triggered by activating the Flash plugin on any page with Flash content. When this is done, the browser becomes unresponsive. After a while, the "this script is taking too long" dialog pops up; however, choosing to stop the script doesn't do anything.

The OS X Activity Monitor shows that (immediately after Flash is activated), the system process ReportCrash (/System/Library/CoreServices/ReportCrash) begins taking up 100% of the CPU. In fact, it seems that there are multiple crash reports being spawned, one after the other. The list of open files for this process shows many calls to system libraries, but also several Firefox libraries:

- /Applications/FirefoxNightly.app/Contents/MacOS/XUL
- /Applications/FirefoxNightly.app/Contents/MacOS/libmozalloc.dylib
- /Applications/FirefoxNightly.app/Contents/MacOS/libmozglue.dylib
- /Applications/FirefoxNightly.app/Contents/MacOS/XUL
- /Applications/FirefoxNightly.app/Contents/MacOS/libnss3.dylib
This sounds a lot like bug 1015976, which also was reported for OS X 10.6.

Please find out exactly which mozilla-central nightly this started happening with, and let us know.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1015976
> Please find out exactly which mozilla-central nightly this started happening with, and let us know.

Never mind, I've already found out.  See bug 1015976 for further information.
You need to log in before you can comment on or make changes to this bug.