Closed Bug 1019418 Opened 5 years ago Closed 5 years ago

Mix of English/translated strings displayed in Firefox Account setup

Categories

(Firefox OS Graveyard :: FxA, defect, P2)

defect

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: flod, Assigned: _6a68)

References

Details

(Whiteboard: [fxa4fxos2.0])

Attachments

(8 files)

Attached image Screenshots on Keon
Strings landed a few hours ago in bug 987418.

I translated locally those strings, flashed Gaia on the device but I'm still seeing a mix of translated/untranslated content.

I can't see the problem in the HTML. Take for example the string "Use your email address to create an account or sign in."

The id is fxa-use-email-to-sign-in and the code is using the same ID in data-l10n-id
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/fxa/elements/fxa-email.html#L5

Could it be that mozl10n.translate is not called on the page (if this makes sense)? The string working (tos+privacy link) at the bottom is changed by JavaScript, and I see also the "Connecting" or other errors (wrong password) correctly translated.
Blocks: 987418
There's nothing waiting for the l10n resoures to be ready, I suspect this is just a race.

No idea what's the recommended coding pattern, both for initial load and language changes right now. Stas?
Thanks for digging up this bug, Francesco! I'll dig in once I've finished up my last feature bug work today.

Axel, as far as how to wait for l10n, Stas posted about this to dev-gaia recently[1]. I'll follow the suggestions there :-)

[1] https://groups.google.com/d/topic/mozilla.dev.gaia/6jKrqxOzPWI/discussion
Priority: -- → P3
Whiteboard: [fxa4fxos2.0]
Setting flag to block 2.0, priority seems to be way too low for this.
blocking-b2g: --- → 2.0?
I agree, will start work on this tomorrow.
Assignee: nobody → 6a68
Priority: P3 → P2
blocking-b2g: 2.0? → 2.0+
Bug's gone quiet for a few days, I am actively working on this.
Attached file Github PR 20638
Hey guys,

This PR is a little bit involved, but is a late-l10n 2.0 blocker. Do you have time to take a look? If not, let me know who would be a good alternate for this week.

I have separated the PR into several different commits, because I fixed the underlying bug, then discovered several smaller l10n-related bugs when doing a final verification pass with the 'accented english' locale. I think the individual commits will be easier to review than the diff as a whole.

I've taken screenshots of all the screens looking correct with this set of fixes applied, I'll upload them next.
Attachment #8441708 - Flags: review?(ferjmoreno)
Attachment #8441708 - Flags: feedback?(francesco.lodolo)
These screenshots use the testing 'accented english' locale to show that l10n is working properly in all screens of the system app with this fix applied.
Comment on attachment 8441708 [details] [review]
Github PR 20638

I left a question on Github, but I tested the patch on my localized Keon and it works great from Settings (both login to existing account, and account creation).

From FTU I get a very weird behavior, not sure if this bug should cover these issues, assuming someone can reproduce it: when I try to sign-in from FTU, after the password I get an error (can't connect, system not available, try again later). 

If I go back to the home screen, and then back to FTU, I see a "Signed in as XXX" displayed in English. Go into settings to log-out, the Firefox Account section is empty. At some point, when trying to create a new account, I even saw "Hello, XXX" untranslated (can't reproduce it, always get the error message).

P.S. the deadline for this week is for patches introducing new strings on 2.0, thus late-l10n
Attachment #8441708 - Flags: feedback?(francesco.lodolo) → feedback+
(In reply to Francesco Lodolo [:flod] from comment #14)
> If I go back to the home screen, and then back to FTU, I see a "Signed in as
> XXX" displayed in English.

That's probably bug 1021523 (that string was still missing in my build).
(In reply to Francesco Lodolo [:flod] from comment #15)
> That's probably bug 1021523 (that string was still missing in my build).

Added the missing string, reflashed, this time sign-in from FTU worked as expected.
Awesome, thanks for the feedback! Yeah, sorry, totally forgot to mention bug 1021523 :-P
Comment on attachment 8441708 [details] [review]
Github PR 20638

LGTM!
Attachment #8441708 - Flags: review?(ferjmoreno) → review+
Master: https://github.com/mozilla-b2g/gaia/commit/2863c6e648979bad83a106c35d2db204c5283a22
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S4 (20june)
Duplicate of this bug: 1028320
RyanVM is out, going to manually uplift this.

Asking njpark to verify that it really really looks fixed before I do ;-)
Flags: needinfo?(npark)
Verified on 2.0 Gecko, (master branch had a gecko bug that hangs the FxA connection) with accented english and english locale.  In both instances it showed proper e-mail address of the user.  All contented were following the set locale, and no {{email}} text was visible.
Flags: needinfo?(npark)
Opened a PR against v2.0, once gaia-try and/or travis look good, I'll uplift (since RyanVM is out today).

https://github.com/mozilla-b2g/gaia/pull/20820
You need to log in before you can comment on or make changes to this bug.