<mi> font-family is not applied

RESOLVED WONTFIX

Status

()

Core
MathML
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: Ivan Enderlin, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140602040202

Steps to reproduce:

Open this URL:

data:text/html,<style>@font-face { font-family: Math; src: url("http://static.hoa-project.net/Font/NeoEuler.woff") format("woff"); font-weight: normal; font-style: normal } mi, mtext { font-family: Math }</style><math><mi>U</mi><mtext>U</mtext></math>


Actual results:

The <mtext> font family is modified, while the <mi> one is not modified. I wonder why. When debugging the <mi>, I don't see any difference between computed rules of <mi> and <mtext>. The STIXGeneral-Regular font family is used for <mi>.


Expected results:

The <mi> content should have the Neo Euler font family.
After bug 930504, the italic mathvariant uses the Mathematical Alpha Numeric char when available, as required by the MathML spec. I think Neo Euler do not have these characters yet, so Gecko probably fallbacks to other fonts that have them. I guess if you do <mi mathvariant="normal"> instead, Neo Euler will be used. So I think it's a bug in Neo Euler.
(Reporter)

Comment 2

4 years ago
Exact. I was assuming something like that. Neo Euler is not fully released. Is is possible to control @mathvariant from CSS? I saw -moz-math-variant but not sure.
(Reporter)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(In reply to Ivan Enderlin from comment #2)
> Exact. I was assuming something like that. Neo Euler is not fully released.
> Is is possible to control @mathvariant from CSS? I saw -moz-math-variant but
> not sure.

At the moment -moz-math-variant is internal to Gecko. It might be technically possible to expose it, but that should be discussed with the MathML WG / Mozilla CSS reviewers. One concern I see is that it is supposed to bring semantics information, not stylistic, so putting it in a separate stylesheet will lost that info when copied & paste or will be ignored by MathML renderers that are not CSS-aware (such as MathJax or MathPlayer).
(Reporter)

Comment 4

4 years ago
Yup exactly. Just to keep you informed, your slides (http://fred-wang.github.io/MozSummitMathML/index.html) have this issue (since you're also using Neo Euler).

Thanks for the answer and keep going!
You need to log in before you can comment on or make changes to this bug.