All users were logged out of Bugzilla on October 13th, 2018

Datek main page initial layout is bad on Mac - wrong font size

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: bnesse, Unassigned)

Tracking

({platform-parity, top100})

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
I stumbled across this while trying to find a better test case for bug 100117.
This works correctly on Windows. On the Mac it doesn't seem to get the font size
correct on the first load. If you click on any of the items the size is set
correctly on any additional draws. Images coming.
(Reporter)

Comment 1

17 years ago
Created attachment 51076 [details]
Image of initial page draw on the Mac.
(Reporter)

Comment 2

17 years ago
Created attachment 51077 [details]
What it looks like after clicking on "Getting Started"
(Reporter)

Comment 3

17 years ago
Created attachment 51078 [details]
What it looks like if you click on "Getting Started" again to close it.
(Reporter)

Updated

17 years ago
Keywords: 4xp, pp

Updated

17 years ago
Keywords: top100
Target Milestone: --- → mozilla0.9.9
Marking nsbeta1+
Keywords: nsbeta1+

Comment 5

17 years ago
This problem is related to their js:

if (agt.indexOf("mac")!=-1) {
	var macStyle='<STYLE type="text/css"><!--span{position:absolute;
font-family:Arial; font-size:12pt; width:120px}#leftlinks{color:000066;
text-decoration:none;}--></STYLE>';
document.write(macStyle);
}


This font-size declaration is applied to both NS and IE MAC OS X and OS 9 clients.

Comment 6

17 years ago
If I disable the script tag, the style tag in the document will apply the 9pt
font-size declaration.

Comment 7

17 years ago
Created attachment 68650 [details]
Script tag commented - Font looks correct

Comment 8

17 years ago
Dood! cool reduction, over to evang.
Component: Compositor → English: Non-US
Product: Browser → Tech Evangelism
Target Milestone: mozilla0.9.9 → ---
Version: other → unspecified

Comment 9

17 years ago
reassign to default owner...
Assignee: attinasi → momoi
QA Contact: petersen → jonrubin
*** Bug 139639 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
10 months later...

Datek has merged with Ameritrade. It no longer uses the left side menu that
caused this bug.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 12

16 years ago
Mass reassigning English-Other bugs to general default assignees.
Assignee: momoi → english-other
QA Contact: jonrubin → english-other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.