Intermittent test_bug667612.html | application terminated with exit code 1 | application crashed [@ mozilla::dom::workers::WorkerPrivate::ClearMainEventQueue(mozilla::dom::workers::WorkerPrivate::WorkerRanOrNot)] | Assertion failure: !NS_HasPendingEvents

RESOLVED DUPLICATE of bug 970568

Status

()

RESOLVED DUPLICATE of bug 970568
4 years ago
4 years ago

People

(Reporter: cbook, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test mochitest-2 on 2014-06-02 21:30:48 PDT for push c1acd3bf21ed

slave: talos-r4-snow-148

https://tbpl.mozilla.org/php/getParsedLog.php?id=40922668&tree=Mozilla-Inbound

Assertion failure: !NS_HasPendingEvents(currentThread), at /builds/slave/m-in-osx64-d-00000000000000000/build/dom/workers/WorkerPrivate.cpp:4537
TEST-UNEXPECTED-FAIL | /tests/dom/events/test/test_bug667612.html | application terminated with exit code 1
PROCESS-CRASH | /tests/dom/events/test/test_bug667612.html | application crashed [@ mozilla::dom::workers::WorkerPrivate::ClearMainEventQueue(mozilla::dom::workers::WorkerPrivate::WorkerRanOrNot)]

21:37:19     INFO -  Operating system: Mac OS X
21:37:19     INFO -                    10.6.8 10K549
21:37:19     INFO -  CPU: amd64
21:37:19     INFO -       family 6 model 23 stepping 10
21:37:19     INFO -       2 CPUs
21:37:19     INFO -  Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
21:37:19     INFO -  Crash address: 0x0
21:37:19     INFO -  Thread 49 (crashed)
21:37:19     INFO -   0  XUL!mozilla::dom::workers::WorkerPrivate::ClearMainEventQueue(mozilla::dom::workers::WorkerPrivate::WorkerRanOrNot) [WorkerPrivate.cpp:c1acd3bf21ed : 4522 + 0x0]
21:37:19     INFO -      rbx = 0x00007fff708c12f8   r12 = 0x000000012d881800
21:37:19     INFO -      r13 = 0x0000000000000000   r14 = 0x000000012d881800
21:37:19     INFO -      r15 = 0x0000000000000004   rip = 0x00000001032255df
21:37:19     INFO -      rsp = 0x00000001521004f0   rbp = 0x0000000152100510
21:37:19     INFO -      Found by: given as instruction pointer in context
21:37:19     INFO -   1  XUL!mozilla::dom::workers::WorkerPrivate::NotifyInternal(JSContext*, mozilla::dom::workers::Status) [WorkerPrivate.cpp:c1acd3bf21ed : 5084 + 0xc]
21:37:19     INFO -      rbx = 0x0000000000000001   r12 = 0x000000012d881800
21:37:19     INFO -      r13 = 0x0000000000000000   r14 = 0x0000000000000001
21:37:19     INFO -      r15 = 0x0000000000000004   rip = 0x00000001032240cb
21:37:19     INFO -      rsp = 0x0000000152100520   rbp = 0x0000000152100560
21:37:19     INFO -      Found by: call frame info
21:37:19     INFO -   2  XUL!(anonymous namespace)::NotifyRunnable::WorkerRun(JSContext*, mozilla::dom::workers::WorkerPrivate*) [WorkerPrivate.cpp:c1acd3bf21ed : 1103 + 0xc]
21:37:19     INFO -      rbx = 0x0000000122c2fcc0   r12 = 0x0000000122c2fcc0
21:37:19     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000000
21:37:19     INFO -      r15 = 0x00000001256f9480   rip = 0x000000010322e701
21:37:19     INFO -      rsp = 0x0000000152100570   rbp = 0x0000000152100570
21:37:19     INFO -      Found by: call frame info
21:37:19     INFO -   3  XUL!mozilla::dom::workers::WorkerRunnable::Run() [WorkerRunnable.cpp:c1acd3bf21ed : 312 + 0xf]
21:37:19     INFO -      rbx = 0x0000000122c2fcc0   r12 = 0x0000000122c2fcc0
21:37:19     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000000
21:37:19     INFO -      r15 = 0x00000001256f9480   rip = 0x000000010323b8dc
21:37:19     INFO -      rsp = 0x0000000152100580   rbp = 0x0000000152100640
21:37:19     INFO -      Found by: call frame info
21:37:19     INFO -   4  XUL!mozilla::dom::workers::WorkerPrivate::ProcessAllControlRunnablesLocked() [WorkerPrivate.cpp:c1acd3bf21ed : 4507 + 0x9]
21:37:19     INFO -      rbx = 0x000000012d881800   r12 = 0x0000000122c2fcc0
21:37:19     INFO -      r13 = 0x000000012d996fe0   r14 = 0x000000012d881878
21:37:19     INFO -      r15 = 0x000000012d9f1ee0   rip = 0x0000000103223e3d
21:37:19     INFO -      rsp = 0x0000000152100650   rbp = 0x0000000152100690
21:37:19     INFO -      Found by: call frame info
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: crash, intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 970568
You need to log in before you can comment on or make changes to this bug.