Closed Bug 1019560 Opened 5 years ago Closed 5 years ago

Huge FPS drop and increase in CPU usage when selecting the "Large Player" in YouTube when E10S is enabled

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect)

x86_64
Windows 8.1
defect
Not set

Tracking

(e10s+)

RESOLVED INVALID
Tracking Status
e10s + ---

People

(Reporter: achwaqkhalid, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140602072051

Steps to reproduce:

Enable e10s in the latest Nightly
Go to: www.YouTube.com
select a video
switch to "Large Player"


Actual results:

FPS Drop
Increase in CPU Usage in the following processes:
- plugin-container
- firefox
- flash player plugin


Expected results:

smooth playing experience
Blocks: fxe10s
Summary: Huge FPS drop and increase in CPU usage when selecting the "Large Player" in YouTube when @E10S is enabled → Huge FPS drop and increase in CPU usage when selecting the "Large Player" in YouTube when E10S is enabled
Blocks: e10s
No longer blocks: fxe10s
Component: Untriaged → Video/Audio
Product: Firefox → Core
We don't have support for windowed mode yet. Marking dependent on that work.
Status: UNCONFIRMED → NEW
Depends on: 923746
Ever confirmed: true
If you set |plugins.force.wmode| to transparent in a non-e10s build, do you see similar behavior? If so this is just a side effect of flash windowless mode not being very efficient.

If it *doesn't* repro outside e10s mode with that pref, though, it could mean our plugin layers code needs to be looked at for windowless, which is probably independent of the windowed-mode/IPC work
Depends on: e10s-perf
Component: Video/Audio → Flash (Adobe)
Product: Core → Plugins
Version: 32 Branch → unspecified
Blocks: e10s-perf
No longer blocks: core-e10s
No longer depends on: e10s-perf
Note, I'm not seeing a big improvement in perf with windowed plugins either. This may be more internal vs. something related to windowless.
I'm marking this invalid simply because I can't find flash on youtube anymore. Please reopen if you can reproduce on another flash based video site.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.