outliner drag-n-drop without changing columns sorts on that column

RESOLVED FIXED in mozilla0.9.7

Status

()

Core
XUL
P3
normal
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Dean Tessman, Assigned: Joe Hewitt (gone))

Tracking

Trunk
mozilla0.9.7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

4.63 KB, patch
jag (Peter Annema)
: review+
Blake Ross
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
Steps to reproduce:

1. In the message pane of Mail & News, start dragging the Subject column header
around.
2. Drag it back and forth, but don't let go of the mouse button.
3. Drag it back to its original position.
4. Let go of the mouse button.

Expected Results: Drag is canceled and nothing else happens.

Actual Results: Drag is canceled and the list is sorted by the Subject column.

This is getting treated as a click, probably because there's a mouse down on the
column header followed eventually by a mouse up.  If there's a drag of the
header in between there, that click event should be eaten.
(Reporter)

Comment 1

16 years ago
Build is 2001092703 on Win2K.
OS: Windows 2000 → All
Hardware: PC → All
I'm also seeing this on MacOS using build 2001092804.
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 3

16 years ago
Created attachment 58677 [details] [diff] [review]
patch

This patch cancels the click event after a drag operation.

Comment 4

16 years ago
Comment on attachment 58677 [details] [diff] [review]
patch

sr=blake if you remove the you-know-what-ism that we discussed
Attachment #58677 - Flags: superreview+

Comment 5

16 years ago
Comment on attachment 58677 [details] [diff] [review]
patch

r=jag if you change the you-know-what-ism blake already pointed out, flip a bit
and fix the indentation on that whatchamacallit.
Attachment #58677 - Flags: review+

Comment 6

16 years ago
hmm, just when I wanted to comment :)
well I was asked for review too, so adding my comments

Looks good only some nits:

var bx =
col.parentNode.boxObject.QueryInterface(Components.interfaces.nsIOutlinerBoxObject)

don't we have |.outlinerBoxObject| property ?

I don't like timers, but if there's no other way ...

r=varga
(Assignee)

Comment 7

16 years ago
good point, Jan, that was pretty dumb.

fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.