mach xpcshell-test unnecessarily re-runs single tests when running just one

RESOLVED DUPLICATE of bug 969633

Status

Testing
XPCShell Harness
RESOLVED DUPLICATE of bug 969633
4 years ago
4 years ago

People

(Reporter: standard8, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
runxpcshelltests.py has the functionality to not re-run failed tests in "sequential" mode when only one test is being run.

However, due to mach's use of a manifest, this is broken when using mach, and the test gets unnnecessarily rerun unless you specify --sequential.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 969633
You need to log in before you can comment on or make changes to this bug.