[flame] The Call button from Dialer app is not working (has no effect)

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Dialer
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: viorela, Assigned: gerard)

Tracking

({regression, smoketest})

unspecified
2.0 S3 (6june)
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 fixed)

Details

(Whiteboard: [fromAutomation])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
We are unable to make a call, as the call button is not working

#STR:
1. Launch Dialer app
2. Write a phone number
3. Tap Call button

# Expected results:
A phone call is launched, call screen window is displayed

# Actual results:
Nothing happens; Call button has no effect

Device: Flame
Gaia      61cd07a8b5fa017777db6d345e00afb4fb8789b7
Gecko     https://hg.mozilla.org/mozilla-central/rev/f28005b84ed0
BuildID   20140603040210
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

I was able to reproduce this both manually and by running the automated test.

Jenkins run: http://selenium.qa.mtv2.mozilla.com:8080/view/B2G%20Flame/job/b2g.flame.mozilla-central.ui.non-smoketest/47/HTML_Report/
(Reporter)

Updated

4 years ago
Priority: -- → P1

Comment 1

4 years ago
reckon fallout from this bug?
https://bugzilla.mozilla.org/show_bug.cgi?id=1008974
This is working correctly on 1.4, right?
blocking-b2g: --- → 2.0?
Keywords: qaurgent, regression, regressionwindow-wanted, smoketest
(In reply to Zac C (:zac) from comment #1)
> reckon fallout from this bug?
> https://bugzilla.mozilla.org/show_bug.cgi?id=1008974

That bug talks about making a call from the contacts app. This bug speaks about making a call within the dialer.

Comment 4

4 years ago
Dialer is working correctly on v1.4 Flame
(Assignee)

Comment 5

4 years ago
Might be a dupe from bug 1019607.

Comment 6

4 years ago
A quick regression range from releng builds (we can't drill down to tinderbox builds yet):

Last passing
Gecko: https://hg.mozilla.org/mozilla-central/99137ca57770
Gaia: https://github.com/mozilla-b2g/gaia/commit/8341cddb04773957069ac1334692a888b8bb1091

First failing
Gecko: https://hg.mozilla.org/mozilla-central/f28005b84ed0
Gaia: https://github.com/mozilla-b2g/gaia/commit/61cd07a8b5fa017777db6d345e00afb4fb8789b7
Zac - We need a logcat on this bug.

Comment 8

4 years ago
Created attachment 8433382 [details]
dialer_fail.log

logcat of the failure
The gaia range has two commits: https://github.com/mozilla-b2g/gaia/compare/8341cddb04773957069ac1334692a888b8bb1091...61cd07a8b5fa017777db6d345e00afb4fb8789b7 and none of them looks suspicious.

So this looks like a Gecko regression. I have no idea how to show the commits in that range with hg.
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=99137ca57770&tochange=f28005b84ed0
I don't think the window above is correct. There's nothing in the push log that seems suspected of the issue.
We have two JS engine changes maybe… Bug 1018476 and bug 1018621.

Comment 13

4 years ago
looks like we're fine here, https://github.com/mozilla-b2g/gaia/pull/19938 fixes this issue - tapping a call button will launch a phone call successfully
Keywords: qaurgent, regressionwindow-wanted

Comment 14

4 years ago
resolved fixed via fix in bug 1019607 (comment 13)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Duplicate of this bug: 1019168

Updated

4 years ago
Blocks: 987487
Viorela, please ensure you're still using [fromAutomation] when it applies; thanks!
Whiteboard: [fromAutomation]

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
Assignee: nobody → lissyx+mozillians
status-b2g-v2.0: --- → fixed
Target Milestone: --- → 2.0 S3 (6june)
You need to log in before you can comment on or make changes to this bug.