[Vertical Homescreen][Edge case] Icon could be misplaced when dropping it just below a divider

VERIFIED FIXED

Status

Firefox OS
Gaia::Homescreen
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 verified, b2g-v2.1 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8433468 [details]
Dropping on a divider - video

Prerequisites
Having 1 group of 2 icons and 1 group of one icon

Steps to reproduce
1. Drag the last icon from the 1st group
2. Drop it just below the center of the divider between the two groups

Actual result
The icon is landed on the far left of the second group. See attached video for details.

Expected result
The icon must land in the middle of the screen

Reproducibility rate: 7/10

Updated

4 years ago
QA Whiteboard: [VH-FL-blocking-]
Blocks: 1022414
No longer blocks: 1015336

Updated

4 years ago
QA Whiteboard: [VH-FL-blocking-] → [VH-FL-blocking-][VH-FC-blocking-]

Updated

4 years ago
Blocks: 1015336
No longer blocks: 1022414
After landing several patches about drag&drop I cannot reproduce it, could you test it again? Thanks a lot
Keywords: qawanted
I believe this was fixed with the work from bug 1022414. Please reopen if you're still seeing this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed

Updated

4 years ago
Keywords: qawanted
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.0: fixed → verified
Created attachment 8533067 [details]
Verify_Video_Flame.MP4

This issue has been verified successfully on Flame 2.1.
See attachment: Verify_Video_Flame.MP4
Reproducing rate: 0/10

Flame v2.1 version:
Gaia-Rev        38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8b92c4b8f59a
Build-ID        20141205001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141205.035305
FW-Date         Fri Dec  5 03:53:16 EST 2014
Bootloader      L1TC00011880
status-b2g-v2.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.