puppetizing ubuntu 14.04 trusty produces errors

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dividehex, Assigned: dividehex)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
In addition to the user environment changes in puppet 3.6.1, puppetizing ubuntu 14.04 against toplevel::server has problems with the pinned version of libssl, openssl, and libssl-dev

Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Could not update: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold --force-yes install libssl1.0.0=1.0.1-4ubuntu5.12' returned 100: Reading package lists...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Building dependency tree...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Reading state information...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: E: Version '1.0.1-4ubuntu5.12' for 'libssl1.0.0' was not found
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Wrapped exception:
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold --force-yes install libssl1.0.0=1.0.1-4ubuntu5.12' returned 100: Reading package lists...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Building dependency tree...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Reading state information...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: E: Version '1.0.1-4ubuntu5.12' for 'libssl1.0.0' was not found
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: (/Stage[main]/Packages::Openssl/Package[libssl1.0.0]/ensure) change from 1.0.1f-1ubuntu2.1 to 1.0.1-4ubuntu5.12 failed: Could not update: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold --force-yes install libssl1.0.0=1.0.1-4ubuntu5.12' returned 100: Reading package lists...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: (/Stage[main]/Packages::Openssl/Package[libssl1.0.0]/ensure) Building dependency tree...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: (/Stage[main]/Packages::Openssl/Package[libssl1.0.0]/ensure) Reading state information...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: (/Stage[main]/Packages::Openssl/Package[libssl1.0.0]/ensure) E: Version '1.0.1-4ubuntu5.12' for 'libssl1.0.0' was not found
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Could not update: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold --force-yes install openssl=1.0.1-4ubuntu5.12' returned 100: Reading package lists...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Building dependency tree...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Reading state information...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: E: Version '1.0.1-4ubuntu5.12' for 'openssl' was not found
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Wrapped exception:
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold --force-yes install openssl=1.0.1-4ubuntu5.12' returned 100: Reading package lists...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Building dependency tree...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Reading state information...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: E: Version '1.0.1-4ubuntu5.12' for 'openssl' was not found
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: (/Stage[main]/Packages::Openssl/Package[openssl]/ensure) change from 1.0.1f-1ubuntu2.1 to 1.0.1-4ubuntu5.12 failed: Could not update: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold --force-yes install openssl=1.0.1-4ubuntu5.12' returned 100: Reading package lists...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: (/Stage[main]/Packages::Openssl/Package[openssl]/ensure) Building dependency tree...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: (/Stage[main]/Packages::Openssl/Package[openssl]/ensure) Reading state information...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: (/Stage[main]/Packages::Openssl/Package[openssl]/ensure) E: Version '1.0.1-4ubuntu5.12' for 'openssl' was not found
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Could not update: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold --force-yes install libssl-dev=1.0.1-4ubuntu5.12' returned 100: Reading package lists...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Building dependency tree...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Reading state information...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: E: Version '1.0.1-4ubuntu5.12' for 'libssl-dev' was not found
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Wrapped exception:
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold --force-yes install libssl-dev=1.0.1-4ubuntu5.12' returned 100: Reading package lists...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Building dependency tree...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: Reading state information...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: E: Version '1.0.1-4ubuntu5.12' for 'libssl-dev' was not found
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: (/Stage[main]/Packages::Openssl/Package[libssl-dev]/ensure) change from purged to 1.0.1-4ubuntu5.12 failed: Could not update: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold --force-yes install libssl-dev=1.0.1-4ubuntu5.12' returned 100: Reading package lists...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: (/Stage[main]/Packages::Openssl/Package[libssl-dev]/ensure) Building dependency tree...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: (/Stage[main]/Packages::Openssl/Package[libssl-dev]/ensure) Reading state information...
Jun  3 10:37:07 openstack-testing puppet-agent[3508]: (/Stage[main]/Packages::Openssl/Package[libssl-dev]/ensure) E: Version '1.0.1-4ubuntu5.12' for 'libssl-dev' was not found
(Assignee)

Comment 1

5 years ago
Created attachment 8433501 [details] [diff] [review]
bug1019779-1.patch

pins proper version of libssl, libssl-dev and openssl based on $::operatingsystemrelease for ubuntu
Assignee: relops → jwatkins
Status: NEW → ASSIGNED
Attachment #8433501 - Flags: review?(dustin)
Comment on attachment 8433501 [details] [diff] [review]
bug1019779-1.patch

This should have a fail() for the default case, but other than that is good to go.
Attachment #8433501 - Flags: review?(dustin) → review+
(Assignee)

Comment 3

5 years ago
remote:   https://hg.mozilla.org/build/puppet/rev/79b85d759b0e
remote:   https://hg.mozilla.org/build/puppet/rev/7c49e53529c2
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.