[B2G][Contacts][Outlook/Gmail] Importing then deleting contacts from Outlook/Gmail reports negative number of contacts found

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Contacts
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: RolandK, Assigned: Jose Manuel Cantera)

Tracking

unspecified
2.0 S3 (6june)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 fixed)

Details

(Whiteboard: [2.0-flame-test-run-1])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8433636 [details]
logcat

Description:
When the user deletes contacts from their Outlook account and they still have the contacts imported to their device, when they attempt to next import from Outlook the number of contacts reported will be negative  in respect to the number of contacts deleted. 

I.e

If I imported 18 contacts from Outlook and deleted those contacts from the Outlook account and not the device, the next time I attempt to import from Outlook, the number of contacts found will be -18.

Setup Steps:
1) Have an Outlook account setup with several contacts

Repro Steps:
1) Update a Flame device to v2.0 BuildID: 20140530040207
2) Contacts > Settings > Import from Outlook
3) Sign-in
4) Select all contacts and import
5) On the desktop, sign-in to the Outlook account and delete all contacts
6) On the DuT, Contacts > Settings > Import from Outlook
7) Observe number of contacts is now negative

Actual:
The number of contacts found is displayed as a negative.

Expected:
The number of contacts is 0.

2.0 Environmental Variables:
Device: Flame 2.0
BuildID: 20140530040207
Gaia: 26d8fcab9b61f46451600f39c51e03
87ef3c4f88
Gecko: e6f113c83095
Version: 32.0a1
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/7230/
See attached: screenshot, logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8433640 [details]
screenshot

I was able to reproduce this issue on the latest v.2.0 Buri build:

Buri 2.0

2.0 Environmental Variables:
Device: Buri 2.0 MOZ
BuildID: 20140530040207
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko: e6f113c83095
Version: 32.0a1
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

-

I was able to reproduce this on the latest v1.4 Flame build:

Flame 1.4

1.4 Environmental Variables:
Device: Flame 1.4
BuildID: 20140530000202
Gaia: fe612fd21389193a8e593aa718831602e5086a62
Gecko: 25011f9a8f26
Version: 30.0
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
(Reporter)

Updated

4 years ago
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
(Reporter)

Comment 2

4 years ago
Updating title because this issue also occurs in Gmail.
Summary: [B2G][Contacts][Outlook] Outlook reports negative number of contacts found → [B2G][Contacts][Outlook/Gmail] Importing then deleting contacts from Outlook/Gmail reports negative number of contacts found
(Assignee)

Updated

4 years ago
Assignee: nobody → jmcf
QA Wanted to check 1.3.
Keywords: qawanted
(Assignee)

Comment 4

4 years ago
Created attachment 8433977 [details]
19992.html
Attachment #8433977 - Flags: review?(crdlc)
Comment on attachment 8433977 [details]
19992.html

LGTM, good job as usual
Attachment #8433977 - Flags: review?(crdlc) → review+
(Assignee)

Comment 6

4 years ago
https://github.com/mozilla-b2g/gaia/commit/c68ff31c672f5e760ea946d8b190a92e4c99e7b5
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-v2.0: affected → fixed
Target Milestone: --- → 2.0 S3 (6june)

Updated

4 years ago
Keywords: qawanted
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1020070
You need to log in before you can comment on or make changes to this bug.