[product] [story] [FXA7] New Firefox Account user logged in and does not have an MP Persona account

RESOLVED DUPLICATE of bug 1019971

Status

Tracking
User Story
RESOLVED DUPLICATE of bug 1019971
3 years ago
3 years ago

People

(Reporter: dbialer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User Story

As a New User of Marketplace with a verified FxAccount, when I perform a task that would require a login and am already logged in, and if I didn't already have a previous Persona Marketplace account, I should be able to complete my my task.
(Reporter)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1019968 +++

Use Case:
At start user IS logged in and performs a task (review,purchase) that requires login with the conditions:
An verified Firefox Account exists
User does not have an existing Marketplace Persona Account

Expected Results
1. No login is presented to the user as the user is already logged in but visiting Marketplace for the first time since creating the FxAccount.
2. User account is created and can continue with actions that require login.

Test Case:
1. Perform a task that requires a user to be logged in (purchase, review)
2. Continue with task (no login necessary)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1019971
You need to log in before you can comment on or make changes to this bug.