[quirks]Table duplicated with non standard markup

VERIFIED DUPLICATE of bug 101148

Status

()

Core
HTML: Parser
VERIFIED DUPLICATE of bug 101148
17 years ago
16 years ago

People

(Reporter: Kipp Howard, Assigned: harishd)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4+)
Gecko/20010925
BuildID:    2001092503

When loading these this page (or my trimmed down version of the page) the main
contents of the page are displayed twice.  

If the second table is below the bottom of the browser and you select the "Next
>" just above the date, Mozilla scrolls to the bottom table for some reason and
highlights the "Next >" in that table.  Then you can select the "Next >" link
and Mozilla will navigate to the next message.

Reproducible: Always
Steps to Reproduce:
1. Load the page specified
2. Notice duplicate table with main content
3. Select "Next >" just above the date in the first table
4. Mozilla scrolls to the 2nd table with "Next >" highlighted
5. Selecting "Next >" in either table now works

Expected Results:  1. Only one table should be displayed
2. When selecting the "Next >" link, Mozilla should navigate

I have paired the file down to the following.  If this is really ugly, I'll try
and attach the file directly to this bug.
(Reporter)

Comment 1

17 years ago
Created attachment 51112 [details]
Trimmed down HTML file that exhibits the problem
(Reporter)

Comment 2

17 years ago
It appears my trimmed down version doesn't exhibit the scrolling problem
described below but it does exhibit the duplicate table problem.
->Parser, looks more like the content model choking than layout.  Should this be fixed for quirks mode, or shall we evangelize?
Assignee: attinasi → harishd
Component: Layout → Parser
Keywords: testcase
QA Contact: petersen → moied
Summary: Table duplicated with non standard markup → [quirks]Table duplicated with non standard markup
Whiteboard: WONTFIX?
Related to bug 101983, perhaps?  and maybe nastier than I first thought...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: WONTFIX?

Comment 5

17 years ago
Created attachment 51242 [details]
testcase I made for another bug on this site...

Comment 6

17 years ago
bug 101148 and this are the same - who wants theirs dup'd?
(Reporter)

Comment 7

17 years ago
I don't care.  You can mark this one as the one that is a duplicate.  I added
myself to the CC list of bug 101148 so I can test it when it is fixed.

PS: this is only my second bugzilla report so I'm not sure if I'm supposed to
mark  it as a duplicate or not.  I'll let someone else do it unless I'm told
otherwise.


*** This bug has been marked as a duplicate of 101148 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

16 years ago
verified duplicate of 101148

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.