If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Need to apply WindowsXP Start Menu integration patch to trunk

RESOLVED FIXED in mozilla0.9.6

Status

SeaMonkey
UI Design
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Bill Law, Assigned: Bill Law)

Tracking

({qawanted})

Trunk
mozilla0.9.6
x86
Windows 2000
qawanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Assignee)

Description

16 years ago
See bug 97813.  That was fixed on the branch but the patch has to be expanded a 
bit to enable it to be checked in on the trunk.

The issue is the hard-coded "Netscape 6" string that is put in the registry to 
identify the application when it is added to the Start Menu.  The "proper" way 
to do that is to place that string into a .exe or .dll string resource and 
specify that resource via the LocalizedString value under 
HKLM\Softare\Clients\StartMenuInternet\XXXXXXXX.EXE.  This requires changes 
elsewhere to get that string resource added.  This bug is to track that work 
and the landing of the rest of the patch(es) for bug 97813 onto the trunk.
Keywords: qawanted
QA Contact: sairuh → jrgm

Comment 1

16 years ago
Created attachment 51140 [details] [diff] [review]
installer fix for the trunk (ns tree)

Comment 2

16 years ago
Created attachment 51141 [details] [diff] [review]
installer fix for the trunk (moz tree)

Comment 3

16 years ago
The installer patches were already r=/sr= by law and dveditz from bug 97813.

Comment 4

16 years ago
Comment on attachment 51140 [details] [diff] [review]
installer fix for the trunk (ns tree)

This is actually r=law/sr=dveditz, not me.
Attachment #51140 - Flags: superreview+
Attachment #51140 - Flags: review+

Comment 5

16 years ago
Comment on attachment 51141 [details] [diff] [review]
installer fix for the trunk (moz tree)

This is actually r=law/sr=dveditz, not me.
Attachment #51141 - Flags: superreview+
Attachment #51141 - Flags: review+
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla0.9.6
(Assignee)

Updated

16 years ago
Blocks: 80066
(Assignee)

Comment 6

16 years ago
Created attachment 54285 [details] [diff] [review]
Patch for non-installer changes; mostly this is identical to the bug used to add this to the mozilla0.9.4 branch
(Assignee)

Comment 7

16 years ago
The changes from the (already approved) changes that were applied to the 
mozilla0.9.4 branch (via bug 97013) are:

1. A new nsINativeAppSupportWin.idl file in mozilla/xpfe/appshell/public (and 
makefile.win stuff to go with it).  This file is used to generate a separate .h 
that can be pulled into splash.rc to define the new text string (and in 
nsWindowsHooksUtils.cpp to access the value).

2. Changes splash.rc to add a new string resource for the text that will appear 
in the Start Menu (e.g., "Mozilla" for Mozilla, "Netscape 6.x" for Netscape).

3. Changes to makefile.win in mozilla/xpfe/bootstrap so that it points to 
$(XPDIST)/include/appshell when running the resource compiler so that 
nsINativeAppSupportWin.h can be found.

4. Code in nsWindowsHooksUtil.cpp (in function setWindowsXP) to build 
the "LocalizedString" registry key setting using the executable name plus 
the ",nnn" where nnn is the value from nsINativeAppSupportWin.h.

The rest of the changes (in nsWindowsHooks.cpp and nsWindowsHooksUtil.cpp) is 
the same as what was added on the branch.
(Assignee)

Comment 8

16 years ago
Adding Blake to cc: list.  Review and super-review needed!

Comment 9

16 years ago
Comment on attachment 54285 [details] [diff] [review]
Patch for non-installer changes; mostly this is identical to the bug used to add this to the mozilla0.9.4 branch

sr=blake pending sean's review
Attachment #54285 - Flags: superreview+

Comment 10

16 years ago
VerifyRestrictedAccess() should be changed to something like, 
IsAccessRestricted().

I don't see a similar change to ns/xpfe/bootstrap as there is to 
mozilla/xpfe/bootstrap.  Is such a patch in a bugscape bug somewhere?

Adding Srilatha to the CC: list because she will need to do similar changes wrt 
the changes in the bootstrap dir for her SMAPI trunk merge.
(Assignee)

Comment 11

16 years ago
Created attachment 56333 [details] [diff] [review]
Patches to NS commercial tree version of xpfe/bootstrap
(Assignee)

Comment 12

16 years ago
I've renamed verifyRestrictedAccess to isAccessRestricted, as suggested.

I've also attached additional changes to files in the NS version of the
xpfe\bootstrap files (makefile.win and splash.rc).  I think I had emailed you
those, Sean (although I might have forgotten to include the makefile.win
changes).  Anyway, that's everything.

Comment 13

16 years ago
Comment on attachment 54285 [details] [diff] [review]
Patch for non-installer changes; mostly this is identical to the bug used to add this to the mozilla0.9.4 branch

r=ssu given law's latest comments.
Attachment #54285 - Flags: review+
(Assignee)

Comment 14

16 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.