For interlaced video clip, audio is only heard and video is not seen during playback

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: poojas, Unassigned)

Tracking

30 Branch
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:1.4+)

Details

(Whiteboard: [caf priority: p2][CR 672627])

(Reporter)

Description

4 years ago
While playing interlaced video clip on 8x10 tragets seen below OMX error:

E/OMX-VDEC-1080P(  227): ERROR: Sending OMX_EventError to Client
E/OMXCodec( 1135): [OMX.qcom.video.decoder.avc] ERROR(0x80001009, 0)

0x80001009 error corresponds to ERROR_BUFFER_TOO_SMALL [1]

Expected behavior:

If some video is not supported, it should not be enumerated at all instead of playing partially.
Can we avoid creating thumbnail for video clip if we get OMX error while loading?

[1] https://www.codeaurora.org/cgit/quic/la/platform/frameworks/av/tree/include/media/stagefright/MediaErrors.h?h=kk_3.5#n36

Updated

4 years ago
Whiteboard: [CR 672627] → [caf priority: p3][CR 672627]
(Reporter)

Updated

4 years ago
Blocks: 984663

Updated

4 years ago
Component: Gaia::Video → Video/Audio
Product: Firefox OS → Core
Version: unspecified → 30 Branch
Can we get an example test file demonstrating the problem here?

Updated

4 years ago
blocking-b2g: --- → 1.4?

Updated

4 years ago
Whiteboard: [caf priority: p3][CR 672627] → [caf priority: p2][CR 672627]

Updated

4 years ago
Flags: needinfo?(poojas)
Regression from 1.3. Issue seen when running 1.4 code.
Keywords: regression
We need more data here to conclude this is a regression (i.e. the test file with testing results showing this doesn't reproduce on 1.3).
Keywords: regression

Updated

4 years ago
Keywords: regression
blocking-b2g: 1.4? → 1.4+
Keywords: regression
(In reply to Jason Smith [:jsmith] from comment #1)
> Can we get an example test file demonstrating the problem here?

Yes, please. I can assign this one but need the file and a regression window.
Inder,

Please consider this a reminder for attaching the file. I know you've been meaning to do it but will help us carry on with our investigation.
Flags: needinfo?(ikumar)

Comment 6

4 years ago
Preeti -- can we get list of Moz folks (@mozilla.com) who we can email the video files to? Unfortunately can't attach the files to the bug as they are proprietary.
Flags: needinfo?(ikumar)
(In reply to Inder from comment #6)
> Preeti -- can we get list of Moz folks (@mozilla.com) who we can email the
> video files to? Unfortunately can't attach the files to the bug as they are
> proprietary.

Send it to me Inder. I'll distribute internally.
Prior to the fix for bug 869289, the video app did not show videos (like the test file) that fail to generate a thumbnail. It appears that we now explicitly allow H.264 files to enumerate in the video app even when we (might) not be able to play them back. 

Given the steps required to reproduce this (manually placing an unsupported MP4 video into the SD card,) I'm inclined to keep the fix for 869289 as it allows for more videos to be enumerated on devices that can play them back. 

I think this should be resolved as WONTFIX and I'm marking it as such. If you disagree, please comment with steps that a user can reproduce with normal usage. FWIW, the test file supplied doesn't play back on an iPhone 5 either.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(poojas) → needinfo?(gduan)
Resolution: --- → WONTFIX

Comment 9

4 years ago
(In reply to Jet Villegas (:jet) from comment #8)
> Prior to the fix for bug 869289, the video app did not show videos (like the
> test file) that fail to generate a thumbnail. It appears that we now
> explicitly allow H.264 files to enumerate in the video app even when we
> (might) not be able to play them back. 

Jet, I see bug 869289 skips only thumbnail generation error. We see below OMXCodec error with the specific clip shared with you. Is it possible to hide bad clips based on that omx error or you are seeing the below errors even with good H.264 files?

E/OMX-VDEC-1080P(  227): ERROR: Sending OMX_EventError to Client
E/OMXCodec( 1135): [OMX.qcom.video.decoder.avc] ERROR(0x80001009, 0)

0x80001009 error corresponds to ERROR_BUFFER_TOO_SMALL [1]
Flags: needinfo?(bugs)
The JS layer that enumerates videos and generates the thumbnails doesn't see low-level OMX errors like that one. In fact, they want to enumerate those videos because, on some hardware, these errors do occur during enumeration but the videos play back. I still think the steps to reproduce this bug don't warrant that kind of fix, especially if the risk is that users fail to see videos that do work even when errors are generated.
Flags: needinfo?(bugs)
Flags: needinfo?(gduan)
You need to log in before you can comment on or make changes to this bug.