Clicking Undo repeatidly when waiting for page to respond opens several new composer pages

VERIFIED INVALID

Status

SeaMonkey
Composer
VERIFIED INVALID
17 years ago
13 years ago

People

(Reporter: TucsonTester2, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build ID 
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.4) Gecko/20010924 Netscape6/6.2

Description:
When using the Undo option if you keep clicking undo when the page is processing
the undo action it opens new untitled composer pages.

Reproducible:Everytime

Steps to Reproduce
1.Open blank Composer
2.Insert 19 Images into the blank composer page
3.After Images are inserted, then insert a table 100x100
4.Once talbe has been inserted and page is responding normally again, select
edit>undo.
5.The page will seem to have stoped responding for a few seconds. While the page
is initiation the undo action click undo about 5 to 6 more times.
6.Notice once the page has performed the action and the composer is responding
again that there are about 5 new composer pages open

Actual Results:
By Clicking Undo repeatedly when the composer page is trying to process the undo
request, it glitches out and opens new untitled composer pages.

Expected Results:
Clicking undo repeatedly should actually keep performing the undo action by
removing some of the images you have inserted after removing the table

Comments:
Window ME and 2000 tested on. Windows 95 did not show the same results.

Comment 1

17 years ago
Works for me on NT4 with the next day's build:
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.4+) Gecko/20010925
Build ID 2001092503

It eventually undid the creation of the table, then processed the waiting
Ctrl+Z's as expected.

Boy, that table sure does take a heck of a long time at 100% CPU (PIII-600) to
create or destroy. And getting a response from 'view source' takes five minutes
or more ... the source is 414kB ...

Comment 2

16 years ago
It looks like in order to get this bug to happen you have to actually use the
Edit > Undo option from the toolbar.  That being said, I think what is happening
is if you just keep hitting Undo while the Edit menu is dropped down, it stores
the clicks, and applies them after the Edit menu goes away, thus making your
clicks actually be on the New button which was previously behind the Edit menu.
 But if you repeatedly click on Edit and then Undo while Composer is frozen, it
keeps undoing as would be expected.  

Therefore I am marking this bug INVALID.  If anyone disagree's with me, please
feel free to reopen this bug. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

16 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 4

15 years ago
reassign bugs in case they are later reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.